LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 10-26-2004, 10:28 PM   #1
XYNaPSE
LQ Newbie
 
Registered: Jul 2003
Posts: 23

Rep: Reputation: 15
Cannot Activate network device


Hello,

Im a serious Linux newb. Iv tried Redhat 7 and 9 a while ago and now I installed FC2 64 bit version. The problem I am having is after the installation I open up mozilla to see if I have iNet. I type in google address and cant find the server. So I try to configure the networking. I deleted the old network device in the netwrok configurations window because it wouldnt activate or do anything and re-detected it. I try to activate it and get this error.

Cannot activate Network device eth0
does not seem to be present
delaying initialization.

I go to the hardware tab and it says

Device eth0
IRQ unknown

During the installation I said yes to the firewall if that means anything. I tried looking for a program to configure the firewall but couldnt find anything. I have an OnBoard Lan. also sound doesnt work. Iv searched the forum and cant find anything.

Heres my hardware specs


AMD64 3000+
1 gig of ram

EPOx 8kda3j mobo
Onbboard 10/100 Ethernet
Onboard Sound

ATI Radeon 9800 pro
SATA 200gig Maxtor Diamond plus

Thanks in advance
 
Old 10-26-2004, 11:00 PM   #2
XYNaPSE
LQ Newbie
 
Registered: Jul 2003
Posts: 23

Original Poster
Rep: Reputation: 15
I also have a d-link router with cable access
 
Old 10-26-2004, 11:39 PM   #3
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
What's it look like when you type /sbin/ifconfig
 
Old 10-27-2004, 12:14 AM   #4
XYNaPSE
LQ Newbie
 
Registered: Jul 2003
Posts: 23

Original Poster
Rep: Reputation: 15
Link encap:Local Loopback
inet addr:127.0.0.1 Mask 255.0.0.0
inet6 addr: :: 1/128 Scope:Host
UP Loopback RUNNING MTU: 16436 Metric:1
RX packets: 1475 errors:0 dropped:0 overruns:0 frame:0
TX packets: 1475 errors:0 dropped:0 overruns:0 frame:0

Collisions: 0 txqueuelen: 0
RX bytes: 1405076 (1.3mb)
TX bytes: 1405076 (1.3mb)

I was also looking up some stuff on Fedora and ethernet problems and noticed that some people were having problems with the new kernel and installing the drivers for the Onboard nic. Sounds like the same problem im having not sure.

Last edited by XYNaPSE; 10-27-2004 at 12:19 AM.
 
Old 10-27-2004, 12:32 PM   #5
XYNaPSE
LQ Newbie
 
Registered: Jul 2003
Posts: 23

Original Poster
Rep: Reputation: 15
Anyone know what the problem is and how I can fix it?
 
Old 10-27-2004, 12:53 PM   #6
WhiteChedda
Member
 
Registered: Aug 2003
Location: Florida
Distribution: Mandrake 9.1 for now
Posts: 205

Rep: Reputation: 30
Quote:
Originally posted by XYNaPSE
Anyone know what the problem is and how I can fix it?

Looks like you need to load a module driver for the NIC.

try issueing the following commands,

modprove forcedeth
then
dhcpcd

then

ifconfig

If you see an eth0 card, you are in business.
 
Old 10-27-2004, 01:06 PM   #7
XYNaPSE
LQ Newbie
 
Registered: Jul 2003
Posts: 23

Original Poster
Rep: Reputation: 15
Thanks for the help. Am I supposed to type thosee comands in the terminal? I tried them in the terminal but the commands were not found. Sorry Im a newb.
 
Old 10-27-2004, 01:14 PM   #8
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Quote:
modprove forcedeth
then
dhcpcd
Just a little typo there. Try modprobe forcedeth

Yes you do type those commands in the terminal. Likely need to be root user first so type the command: su - then enter the root password.
 
Old 10-27-2004, 02:10 PM   #9
XYNaPSE
LQ Newbie
 
Registered: Jul 2003
Posts: 23

Original Poster
Rep: Reputation: 15
Ok same thing. I type su and password to get to admin and type in modprobe forcedeth and it says modprobe is not a command.
 
Old 10-27-2004, 02:16 PM   #10
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Try it with the full path : /sbin/modprobe forcedeth
 
Old 10-27-2004, 02:30 PM   #11
XYNaPSE
LQ Newbie
 
Registered: Jul 2003
Posts: 23

Original Poster
Rep: Reputation: 15
Ok. That time the /sbin/modprobe forcdeth command worked but the others did not. I tried /sbin/dhcpcd and dhcpcd. I also tried doing a search fo dhcpcd and couldnt find anything.
 
Old 10-27-2004, 02:50 PM   #12
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Try the command: service network restart and if that works ok, you should see something like Bringing up interface eth0 [ok] .
If that worked ok, then try to ping something on the net like
ping -c 3 yahoo.com
 
Old 10-27-2004, 05:29 PM   #13
XYNaPSE
LQ Newbie
 
Registered: Jul 2003
Posts: 23

Original Poster
Rep: Reputation: 15
ok.. that did not work. I did what you said and it did this

shutting down loopback interface [ok]
Setting network parameters [ok]
Bringing up loopback interface [ok]

Then I pinged yahoo.com and it said unknown host yahoo.com
 
Old 10-27-2004, 05:30 PM   #14
mermxx
Member
 
Registered: Apr 2004
Location: Wales
Distribution: rh9, winxp
Posts: 411

Rep: Reputation: 30
U can also try going into bios at start up and see if u have ur network card enabled/disabled and amend ( u will find this in Plug and Play for your mobo) it would seem to me that this is the problem if NIC and sound are both onboard and both are not working :-)
 
Old 10-27-2004, 05:33 PM   #15
XYNaPSE
LQ Newbie
 
Registered: Jul 2003
Posts: 23

Original Poster
Rep: Reputation: 15
I know its enabled cause im using the same computer to type this message. I am dual booting with WinXP and Fedora Core 2.

Last edited by XYNaPSE; 10-27-2004 at 05:45 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3c905C network card in docking station. Cannot activate network device eth0. pathelms Linux - Networking 4 04-12-2006 03:55 PM
Network card not working? Cannot activate network device eth0 lifeonitsown Linux - Networking 1 11-17-2005 07:30 AM
cannot activate network device oliwally Linux - Networking 7 07-26-2004 02:42 AM
Cannot activate network device faqs Linux - Networking 13 05-26-2004 10:45 PM
Can't activate network device ozstar Linux - Networking 15 11-02-2003 06:10 AM


All times are GMT -5. The time now is 02:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration