LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Cannot accss X Window (http://www.linuxquestions.org/questions/linux-newbie-8/cannot-accss-x-window-790122/)

jprathap 02-19-2010 01:14 AM

Cannot accss X Window
 
Hi all,

I am using fedora 10. When i connect it from other system ,I am not able to access the gui application like (kate,gedit,etc...) even though i connect ssh with X option.

ssh -X root@192.168.1.11

I am able to login with the system. But

It showing error
kate: cannot connect to X server localhost:10.0

Please Help me.

Thanks in advance

vinaytp 02-19-2010 01:24 AM

Dear jprathap,

Please make sure X11 forwarding is enabled in both client and server configuration files of ssh on both the machines.

In /etc/ssh/sshd_config
Code:

X11Forwarding yes
In /etc/ssh/ssh_config
Code:

ForwardX11 yes
Restart sshd daemon on both the machiens
Code:

# /sbin/services sshd restart

routers 02-19-2010 06:21 AM

also try this way
ssh -X root@192.168.1.11 /usr/bin/konqueror

JimBrewster 02-19-2010 06:25 AM

Before 'ssh -X' run 'xhost+[<remote host>] to give the remote machine access to your display.

ongte 02-19-2010 08:23 AM

I find using this easier:
Quote:

# ssh -Y root@192.168.1.11
It avoids the having to turn on forwarding all the time.

jprathap 02-21-2010 09:26 PM

Hi all...

I tried all the possible configurations as you mentioned. But i could not get what i expected.


My configuration is as follows
Quote:

# Accept locale-related environment variables
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
AcceptEnv LC_IDENTIFICATION LC_ALL
AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
X11Forwarding yes
X11DisplayOffset 10
X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
What would be the prob?

evo2 02-21-2010 09:38 PM

Quote:

Originally Posted by JimBrewster (Post 3869266)
Before 'ssh -X' run 'xhost+[<remote host>] to give the remote machine access to your display.

Running xhost+ is not needed if ssh is configured properly.
Additionally, it has serious security issues and so should be avoided.

Evo2.

evo2 02-21-2010 09:40 PM

Quote:

Originally Posted by jprathap (Post 3872047)
What would be the prob?

To help debug the problem please run ssh with the '-v' flag to get verbose output.

Evo2.

jprathap 02-26-2010 04:12 AM

Cannot Access X window In fedora
 
I tried all the possibility that you've mentioned. But I am getting the same error.
Plz help me

routers 02-26-2010 04:21 AM

why not you paste back the command you do then with the error msg you got here

i ask you to do this and show back the error include the command you do

ssh -X root@192.168.1.11 /usr/bin/konqueror

evo2 02-26-2010 04:26 AM

Quote:

Originally Posted by jprathap (Post 3877530)
I tried all the possibility that you've mentioned. But I am getting the same error.
Plz help me

To debug a problem you should try to get all the information you can. In this case that means running your ssh client with '-vvv' flag and reading the sshd server logs (if you have access to them). If the above does not provided the information allowing you to solve your problem, post the information to the forum where it may allow other people to understand/solve the problem.

Evo2.


All times are GMT -5. The time now is 01:24 PM.