LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2010, 05:51 AM   #1
casualzone
Member
 
Registered: Jan 2010
Posts: 189

Rep: Reputation: 15
Cannot access USB ntfs file system!


I have reinstalled my centOS linux in my laptop

I have installed ntfs-3g by
yum install fuse fuse-ntfs-3g
recommended from : http://wiki.centos.org/TipsAndTricks/NTFS

I have mount it to my window ntfs system and setup /etc/fstab
/dev/sda3 /mnt/win_c ntfs-3g auto 0 0

Now I am able to access window ntfs system.

HOWEVER, I could not access to USB NTFS system. May I know why?????
It gave me:
The volumn "Expansion Drive" uses the ntfs file system which is not supported by your system


The USB drive is FreeAgent (500G). I have partitioned it to 3 parts. 1 part is ntfs. The other two is ext3. I can access ext3 smoothly.


Linux circuit 2.6.18-164.el5 #1 SMP Thu Sep 3 03:28:30 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
 
Old 02-01-2010, 06:29 AM   #2
Web31337
Member
 
Registered: Sep 2009
Location: Russia
Distribution: Gentoo, LFS
Posts: 399
Blog Entries: 71

Rep: Reputation: 65
how did you try to mount it and which error message you got exactly?
are you sure it's NTFS? are you sure it's not corrupt?
you can also try use "ntfsfix" util to check the volume.

Last edited by Web31337; 02-01-2010 at 06:30 AM.
 
Old 02-01-2010, 06:38 AM   #3
casualzone
Member
 
Registered: Jan 2010
Posts: 189

Original Poster
Rep: Reputation: 15
It is not corrupted, bcos i could use it in window

It is USB drive, it supposedly auto mount to all USB drives. I got 3 partitions. 2 partition from ext3 can auto mount.
The other one is ntfs.. i got the error message

The volumn "Expansion Drive" uses the ntfs file system which is not supported by your system
 
Old 02-01-2010, 07:29 AM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
The "auto" in the options means that it will be mounted when you boot up. You don't want that. It will cause a failure to fully boot up if the drive isn't connected. Change it to noauto.

You also want to add other mount options. noauto,uid=<yourusername>,gid=<yourusergroup>,fmask=<permissions>,dmask=<permissions>,nls=utf8

The ntfs filesystem doesn't contain Linux uid & permissions, so you need to indicate the permissions of all of the files and all of the directories in the mount options. Also use the UUID or device path instead for the device. The next time you boot up or plug it in, it may have a different device. Also, /dev/sda3 indicates the first hard disk which will be the internal drive not your external one. You may have mounted the wrong partition.

example
ls /dev/disk/by-uuid/
...
lrwxrwxrwx 1 root root 10 2010-01-18 22:57 145266D35266B95E -> ../../sda2
...

UUID=145266D35266B95E /mnt/win_c ntfs-3g noauto,uid=czone,gid=czone,fmask=0117,dmask=0007,nls=utf8

There are other mount options you may want. See the manpages for mount, mount.ntfs and fstab for more details.
 
1 members found this post helpful.
Old 02-01-2010, 09:13 AM   #5
casualzone
Member
 
Registered: Jan 2010
Posts: 189

Original Poster
Rep: Reputation: 15
sorry for the confusion.

I am able to mount to internal partition with ntfs (sda3)(window). No problem.

The problem I have is I am not able to access USB ntfs partition.
Hope u got my message.
 
Old 02-01-2010, 09:33 AM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
I took you to mean that you were mounting it over the mount point that is normally used for your Windows partition.

Having the "auto" option for an internal NTFS filesystem is OK.
The ntfs-3g kernel module needs the fuse kernel module to work.
Run the command:
lsmod

Make sure that the fuse module is available and loaded.
> grep FUSE /boot/config-2.6.31.8-0.1-desktop
CONFIG_FUSE_FS=m

or

zcat /proc/config.gz | grep FUSE
CONFIG_FUSE_FS=m

lsmod | grep fuse
fuse 87984 7

Ntfs-3g is a userland module. The fuse kernel module is an interface for userland filesystem modules.

If it isn't loaded:
sudo /sbin/modprobe fuse
 
Old 02-01-2010, 08:58 PM   #7
casualzone
Member
 
Registered: Jan 2010
Posts: 189

Original Poster
Rep: Reputation: 15
I can access to ntfs partition (internal harddisk and same harddisk to linux) to window.
The mount point is
drwxrwxrwx 1 root root 12288 Jan 29 11:43 win_c
drwxrwxrwx 1 root root 8192 Jan 29 09:55 win_f

So no problem accessing this partitions since they are all internal harddisk.

/dev/sda3 on /mnt/win_c type fuseblk (rw,allow_other,blksize=4096)
/dev/sda5 on /mnt/win_f type fuseblk (rw,allow_other,blksize=4096)

------------------------------------------------
The problem I have is that I plug in my external USB (500GB in total but got 3 partitions. One to ntfs about 350G, one to ext3 about 100G, one to vfat 50G). The ext3 & vfat partitions can be automount and appeared the icons in my desktop. However the USB ntfs partition cannot...
It gave me:



Cannot mount Volumn
The volumn "Expansion Drive" uses the ntfs file system which is not supported by your system



I have installed fuse, ntfs-3g
--------------------------------------------
lsmod | grep fuse
fuse 83057 4



#grep FUSE /boot/config-2.6.18-164.el5
CONFIG_FUSE_FS=m
 
Old 02-01-2010, 09:39 PM   #8
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX, OS X
Posts: 567

Rep: Reputation: 57
I ahve the 250 version of the FreeAgent drives with 1 ntfs partition. It auto mounts when connected via usb.

If I run mount here is the output for that drive
Code:
/dev/sdc1 /media/FreeAgent\040Drive ntfs rw,nosuid,nodev,uhelper=hal,uid=1000,utf8 0 0
try mounting it with the filesystem type ntfs instead of ntfs-3g
 
Old 02-01-2010, 09:46 PM   #9
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Run "sudo tail -f /var/log/messages" in a terminal and then plug in the drive. It will tell you which device is found and whether it recognizes the partitions. If there is a problem with the device and it doesn't recognize the partitions, then that is a problem you need to address.

If it does recognize the NTFS partition, then you need to create a directory so you have somewhere to mount it.

You need to determine what the kernel does say about the ntfs partition. Please indicate which device node is assigned to it.
You can run "sudo file -s /dev/sdb3" to find out what filesystem is on it. Does file -s recognize the filesystem?
 
Old 03-11-2010, 08:49 PM   #10
casualzone
Member
 
Registered: Jan 2010
Posts: 189

Original Poster
Rep: Reputation: 15
HI all,

I come back to this problem again which previous unsolved. Before this, i was busy other stuff.

I try to mount manually my USB freeagent harddisk

#mount /dev/sdb1 freeagent
mount: unknown filesystem type 'ntfs'

Sound like I do not have ntfs filesystem support although i have install ntfs-3g.
May I know how could I install ntfs ??

#file -s /dev/sdb1 [USB external harddisk which is not able to mount]
/dev/sdb1: x86 boot sector, code offset 0x52, OEM-ID "NTFS ", sectors/cluster 8, reserved sectors 0, Media descriptor 0xf8, heads 255, hidden sectors 63, dos < 4.0 BootSector (0x80)

#file -s /dev/sda3 [internal harddisk installed with window, able to auto mount with ntfs-3g]
/dev/sda3: x86 boot sector, code offset 0x52, OEM-ID "NTFS ", sectors/cluster 8, reserved sectors 0, Media descriptor 0xf8, heads 255, hidden sectors 21133312, dos < 4.0 BootSector (0x80)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Write access to NTFS USB drive ekkins Linux - Newbie 5 07-16-2013 05:15 PM
how to access to ntfs file system ? ini_hendry Linux - Software 4 08-20-2007 12:05 PM
How to read .chm file in fedora, can't mount ntfs file system ishti_du Linux - Newbie 12 03-06-2007 04:27 AM
how to access ntfs partitions that do not have an operating system install on them niko_nightwind Linux - Newbie 13 01-16-2005 10:47 AM
ntfs file system nobu Linux - General 2 04-08-2004 01:04 AM


All times are GMT -5. The time now is 08:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration