LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-06-2003, 01:29 PM   #1
pfunck123
LQ Newbie
 
Registered: Feb 2003
Location: ill
Posts: 13

Rep: Reputation: 0
Angry cannot access ftp or internet


I just got through installing my redhat 8.0, during installation I chose medium for the security, and selected ftp, ssh, http. I enabled ftp, went in /etc/xinetd.d/vsftd and set the disable to=NO. Then I restarted xinetd service by typing /etc/initd.d/xinetd restart and restarted ok. Next step I made sure ftp was up by typing netstat -a | grep ftp, get listening. I also went in /etc/vsftd.conf and made sure local_enable=Yes & write_enable=yes. When I type ftp localhost, I am prompted for username type root, than password. I get an error 530 login incorrect. I even tried logging in and out, and have no problem logging in with the root id and password.


Now for internet, I provided the proxy address with port, i have done this quite a few time, any how internet won't work either. I can ping say www.yahoo.com, but can't go to the page. So my proxy settings are correct cause I can ping.

I am thinking that somewhere internal firewall is blocking all my access, can someone please shed some light on this issue.


Thanks in advance,
Pete
 
Old 11-06-2003, 03:52 PM   #2
dorian33
Member
 
Registered: Jan 2003
Location: Poland, Warsaw
Distribution: LFS, Gentoo
Posts: 591

Rep: Reputation: 32
1. Probably ftp needs separate username descriptions (I've never used vsftp)
2. Pinging and browsing has nothing in common (different potocols ICMP vs. TCP). So it can be a matter of proxy settings.
 
Old 11-06-2003, 04:15 PM   #3
pfunck123
LQ Newbie
 
Registered: Feb 2003
Location: ill
Posts: 13

Original Poster
Rep: Reputation: 0
I was able to figure it out, the root was blocked in a file called /etc/vsftpd.users and root was listed in it.
 
Old 11-06-2003, 04:30 PM   #4
dorian33
Member
 
Registered: Jan 2003
Location: Poland, Warsaw
Distribution: LFS, Gentoo
Posts: 591

Rep: Reputation: 32
And what about passwords file? I think (but never use vsftp!) it should be different one (not /etc/shadow). So you'll need to create it.
 
Old 11-06-2003, 05:52 PM   #5
markus1982
Senior Member
 
Registered: Aug 2002
Location: Stuttgart (Germany)
Distribution: Debian/GNU Linux
Posts: 1,467

Rep: Reputation: 46
root should never login in by ftp. ftp uses cleartext and if a system user logs in this DOES affect system security. you should run vsftpd with virtual users only.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ftp(through web site access to ftp server) kelper Linux - Software 4 07-03-2015 06:14 PM
vsftp - Can access FTP within office network BUT cant access via Internet! kokfei77 Red Hat 2 03-07-2012 08:24 PM
access to ftp from internet yucehan Linux - Networking 3 03-07-2005 03:09 PM
I lose ftp access when I disable shell access for user captainObvious Linux - General 3 11-13-2004 06:49 PM
Unable to access my ssh server and ftp server from the Internet, but smtp works foxone Linux - Networking 1 05-28-2004 06:17 PM


All times are GMT -5. The time now is 09:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration