LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-04-2004, 06:12 AM   #1
pafrica
Member
 
Registered: Aug 2004
Location: canada
Distribution: Slackware
Posts: 66

Rep: Reputation: 15
cannot access FAT32 partition


hi everyone,

i have a VFAT partition mounted on /fat-d at start-up. the problem is, i cant cd into /fat-d as a regular user unless i unmount it first then mount it again. so far, i have tried messing with the options in fstab, and i also tried changing directory permissions for /fat-d (the permissions always go back to 744 when i reboot).

this is what is in my fstab:
Code:
/dev/hda3        swap             swap        defaults         0   0
/dev/hda4        /                ext2        defaults         1   1
/dev/hda1        /fat-c           vfat        defaults,users   1   0
/dev/hda5        /fat-d           vfat        defaults,users,dmask=000,fmask=033   1   0
/dev/cdrom       /mnt/cdrom       iso9660     noauto,users,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,users     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
I dont know what else i can do.
 
Old 09-04-2004, 06:26 AM   #2
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
This is my entry in /etc/fstab
Code:
/dev/hda6 /mnt/windata vfat iocharset=iso8859-15,rw,umask=0 0 0
See if something like this helps.

Baldrick
 
Old 09-04-2004, 06:34 AM   #3
mungulish
Member
 
Registered: Aug 2004
Location: Serbia and Montenegro
Distribution: Debian, Ubuntu, OpenSUSE
Posts: 33

Rep: Reputation: 15
I would use umask instead of fmask and dmask, that should do the trick, but if it still doesn't work, try removing the default option and inserting what you need only. Search in the man pages for mount.

man mount
 
Old 09-04-2004, 03:43 PM   #4
pafrica
Member
 
Registered: Aug 2004
Location: canada
Distribution: Slackware
Posts: 66

Original Poster
Rep: Reputation: 15
i used the umask and iocharset options. it works like a charm now.
thank you both very much
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help with access to local FAT32 partition??? Lleb_KCir Linux - General 8 05-08-2005 06:09 PM
Access FAT32 Partition brig Linux - Software 3 04-02-2005 09:22 AM
Users can't access FAT32-Partition thorax Linux - Software 3 07-23-2004 02:32 PM
Access files on a fat32 partition? warrant6767 Linux - Hardware 2 06-30-2004 05:25 PM
How to access Windows FAT32 Partition ? d_kote23 Linux - Newbie 5 05-12-2004 06:18 AM


All times are GMT -5. The time now is 02:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration