LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-19-2009, 10:42 AM   #1
wombat7477
LQ Newbie
 
Registered: Jun 2009
Posts: 4

Rep: Reputation: 0
Cannot 'mount' while installing from live-cd


Hey...

I'm installing Gentoo from a live-CD. I have some experience with UNIX, but this is my first time w/ a fresh install. I've got my partitions created and file systems applied. However, when I try to mount them, I get:

mount: only root can do that

I'd assume that the install CD gives me superuser permissions. I can't exactly log in as root until I finish installing, right?

Where is my fail?

EDIT: I'm avoiding the installation GUI because I want the experience of installing from command line

Last edited by wombat7477; 06-19-2009 at 10:44 AM.
 
Old 06-19-2009, 10:59 AM   #2
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
Could you give the precise command that produces this error?
There's a thread from 2005 here http://www.linuxquestions.org/questi...-mount-288252/ that describes a similar problem. You might want to look at it.
 
Old 06-19-2009, 11:05 AM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,712
Blog Entries: 27

Rep: Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055
Hi,
Quote:
Originally Posted by wombat7477 View Post
Hey...
I'm installing Gentoo from a live-CD. I have some experience with UNIX, but this is my first time w/ a fresh install. I've got my partitions created and file systems applied. However, when I try to mount them, I get:

mount: only root can do that

I'd assume that the install CD gives me superuser permissions. I can't exactly log in as root until I finish installing, right?

Where is my fail?

EDIT: I'm avoiding the installation GUI because I want the experience of installing from command line
Welcome to LQ!

If you have the system installed then you should be able to login as root or via the 'su' command with the proper password.

I prefer Slackware as this provides me with a 'UNIX' experience. Some feel that 'BSD' is a better fit. Each to his own.

This link and others are available from 'Slackware-Links'. More than just SlackwareŽ links!
 
Old 06-19-2009, 11:08 AM   #4
wombat7477
LQ Newbie
 
Registered: Jun 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Uncle_Theodore View Post
Could you give the precise command that produces this error?
There's a thread from 2005 here http://www.linuxquestions.org/questi...-mount-288252/ that describes a similar problem. You might want to look at it.
Thanks UncleT,

I did read that thread, but I wasn't sure it would help me since this is a clean install over an old Windows machine.

The exact command was: mount /dev/sda3 /mnt/gentoo
 
Old 06-19-2009, 11:11 AM   #5
NeddySeagoon
Gentoo support team
 
Registered: May 2009
Location: 56N 3W
Distribution: Gentoo
Posts: 178

Rep: Reputation: 40
wombat7477,

Only root can make parttions and filesystems too.

When you say 'liveCD' do you min a minimal CD, which only gives you a root shell and the tools you need to install or do you mean the GUI Installer CD, which you are using to do a conventional stage3 install.
You get a root shell on that by opening an xterm and doing
Code:
sudo su -
 
Old 06-19-2009, 11:11 AM   #6
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
Quote:
Originally Posted by wombat7477 View Post
Thanks UncleT,

I did read that thread, but I wasn't sure it would help me since this is a clean install over an old Windows machine.

The exact command was: mount /dev/sda3 /mnt/gentoo
Yeah, in the thread I referred to, something was *already mounted* on /mnt/gentoo, but the mount command gave the wrong error message and complicated matters.
Are you sure that there's nothing mounted on /mnt/gentoo already? Run the
mount
command with no options to make sure.
 
Old 06-19-2009, 11:35 AM   #7
wombat7477
LQ Newbie
 
Registered: Jun 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Oh, I see what you mean, Uncle T. But there was not anything mounted on that path.

Neddy - I am using a live-cd that takes me to a GUI, so I'm assuming it's the 2nd of the two options. At any rate, your sudo suggestion was right on. I was able to mount the partitions that way.

But in my floundering, I ran across something else that is concerning me. I thought the problem was that I didn't take action when the 'login' screen, so I was automatically logged in as user 'gentoo'. I tried re-starting and logging in as 'root'. I have no idea what the password should be. I tried just hitting <enter> as the gentoo website suggested. I also tried 'root' and 'password'. I'm stumped, but I don't want to forge ahead when I may end up with no access to the root account
 
Old 06-19-2009, 11:37 AM   #8
wombat7477
LQ Newbie
 
Registered: Jun 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Nevermind, I was able to use passwd after using su to establish a new password. Thanks for all the replies!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to mount a LVM partition using a live cd brazilian_user Linux - General 4 06-16-2009 01:11 AM
How do I mount a USB key using a Live CD? jonrpick Linux - Software 2 03-18-2007 08:31 PM
linux-live cd unionfs fails to mount android6011 Linux - Software 1 10-23-2006 02:12 AM
How do I mount hda while using a Ubuntu Live CD? witiwap Linux - Newbie 10 10-22-2005 07:24 PM
Mount usb devices suse 9.2 live Nawas111 SUSE / openSUSE 1 05-30-2005 08:51 AM


All times are GMT -5. The time now is 09:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration