LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can someone tell me why my sound stopped working? (http://www.linuxquestions.org/questions/linux-newbie-8/can-someone-tell-me-why-my-sound-stopped-working-632605/)

BigOil 04-02-2008 11:43 PM

Can someone tell me why my sound stopped working?
 
using 7.10 Gusty Gibbon

Sound stopped working one day.

Read many posts here, downloaded various mixer utilities and I am sure all the volumes are up and not on mute.

Interesting, if I boot from the Linux DVD the sound works, so a guy at my office said it most likely is a volume setting that's off. How can a find out what to do?

Thanks

Jerre Cope 04-02-2008 11:59 PM

use dmesg | less and
lspci | less

on the live version and your installed version to confirm that you're installed version found the correct soundcard hardware.

It could be an renegade driver got installed and is blocking the original Ubuntu driver.

It could be that another program is hogging the sound card.

Try running mplayer ( or xine, or whatever) from a terminal window so you can see any errors that occur.

BigOil 04-04-2008 09:45 PM

Quote:

Originally Posted by Jerre Cope (Post 3108974)
use dmesg | less and
lspci | less

on the live version and your installed version to confirm that you're installed version found the correct soundcard hardware.

It could be an renegade driver got installed and is blocking the original Ubuntu driver.

It could be that another program is hogging the sound card.

Try running mplayer ( or xine, or whatever) from a terminal window so you can see any errors that occur.


DVD Version:

dmesg | less

[ 0.000000] Linux version 2.6.22-14-generic (buildd@palmer) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 SMP Sun Oct 14 23:05:12 GMT 2007 (Ubuntu 2.6.22-14.46-generic)
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000003ff70000 (usable)
[ 0.000000] BIOS-e820: 000000003ff70000 - 000000003ff72000 (ACPI NVS)
[ 0.000000] BIOS-e820: 000000003ff72000 - 000000003ff93000 (ACPI data)
[ 0.000000] BIOS-e820: 000000003ff93000 - 0000000040000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
[ 0.000000] BIOS-e820: 00000000fecf0000 - 00000000fecf1000 (reserved)
[ 0.000000] BIOS-e820: 00000000fed20000 - 00000000fed90000 (reserved)
[ 0.000000] BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
[ 0.000000] BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)
[ 0.000000] 127MB HIGHMEM available.
[ 0.000000] 896MB LOWMEM available.
[ 0.000000] found SMP MP-table at 000fe710
[ 0.000000] Entering add_active_range(0, 0, 262000) 0 entries of 256 used
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 4096
[ 0.000000] Normal 4096 -> 229376
[ 0.000000] HighMem 229376 -> 262000


lspci | less

00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

BigOil 04-04-2008 09:57 PM

From Live Version

lspci | less


00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)


dmesg | less


[ 0.000000] Linux version 2.6.22-14-generic (buildd@palmer) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 SMP Sun Oct 14 23:05:12 GMT 2007 (Ubuntu 2.6.22-14.46-generic)
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000003ff70000 (usable)
[ 0.000000] BIOS-e820: 000000003ff70000 - 000000003ff72000 (ACPI NVS)
[ 0.000000] BIOS-e820: 000000003ff72000 - 000000003ff93000 (ACPI data)
[ 0.000000] BIOS-e820: 000000003ff93000 - 0000000040000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
[ 0.000000] BIOS-e820: 00000000fecf0000 - 00000000fecf1000 (reserved)
[ 0.000000] BIOS-e820: 00000000fed20000 - 00000000fed90000 (reserved)
[ 0.000000] BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
[ 0.000000] BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)
[ 0.000000] 127MB HIGHMEM available.
[ 0.000000] 896MB LOWMEM available.
[ 0.000000] found SMP MP-table at 000fe710
[ 0.000000] Entering add_active_range(0, 0, 262000) 0 entries of 256 used
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 4096
[ 0.000000] Normal 4096 -> 229376
[ 0.000000] HighMem 229376 -> 262000





So I did as requested and here are the results above. The crazy thing is that when I got back to the live version of Kubuntu to do this last set of commands, THE SOUND WORKED! What the heck is going on?

Since I am new to this can someone please tell me what I should look for in the above set of characters if the sound stops working again?

Thanks.

BigOil 04-04-2008 10:13 PM

Okay, I rebooted the system and the sound stopped working again. Here are the results from those commands again:

Live Version

[ 0.000000] Linux version 2.6.22-14-generic (buildd@palmer) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 SMP Sun Oct 14 23:05:12 GMT 2007 (Ubuntu 2.6.22-14.46-generic)
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000003ff70000 (usable)
[ 0.000000] BIOS-e820: 000000003ff70000 - 000000003ff72000 (ACPI NVS)
[ 0.000000] BIOS-e820: 000000003ff72000 - 000000003ff93000 (ACPI data)
[ 0.000000] BIOS-e820: 000000003ff93000 - 0000000040000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
[ 0.000000] BIOS-e820: 00000000fecf0000 - 00000000fecf1000 (reserved)
[ 0.000000] BIOS-e820: 00000000fed20000 - 00000000fed90000 (reserved)
[ 0.000000] BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
[ 0.000000] BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)
[ 0.000000] 127MB HIGHMEM available.
[ 0.000000] 896MB LOWMEM available.
[ 0.000000] found SMP MP-table at 000fe710
[ 0.000000] Entering add_active_range(0, 0, 262000) 0 entries of 256 used
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 4096
[ 0.000000] Normal 4096 -> 229376
[ 0.000000] HighMem 229376 -> 262000


00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

I really don't know what I am looking at so would appreciate some help.

Jerre Cope 04-05-2008 12:13 AM

0:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

Shows me you have a nice vanilla Audio Card which means it shouldn't be an oddball driver problem.

Have your tried this from the ubuntu community form?

http://ubuntuforums.org/showthread.php?t=205449

BigOil 04-05-2008 12:26 AM

Quote:

Originally Posted by Jerre Cope (Post 3111287)
0:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

Shows me you have a nice vanilla Audio Card which means it shouldn't be an oddball driver problem.

Have your tried this from the ubuntu community form?

http://ubuntuforums.org/showthread.php?t=205449

THanks. I will try those steps tomorrow.

BigOil 04-06-2008 03:36 PM

Quote:

Originally Posted by Jerre Cope (Post 3111287)
0:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

Shows me you have a nice vanilla Audio Card which means it shouldn't be an oddball driver problem.

Have your tried this from the ubuntu community form?

http://ubuntuforums.org/showthread.php?t=205449



Okay, problem solved. http://ubuntuforums.org/showthread.php?t=205449 helped me solve it with the uninstall and reinstall of the alsa packages (or what ever you call them).

Thanks a bunch.

I'm quickly learning that even though Kubuntu is a pretty slick looking Linux OS, it is SO NOT READY for prime time with the masses who aren't willing to troubleshoot extensively to simple stuff like getting the sound working.

Nightcrawlers 05-17-2008 03:42 PM

8.04 Sound Problem New Install
 
I am dual booting a new install of Kubuntu 8.04; from the first reboot after install, I had no sound. In XP my sound works fine (Soundblaster Audigy ZS) but in Kubuntu no joy.

I have tried other versions of Kubuntu and never had a sound problem ever. The only difference now is that I am running an AMD 64 3800+ cpu, and although the m/b has onboard sound, I am using the soundblaster card. I must note here that I am also running an PNY Nvidia 9600 Gt and it shows up in sounds as a sound card(?); I manually choose the Audigy but still no sound.

Also, when I open Amarok I get an error "Xine was unable to initialize any sound drivers". Help me out here, I am stumped. Thanks!


All times are GMT -5. The time now is 09:04 AM.