LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-15-2006, 11:21 AM   #1
Rollotamasi
Member
 
Registered: Jun 2006
Posts: 39

Rep: Reputation: 15
Can see but not access a partiton


Hello all. I am having a bit of a partition issue. I have 39g partition formated in fat32. My theory was that it would be the main partition that windows and linux both write to. Well, my XP can see/write/read to it fine however my linux is another store. Im running unbuntu by the way. In my browser I can "see" the partition but I can actully access is. I get a "Unable to mount the selected volume" error. Under more detials it says "error:device dev/hda2 is not removeable." and the line below says "Could not execute pmount"

What do I need to do to this pasrtition so that both my XP and munbunto can access it?

Thank all!
 
Old 06-15-2006, 01:09 PM   #2
NoStop
Member
 
Registered: Feb 2005
Location: Canada
Distribution: Debian Etch - Enlightenment E17
Posts: 116

Rep: Reputation: 15
Quote:
Originally Posted by Rollotamasi
Hello all. I am having a bit of a partition issue. I have 39g partition formated in fat32. My theory was that it would be the main partition that windows and linux both write to. Well, my XP can see/write/read to it fine however my linux is another store. Im running unbuntu by the way. In my browser I can "see" the partition but I can actully access is. I get a "Unable to mount the selected volume" error. Under more detials it says "error:device dev/hda2 is not removeable." and the line below says "Could not execute pmount"

What do I need to do to this pasrtition so that both my XP and munbunto can access it?

Thank all!
Post the contents of your /etc/fstab file here.
 
Old 06-15-2006, 04:31 PM   #3
Rollotamasi
Member
 
Registered: Jun 2006
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by NoStop
Post the contents of your /etc/fstab file here.
I get a access denied error when I try to run that command and I dont know the way to login to the administrator mode
 
Old 06-15-2006, 06:25 PM   #4
petern2
Member
 
Registered: Sep 2005
Location: Melbourne, Australia
Distribution: XP, Windows 7, PCLinuxOS
Posts: 41

Rep: Reputation: 15
You don't 'run the command' /etc/fstab, you have to access the contents of the file /etc/fstab by opening a terminal and typing:

more -l /etc/fstab

this will show you what's in the file.

To log in as administrator, type: su
hit return then type in your root password, the one you set during the installation. You can then use an editor such as vi to change the contents of the file.

You should also read the thread 'fat32 partition', started by marjan. This explains how to get access to the partition.
I assume this partition was created after you installed Ubuntu, so you have to tell Ubuntu that it's there.

Another thing, could you run a spell check on your posts?
 
Old 06-15-2006, 08:14 PM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
In Ubuntu, root access is OFF by default. To run administrator commands, you have two options:

1. use sudo---eg "sudo fdisk -l" to see all your partitions

2. create the root user:
"sudo passwd root"
enter your user password at the prompt, then the new root password at the next
now: "su" to become root

as root, you can run fdisk to see your partitions, and "mount" to actually mount (connect) one to the filesystem
 
Old 06-16-2006, 02:32 AM   #6
Cain_vX
LQ Newbie
 
Registered: Jan 2006
Location: Mexico
Distribution: Debian testing
Posts: 8

Rep: Reputation: 0
maybe umask?

Well, I think your best bet is to read the fstab and then surf the web for solutions or post it here and see if anyone could help. From my point of view and from personal experience, I suggest you to try appending umask=000 or rw at the beginning of the 3rd column of the entry you are supposed to modify.

It may look like this
Code:
/dev/hdb1 /home/foo vfat umask=000,auto,user 0 0
or
Code:
/dev/hdb1 /home/foo vfat rw,auto,user 0 0
The umask argument is used to "mask" the file permissions of the files and directories under that directory (at least is what I have understood so far). You may learn a lot if you search for this over the internet. What I have learned is that the argument passed is the complement (in octal) of the desired permission you want in that partition, ie: if you want it to be 777 you use 000.

I used the solution above, it worked at the first try. In the "rw" case (which I haven't tried yet) I am not sure if the permissions of the existent files are preserved, anyway, it's your choice.

Check this out and see what you can get:
http://www.tuxfiles.org/linuxhelp/fstab.html
Or read de man for fstab and mound if you wish...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Partiton Problem Kylindra Linux - Hardware 3 06-15-2006 06:32 PM
fat32 partiton marjan Linux - Hardware 7 06-15-2006 06:03 PM
Partiton westcor Linux - General 5 12-01-2005 03:01 AM
fat32 partiton cant see it einstien Linux - Hardware 2 07-07-2005 03:40 PM
Partiton names gag Linux - Newbie 3 10-19-2003 06:42 AM


All times are GMT -5. The time now is 10:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration