LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-21-2006, 02:44 PM   #1
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Rep: Reputation: 31
Can not write with greek fonts


Hey there!!!
I am newbie to Linux(BackTrack) and i recently installed OpenOffice 2.0
I can read a doc consisting of Greek characters but I can not write with them
Any ideas?

Thanks for your time
 
Old 11-21-2006, 03:45 PM   #2
Panagiotis_IOA
Member
 
Registered: Jan 2006
Location: Hellas, Europe
Distribution: Slackware 12
Posts: 238

Rep: Reputation: 32
Hi Manolakis (I have to write in English ).
I suppose you have already import the Greek keyboard. If you have done so, you need to set you locale to the following:

Code:
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
That was how my problem with Greek in OpenOffice was solved.
 
Old 11-21-2006, 03:57 PM   #3
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
Can not write with greek fonts

Hey there!!!
Thanks really much for your reply
To be honest i am quite newbie to Linux and i dont think that i have installed the Greek keyboard. I would be really obliged if you show me the way.

Thanks for your time
 
Old 11-21-2006, 05:05 PM   #4
Panagiotis_IOA
Member
 
Registered: Jan 2006
Location: Hellas, Europe
Distribution: Slackware 12
Posts: 238

Rep: Reputation: 32
You should tell me first which distribution you are using
 
Old 11-21-2006, 08:59 PM   #5
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
I am using BackTrack.
 
Old 11-21-2006, 10:00 PM   #6
Panagiotis_IOA
Member
 
Registered: Jan 2006
Location: Hellas, Europe
Distribution: Slackware 12
Posts: 238

Rep: Reputation: 32
Hm... It's the first time I heard of it but I noticed that is Slackware based so the configuration files should be the same as Slackware.
You have to open the /etc/X11/xorg.conf file with a text editor and add or modify these lines to the "InputDevice" Section of the keyboard:

Code:
    Option      "XkbModel" "pc105"
    Option      "XkbLayout" "us+el"
    Option      "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
My configuration is like this:

Code:
Section "InputDevice"

    Identifier  "Keyboard1"
    Driver      "kbd"
    Option      "XkbModel" "pc105"
    Option      "XkbLayout" "us+el"
    Option      "XkbOptions" "grp:alt_shift_toggle,grp_led:caps"
"alt_shift" indicates the combination of keys used to change from one language to another while "scroll" indicates which light of the keyboard you want to lights up when you switch into Greek.
After this you need to add the locale I gave you on my previous post in the end of the /etc/profile file.

Last edited by Panagiotis_IOA; 11-21-2006 at 10:01 PM.
 
Old 11-22-2006, 11:20 AM   #7
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
Hey again
I want to thank you for your help
I will try this and i hope it will work

Thanks again
 
Old 11-22-2006, 06:13 PM   #8
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
Same problem with Greek fonts

Hey again!!!
Well! I did all of what you said but didnt work
I noticed also that the LC_ALL in the locale is null!(Have a look on what you posted)
Is it something that you forgot to write down or it should be like that.
It will be grateful if you could help

Thanks for your time
 
Old 11-22-2006, 07:00 PM   #9
Panagiotis_IOA
Member
 
Registered: Jan 2006
Location: Hellas, Europe
Distribution: Slackware 12
Posts: 238

Rep: Reputation: 32
Hm... Let's take it from the beginning.
First you edit your xorg.conf file. Restart the X and then checkif you can switch from English to Greek and test writing to Firefox and to a text editor. Then try at OpenOffice. If this is not working then you have to set the new locale and restart X again. Have you done all these?
No, I didn't forget anything to the locale I gave you.
 
Old 11-23-2006, 01:18 PM   #10
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
Problem with Greek fonts

Thanks again for your reply.
I did everything as you said.
Will it be helpful if i say that when i try to change from US to Greek at the bottom rigth corner (on the taskbar) instead of Greek i get err (which probably indicates error).

Thanks again for your time
 
Old 11-23-2006, 01:26 PM   #11
Panagiotis_IOA
Member
 
Registered: Jan 2006
Location: Hellas, Europe
Distribution: Slackware 12
Posts: 238

Rep: Reputation: 32
"err" should indicates error. How did you got Greek option there? After the changes I told you?
 
Old 11-24-2006, 12:06 PM   #12
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
No. It was already there (in KDE keyboard tool).
 
Old 11-25-2006, 09:59 AM   #13
Panagiotis_IOA
Member
 
Registered: Jan 2006
Location: Hellas, Europe
Distribution: Slackware 12
Posts: 238

Rep: Reputation: 32
I'm sorry but I can't think of anything else. Maybe you should try to find some help at www.linux.gr or www.hellug.gr
 
Old 11-26-2006, 05:51 AM   #14
gstath
LQ Newbie
 
Registered: Sep 2004
Location: Athens, Greece
Distribution: Slackware 10.2
Posts: 14
Blog Entries: 1

Rep: Reputation: 0
Supposing that you can already type in Greek and your only problem is that the language KDE icon is not working properly, I'd suggest the following workaround:

Disable the KDE-build-in language indicator and download Leonid Zeitlin's kkbswitch. It is light and works great on slack. Since your distro is slack based it would probably work without issues.
 
Old 11-26-2006, 06:50 PM   #15
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
Hey again
Many thanks for your reply
I am quite newbie to Linux and i dont know how I disable the KDE-build-in language indicator.
Could you please show me?

Thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Greek fonts in OpenOffice 1.9.x ichrispa Linux - Software 1 05-13-2006 08:46 PM
Greek fonts 3p0ch Linux - General 1 07-06-2005 10:31 AM
Install Greek Fonts thothoneos Linux - Newbie 2 03-10-2005 03:40 PM
how to add Greek, German fonts? kpachopoulos Slackware 3 09-14-2004 02:22 AM
Download and install Greek fonts on RH 9 tolis Linux - Software 0 11-22-2003 09:02 PM


All times are GMT -5. The time now is 03:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration