LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-19-2008, 12:08 PM   #1
Close_the_Windows
LQ Newbie
 
Registered: Aug 2008
Distribution: Fedora 14
Posts: 10

Rep: Reputation: 0
Can not Update to Kernel 2.6.9 or any Other I have Tried


I have a Belkin Wireless Adapter for my 6 month old [if that] PC. I go to install the WPA addon to ndiswrapper successfully, but as for the program ndiswrapper, I have a Kernel tree problem with no Kbuild of any sort that it asks for. I tried to update the Kernel countless times hoping to produce a kernel tree, but nothing has worked. I have never made it past 'make configx' or any other make for that matter. Has any body ever had that problem, if so please respond.


Thank You,
Close_the_Windows
 
Old 08-19-2008, 08:06 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 208Reputation: 208Reputation: 208
Do you mean you need the kernel-source to compile against?
 
Old 08-19-2008, 08:47 PM   #3
Close_the_Windows
LQ Newbie
 
Registered: Aug 2008
Distribution: Fedora 14
Posts: 10

Original Poster
Rep: Reputation: 0
Question ?????

Dear Replier,

I must apologize for the informality of my question and the vagueness. I have currently Fedora 8 installed on my PC and the first task I set myself to doing was connecting to my father's WPA/TKIP security enabled network, and found that my Belkin Chip with the chipset bcmlw15 was not supported because of the selfish company who makes them, so after some searching, I found ndiswrapper and the WPA package that was for the WPA security enabled networks. The opitional package's make process whent succesfuly, but when I ran [for ndiswrapper] the first make commands I got the ***Kernel Tree Not Found***/n Please set Kbuild to the kernel... or something close to that anyhow. So, I figured to do as it said, but there was no kbuild, only kbuildsyscoca which did nothing...helpful anyhow... so I decided to update the kernel version to 2.6.9[.] Well, needless to say that that did not work either... so here I am; stuck and I was wondering if you or anybody could help.


Thank You,
Close_the_Windows


Postal Script:

I am completely new to linux and its technicalities, I know basic Gnome and KDE navigation and some Terminal commands, but beyond that I am void.
 
Old 08-19-2008, 09:04 PM   #4
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You probably need the kernel-devel package (yum install kernel-devel), but failing that, try kernel-sources
 
Old 08-19-2008, 09:34 PM   #5
Close_the_Windows
LQ Newbie
 
Registered: Aug 2008
Distribution: Fedora 14
Posts: 10

Original Poster
Rep: Reputation: 0
Oh

Dear Replier,

I did not see that in the installation instructions, and I do not know how to use yum, rpm, or all that jazz. I am drawing a blank.

Thank You,
Close_the_Windows
 
Old 08-19-2008, 09:50 PM   #6
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 208Reputation: 208Reputation: 208
Quote:
Originally Posted by Close_the_Windows View Post
Dear Replier,

I did not see that in the installation instructions, and I do not know how to use yum, rpm, or all that jazz. I am drawing a blank.

Thank You,
Close_the_Windows
Basically you type yum install kernel-devel on the commandline. You need to start a terminal (console) session in order to type it in.

See here for an explaination and usage of YUM: http://fedoraforum.org/forum/showthread.php?t=25880
 
Old 08-19-2008, 09:57 PM   #7
Close_the_Windows
LQ Newbie
 
Registered: Aug 2008
Distribution: Fedora 14
Posts: 10

Original Poster
Rep: Reputation: 0
Question Okay

Dear Replier,

Okay, but yum granted, what dose this have to do with running the makefile of ndiswrapper or the error message I keep getting?
 
Old 08-19-2008, 11:43 PM   #8
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 5, Linux Lite
Posts: 4,312

Rep: Reputation: 208Reputation: 208Reputation: 208
It's not about yum, that is only 1 method of installing apps. The makefile is complaining because it cannot find the library files it needs to successfully compile. You either need to add the kernel-devel (devel = development) files or the kernel-sources (the source files for the kernel) in order for the program to successfully compile and produce the required module.

Read some of this post: http://fedoraforum.org/forum/archive...p/t-29659.html

Last edited by {BBI}Nexus{BBI}; 08-19-2008 at 11:45 PM.
 
Old 08-20-2008, 10:59 AM   #9
Close_the_Windows
LQ Newbie
 
Registered: Aug 2008
Distribution: Fedora 14
Posts: 10

Original Poster
Rep: Reputation: 0
Dear Replier,

So all I have to do is install livna and ndiswrapper will install like magic; I do not need to update my kernel and build a source tree in order to satisfy it?? I will try Livna and see if it works.


Thank You
Close_the_Windows
 
Old 08-20-2008, 11:37 AM   #10
Close_the_Windows
LQ Newbie
 
Registered: Aug 2008
Distribution: Fedora 14
Posts: 10

Original Poster
Rep: Reputation: 0
Exclamation Did not Work

Dear Replier,

I downloaded Livna like the other post said, but all the commands that they gave me did not work. I have it here:

Quote:
[root@Purple ~]# kernel-devel
bash: kernel-devel: command not found
[root@Purple ~]# yum --enablerepo=livna-stable install ndiswrapper kernel-modulendiswrapper-$(
uname -r)
Error getting repository data for livna-stable, repository not found
[root@Purple ~]# yum -y install kmod-ndiswrapper
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mir...t?repo=fedora-
8&arch=i386 error was
[Errno 4] IOError: <urlopen error (-3, 'Temporary failure in name resolution')>
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please
verify its path and try again
[root@Purple ~]# yum --enablerepo=livna-stable install ndiswrapper kernel-modulendiswrapper-$(
uname -r)
Error getting repository data for livna-stable, repository not found
[root@Purple ~]# cd /root/ndiswrapper
bash: cd: /root/ndiswrapper: No such file or directory
[root@Purple ~]# cd /root/ndiswrapper-1.53
[root@Purple ndiswrapper-1.53]# make
make -C driver
make[1]: Entering directory `/root/ndiswrapper-1.53/driver'
Makefile:23: *** Kernel tree not found - please set KBUILD to configured kernel. Stop.
make[1]: Leaving directory `/root/ndiswrapper-1.53/driver'
make: *** [all] Error 2
[root@Purple ndiswrapper-1.53]#
I am STUCK and CONFUSED!!!! Please Help


Thank You,
Close_the_Windows

Last edited by Close_the_Windows; 08-20-2008 at 11:38 AM. Reason: Junk Lines
 
Old 08-21-2008, 10:02 AM   #11
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
Are you quite sure, you mean 2.6.9 ??
Fedora 3 used 2.6.9

Fedora 8 uses 2.6.23.1-42 (at least)
(2.6.23.1-42 is on my install DVD)

Regards
 
Old 10-31-2008, 09:26 PM   #12
Close_the_Windows
LQ Newbie
 
Registered: Aug 2008
Distribution: Fedora 14
Posts: 10

Original Poster
Rep: Reputation: 0
Smile Problem solved

sorry for the delay in response see i have been working on the
problem and solved it.
here is how:
  1. ndiswrapper was not needed
  2. i downloaded a file called broadcom-wl-4.150.10.5.tar.bz2
  3. i unzipped it
  4. i cd'd into the folder that was extracted then into the drivers folder
  5. i opened konsole and typed bcm43xx-fwcutter (file that supported my card)
  6. added my card to the networkmanager
  7. told it not to start it on startup and to control it
  8. then i restarted my computer and logged into the network
i also now am using fedora 9 now and it is stable for the first time!


thank you for all of your help
close the windows
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
update -u Did Not Update Kernel Packages cmnorton Red Hat 1 03-15-2008 10:09 AM
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Software 4 05-06-2007 11:27 AM
YaST Online Update(YOU) Kernel Update? batorma Linux - Newbie 9 10-30-2005 04:17 AM
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Distributions 0 10-13-2004 12:01 PM
KDE update and RH 9.0 Kernel update massacre Linux - Newbie 1 02-02-2004 07:13 PM


All times are GMT -5. The time now is 03:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration