LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-20-2012, 01:20 PM   #1
mmorton89
LQ Newbie
 
Registered: Jul 2012
Location: Columbus, OH
Distribution: Centos 6.3
Posts: 20

Rep: Reputation: Disabled
can not install anything with yum


This is the error i get when i try to update or install anything.


[root@server ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist http://mirrorlist.centos.org/?releas...x86_64&repo=os error was
14: PYCURL ERROR 6 - ""
Error: Cannot find a valid baseurl for repo: base
[root@server ~]#
 
Old 07-20-2012, 01:57 PM   #2
lithos
Senior Member
 
Registered: Jan 2010
Location: SI : 45.9531, 15.4894
Distribution: CentOS, OpenNA/Trustix, testing desktop openSuse 12.1 /Cinnamon/KDE4.8
Posts: 1,144

Rep: Reputation: 217Reputation: 217Reputation: 217
it's hard to say, but try to open the
[code]http://mirrorlist.centos.org/?releas...x86_64&repo=os where the list of repos is located,
it should open
Code:
http://mirror.lihnidos.org/CentOS/6.3/os/x86_64/
http://mirrors.paknet.org/CentOS/6.3/os/x86_64/
http://ftp.arnes.si/pub/mirrors/centos.org/6.3/os/x86_64/
http://mirrors.prometeus.net/centos/6.3/os/x86_64/
http://centos.fastbull.org/centos/6.3/os/x86_64/
http://mi.mirror.garr.it/mirrors/CentOS/6.3/os/x86_64/
http://mirror.crazynetwork.it/centos/6.3/os/x86_64/
http://gd.tuwien.ac.at/opsys/linux/centos/6.3/os/x86_64/
http://centos.mirroraustria.at/6.3/os/x86_64/
http://centos.digitalnova.at/6.3/os/x86_64/
http://mirror.centos.com.ba/6.3/os/x86_64/
http://ftp.freepark.org/pub/linux/distributions/centos/6.3/os/x86_64/
if not, you have a network problem (not connected to internet ?) not yum problem.
 
Old 07-20-2012, 04:59 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,090

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
I am guessing that this is the new CentOS 6.3 ???????
it would be helpful if you stated WHAT operating system this is AND it's version

the cent "fast-mirror" plugin is known to sometimes cause problems

but as "lithos" stated this might be a network issue

it you are behind a router then yum needs to be set up
this is in the cent install documentation
 
Old 07-22-2012, 06:04 AM   #4
mmorton89
LQ Newbie
 
Registered: Jul 2012
Location: Columbus, OH
Distribution: Centos 6.3
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by lithos View Post
it's hard to say, but try to open the
[code]http://mirrorlist.centos.org/?releas...x86_64&repo=os where the list of repos is located,
it should open
Code:
http://mirror.lihnidos.org/CentOS/6.3/os/x86_64/
http://mirrors.paknet.org/CentOS/6.3/os/x86_64/
http://ftp.arnes.si/pub/mirrors/centos.org/6.3/os/x86_64/
http://mirrors.prometeus.net/centos/6.3/os/x86_64/
http://centos.fastbull.org/centos/6.3/os/x86_64/
http://mi.mirror.garr.it/mirrors/CentOS/6.3/os/x86_64/
http://mirror.crazynetwork.it/centos/6.3/os/x86_64/
http://gd.tuwien.ac.at/opsys/linux/centos/6.3/os/x86_64/
http://centos.mirroraustria.at/6.3/os/x86_64/
http://centos.digitalnova.at/6.3/os/x86_64/
http://mirror.centos.com.ba/6.3/os/x86_64/
http://ftp.freepark.org/pub/linux/distributions/centos/6.3/os/x86_64/
if not, you have a network problem (not connected to internet ?) not yum problem.
Yes so I figured out what was wrong it was a network problem but this brings up a new problem. I do not know anything about DNS and networking but I just got this server a few days ago and my /etc/resolv.conf was blank when I got my server. I don't know if this is something the server provider was supposed to setup or if I am supposed to provide my own name servers? but as soon as I changed it to 8.8.8.8 the internet works. Is this the right way or should I contact my server service provider?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant install Virtual machine in CentOS 6 Cannot find package qemu-kvm in yum install linux_rhca Linux - Newbie 4 10-19-2011 05:37 AM
Getting all RPMs needed by 'yum install pkg1 pkg2 pkg3' to install on offline system veeruk101 Linux - Newbie 10 06-14-2011 01:51 AM
yum install flash ... yum: command not found ... which yum ... /usr/bin/yum tg3793 Fedora 8 04-13-2011 11:25 AM
yum install PHP: yum tries to install duplicate httpd beebopbogo Linux - Software 1 05-26-2009 02:08 AM
Query re: order of yum update and yum install jajtiii Linux - General 0 12-12-2005 12:48 PM


All times are GMT -5. The time now is 10:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration