LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-06-2003, 02:21 PM   #1
victorc
LQ Newbie
 
Registered: May 2003
Posts: 5

Rep: Reputation: 0
Question Can not connect to my Samba Server


Hi all,

I installed a Mandrake linux server with Samba 2.2.3a. I created a user in linux and added this user in the samba users file. SMB and UMB are running.

The smb.conf I use is:

[global]
workgroup = myDomain
server string = Samba Server %v
#server string = Samba Server
browseable = yes
load printers = no
log file = /var/log/samba/log.%m
max log size = 100
lock directory = /var/lock/samba
locking = no
strict locking = no
share modes = yes
security = user
null passwords = yes
socket options = TCP_NODELAY
# Allows the Samba server to become a domain controller
os level = 33
domain master = yes
# Facilitates the long names recognition
preserve case = no
short preserve case = no
character set = iso8859-1
[homes]
comment = Home Directories
preexec = /bin/sh -c 'echo /usr/bin/smbclient -M %m -I %I'&
browseable = yes
readonfiltered= no
writable = yes
create mode = 0750
public = yes
["public"]
comment = "Public"
path = /home/ftp/
browseable = yes
hide dot files = yes
readonfiltered= no
public = yes
pritable = yes
create mode = 0775
printable = no


I can't logon on this domain with my Windows 98 computer. I see this server in my explorer, but can not connect to it. I can ping my server. What is wrong, I really don't know what to do?

Regards,

Victor
 
Old 05-06-2003, 03:10 PM   #2
dorian33
Member
 
Registered: Jan 2003
Location: Poland, Warsaw
Distribution: LFS, Gentoo
Posts: 591

Rep: Reputation: 32
1. I am not sure ["public"] is acceptable. Try [public] instead.
2. If you see the share at W98 box can you open it? If not what is the message?
3. Re logon: 'domain logons = yes' is missing. What is the message when you try to logon?
 
Old 05-06-2003, 03:12 PM   #3
KennyK
Member
 
Registered: Apr 2003
Location: California, USA
Distribution: Redhat 8.0, 9.0 Suse 9.0 Pro
Posts: 129

Rep: Reputation: 15
Try to set security = share

Then restart the service. If that works, then you don't have the samba users set up correctly.

Regards
 
Old 05-07-2003, 12:37 PM   #4
victorc
LQ Newbie
 
Registered: May 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for your quick response.

Dorian33:
1. I changed it to [public]
2. I don't see a share in my explore. I get a popup box which want me to enter a password for the share IPX$. I don't created this share as far as I know.
3. I added this to my config file. The error I receive after trying to logon to my domain is "Incorrect parameter". Not a very usefull message!

KennyK: How do you create a valid Samba user?
 
Old 05-07-2003, 02:05 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,254

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
To add a samba user:
as root
smbpasswd -a username

Username must match a regular user as well as the Win98 username you logon to.

The command testparm will perform a syntax check your smb.conf file. Is pritable a typo or is it really in your public share.
Which do you want?
printable = no
or
printable = yes
in your public share.
 
Old 05-07-2003, 03:03 PM   #6
KennyK
Member
 
Registered: Apr 2003
Location: California, USA
Distribution: Redhat 8.0, 9.0 Suse 9.0 Pro
Posts: 129

Rep: Reputation: 15
Quote:
Originally posted by victorc
Thanks for your quick response.

KennyK: How do you create a valid Samba user?
This is how I add Samba users;

First add the Unix user
/usr/sbin/useradd username
passwd username


Then add the Samba user
smbadduser username:username

Hope this helps.
 
Old 05-07-2003, 03:32 PM   #7
victorc
LQ Newbie
 
Registered: May 2003
Posts: 5

Original Poster
Rep: Reputation: 0
I created a new user to samba. This user exist in both Linux and Win98. They both has the same passwords.

When I want to logon on the domain "myDomain" I get windows popupbox with the message (translated from dutch) "Incorrect parameter". If I type the ip number in the field "domain", the samba server makes some noice (harddisk) and I receive the message "password is incorrect or permission to this domain is not granted".

Does somebody know what is wrong?

Regards,

Victor
 
Old 05-07-2003, 04:15 PM   #8
KennyK
Member
 
Registered: Apr 2003
Location: California, USA
Distribution: Redhat 8.0, 9.0 Suse 9.0 Pro
Posts: 129

Rep: Reputation: 15
Were you able to connect when you canged the security = share
You never told me if you could or not. Knowing that will help to trouble shoot this.
 
Old 05-07-2003, 04:36 PM   #9
victorc
LQ Newbie
 
Registered: May 2003
Posts: 5

Original Poster
Rep: Reputation: 0
KennyK, sorry I forgot to told you.

If I change the security to share I CAN access my shares on my server. But I still cannot logon to my server (still get the strange error). Does this mean I have not setup my samba users correctly? I think that is strange. My linux users and my win98 users are the same and have the same password. I also ran the command "smbpasswd -a username". Do I forgot something?

Regards Victor
 
Old 05-07-2003, 04:56 PM   #10
KennyK
Member
 
Registered: Apr 2003
Location: California, USA
Distribution: Redhat 8.0, 9.0 Suse 9.0 Pro
Posts: 129

Rep: Reputation: 15
Try this;

In your smb.conf file

replace;

[homes]
comment = Home Directories
preexec = /bin/sh -c 'echo /usr/bin/smbclient -M %m -I %I'&
browseable = yes
readonfiltered= no
writable = yes
create mode = 0750
public = yes

With;

[homes]
comment = Home Directories
browseable = no
writable = yes

[Profiles]
path = /%G/%U/.profile
writable = yes
browseable = no
guest ok = yes
directory mask = 0755
create mask = 0755
read only = no

Then restart samba.

See it that works
 
Old 05-09-2003, 01:57 PM   #11
victorc
LQ Newbie
 
Registered: May 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks KennyK!

I think the job is almost done. The new settings in the smb.conf files works better. If the user has a blanco password it works!! If the user has not a blanco password it can't logon because the password is wrong (thats what windows telling me). I am sure the password is correct.... So it almost works fine. I keep working on this.
 
Old 05-09-2003, 02:18 PM   #12
KennyK
Member
 
Registered: Apr 2003
Location: California, USA
Distribution: Redhat 8.0, 9.0 Suse 9.0 Pro
Posts: 129

Rep: Reputation: 15
Glad to help. This is a great forum to get info. It has helped me alot. Just let us know if you need anymore help.

Kenny
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot connect to Samba server from Win2k client buddhahat Linux - Networking 11 06-20-2005 04:01 PM
Cannot connect to samba server sp4nk3r Fedora 2 06-08-2004 02:05 AM
Can't connect to Samba server from MS Windows kychan Linux - Networking 2 11-30-2003 05:50 AM
Is samba required to connect to a Windows Advanced server from RedHat 8.0 server? NemesisStar Linux - Hardware 1 10-20-2003 01:32 AM
cannot connect to samba server when its running on port 139 badshaaa Linux - Networking 21 02-07-2002 05:50 AM


All times are GMT -5. The time now is 02:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration