LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2004, 04:48 PM   #1
jrperiod
LQ Newbie
 
Registered: Jan 2004
Location: J-ville FL
Distribution: Gentoo
Posts: 15

Rep: Reputation: 0
Can navigate NTFS as root but not user


OK so Ive searched through the forums and it has helped me. B4 adding "unmask=0222" to my fstab file I wasnt even able to click on my NTFS partition in KDE as a user.

Now I can click on it and it will open but as a user I dont see any files. When I use my root account I can navigate the partition and play my music off of it.

Is there another line of code I need to add to the fstab line. Ive also added "user" and changed "0222" to "0000" but that doesnt change anthing.

Would it make a difference if I changed the NTFS partition to FAT32 or would I still be in the same position of trying to navigate the partition as both root and user.
 
Old 01-16-2004, 05:07 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Are you mounting it before you look at it as the user?
 
Old 01-16-2004, 06:02 PM   #3
jrperiod
LQ Newbie
 
Registered: Jan 2004
Location: J-ville FL
Distribution: Gentoo
Posts: 15

Original Poster
Rep: Reputation: 0
Its mounted automatically.
 
Old 01-16-2004, 06:11 PM   #4
BrianNJ
Member
 
Registered: Jul 2003
Distribution: Gentoo 2004.0
Posts: 157

Rep: Reputation: 30
try using 'users' instead of 'user'
 
Old 01-16-2004, 06:55 PM   #5
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 540

Rep: Reputation: 32
As this partition is auto-mounted at boot it also has root permission set.
disable the automount option with noauto in /etc/fstab an then you can access the drive mounting it when necessary. Also change from owner to user(s) in order you can mount/unmount that drive whenever you need.
Not sure how to do this on mandrake as it uses supermount, not available on slack.
Ask Mandrake forum for details
 
Old 01-16-2004, 07:00 PM   #6
luxitan
Member
 
Registered: Aug 2003
Location: Portugal
Distribution: Gentoo
Posts: 78

Rep: Reputation: 15
you'll have to put umask=0222 on /etc/fstab, the only way i could see my ntfs as user was doing this
 
Old 01-16-2004, 08:01 PM   #7
jrperiod
LQ Newbie
 
Registered: Jan 2004
Location: J-ville FL
Distribution: Gentoo
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks, Im going to try all of this when I get home tonight.

Oh, and I already have unmask=0222
 
Old 01-17-2004, 12:08 AM   #8
jrperiod
LQ Newbie
 
Registered: Jan 2004
Location: J-ville FL
Distribution: Gentoo
Posts: 15

Original Poster
Rep: Reputation: 0
OK here is my unmodified fstab

/dev/hdf1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdf6 /home ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/scd0,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/cdrom2 supermount dev=/dev/hdh,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,sync,codepage=850,iocharset=iso8859-1 0 0
/dev/hde1 /mnt/win_c ntfs iocharset=iso8859-1,ro 0 0
/dev/hde5 /mnt/win_d ntfs iocharset=iso8859-1,ro 0 0
/dev/hde3 /mnt/win_e ntfs iocharset=iso8859-1,ro 0 0
/dev/hde4 /mnt/win_f ntfs iocharset=iso8859-1,ro 0 0
none /mnt/zip supermount dev=/dev/sda4,fs=ext2:vfat,--,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hdf5 swap swap defaults 0 0

whenever I add anything to the win_e and win_f partitions i get this err in my system log

mount: wrong fs type, bad option, bad superblock on /dev/hde4

am I typing it right "unmask=0000" or "unmask=0222" and I added "users"

Oh and what exactly does chmod 777 ....... do
 
Old 01-17-2004, 08:26 PM   #9
jrperiod
LQ Newbie
 
Registered: Jan 2004
Location: J-ville FL
Distribution: Gentoo
Posts: 15

Original Poster
Rep: Reputation: 0


Last edited by jrperiod; 01-17-2004 at 08:28 PM.
 
Old 01-17-2004, 08:57 PM   #10
slackerJoe
LQ Newbie
 
Registered: Jul 2003
Location: Asheville, NC
Distribution: Slackware
Posts: 14

Rep: Reputation: 0
Try these....

/dev/hde3 /mnt/win_e ntfs auto,ro,umask=002 0 0
/dev/hde4 /mnt/win_f ntfs auto,ro,umask=002 0 0

I had the same issue but with this entry every user is able to use files from the ntfs partition and it is auto mounted.
 
Old 01-18-2004, 12:33 PM   #11
jrperiod
LQ Newbie
 
Registered: Jan 2004
Location: J-ville FL
Distribution: Gentoo
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks SlackerJoe, this worked for me.
 
Old 01-18-2004, 07:19 PM   #12
slackerJoe
LQ Newbie
 
Registered: Jul 2003
Location: Asheville, NC
Distribution: Slackware
Posts: 14

Rep: Reputation: 0
Glad to hear it worked for you =)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Scanner to work as USER and not forced as ROOT Root (Suse 9.1) 1kyle Linux - Hardware 0 07-10-2004 09:51 AM
Games runs slow as normal user, but fast as root user mcore Linux - Software 2 06-08-2004 12:11 AM
IntelliMouse thumb buttons work as root, broken as non-root user, wheel works always digital vortex Linux - Hardware 7 03-02-2004 05:14 PM
NTFS drive - no user privilages - root only jon_k Linux - Software 2 09-01-2003 06:28 AM
Why does kppp.desktop require root userid for non-root user? rdaves@earthlink.net Linux - Networking 4 08-27-2001 10:18 AM


All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration