LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-07-2004, 10:59 AM   #1
jtsosie
LQ Newbie
 
Registered: May 2004
Location: Austin,TX
Distribution: Red hat 7.3
Posts: 5

Rep: Reputation: 0
Unhappy Can boot Win2k & Win98 but not Redhat 7.3 - using System Commander 7


It was all working before, but now Linux won't boot. System Commander shows Win2k, Win98 & Redhat. Win98 & Win2k will boot fine, but when I choose Redhat 7.3, it shows:

,,,,
*** System Commander 7 ****************************
Copyright blah blah blah
v7.05
Selection: Redhat 7.3


Then all I get is a blinking cursor beneath that.

I've tried deleting the boot & root partitions of Linux & then restoring them with drive images that worked in the first place, but there's no change. I still get the same result as above. These drive images are from another hdd (I'll call hdd2) that still boots when I put it in this laptop.

Partition 1: Linux Boot (Primary Active)
Partition 2: Fat32 for Win98 & 2k (Primary Active)
Partition 3: Linux Root (Logical)
Partition 4: Linux Swap (Logical)

I have to use RH 7.3 and nothing newer for work. Right now, I have to swap hard drives in my laptop - one for corporate email etc (win on hdd1) & the other to load machines (linux on hdd2).

FYI: I can't install linux from CD. When the install asks for CD2, it keeps telling me Not Found or Wrong CD. I cannot disable dma in the bios (I read that would help). The laptop came with a drive (hdd2) with Redhat already installed and working. I made images of it's partitions and put them on my hdd1 after re-installing Win98 & 2k on FAT32 (I couldn't get FAT32, NTFS, & Linux partitions to play niceley). Then I installed System Commander 7, & all 3 OS worked for a while. I had what I needed and what I wanted (minus an NTFS partition). Now Redhat won't boot for no reason that I can tell.

Laptop is:
Dell C640
P4 - 2.0ghz
256mb RAM
40gig hdd
8x DVD

One day, I'd like to be Linux minded. Regretfully, I still know Windows better.
Thanks for any help you can give.

Last edited by jtsosie; 05-07-2004 at 11:29 AM.
 
Old 05-07-2004, 05:35 PM   #2
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
try reinstalling grub to partition 1
 
Old 05-07-2004, 07:35 PM   #3
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
You might need to run update-grub after you install it,david
 
Old 05-08-2004, 06:52 PM   #4
jtsosie
LQ Newbie
 
Registered: May 2004
Location: Austin,TX
Distribution: Red hat 7.3
Posts: 5

Original Poster
Rep: Reputation: 0
OK! That worked! I think.
Grub comes up when I choose Linux from the System Commander menu. Then it tries to boot Redhat, but I get the following error after a lot of stuff that flashed by too fast to read.

Mounting root filesystem
attempt to access beyond end of device
03:02: rw=0, want=2, limit=1
EXT3-fs: unable to read superblock
mount: error 22 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
Freeing unused kernel memory: 280k freed
Kernel panic: No init found. Try passing init= option to kernel.



I tried typing "update-grub", but got an error like bad command or something.

I've also booted up with the first install CD and run "fsck /dev/hdaX" (where X is the partition number - I tried them all). Each time it said "Clean" & "journal recovered".

It felt good to see my Linux "trying" again.
 
Old 05-08-2004, 07:21 PM   #5
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
k don't worry about GRUB, it's working properly, the problem is that the kernel is trying to mount the wrong root partition on hda2, when it should be hda3.
try passing "root=/dev/hda3" in place of "root=LABEL=/" to the kernel(press 'e' when you're in the grub menu).
you may also need to modify /etc/fstab, you can do it by using the rescue mode.

By the way unlike LILO, there's no need to update everytime you modify the config file when using GRUB, it's read everytime it loads.
 
Old 05-11-2004, 07:28 AM   #6
jtsosie
LQ Newbie
 
Registered: May 2004
Location: Austin,TX
Distribution: Red hat 7.3
Posts: 5

Original Poster
Rep: Reputation: 0
OK. I tried .../hda3. This time it said:

Mounting root filesystem
hda3: bad access: block=2, count=2
end_request: I/O error, dev 03:03 (hda), sector 2
EXT3-fs: unable to read superblock
mount: error 22 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
Freeing unused kernel memory: 280k freed
Kernel panic: No init found. Try passing init= option to kernel.

...hda4 said:

VFS: Can't find ext3 filesystem on dev ide0(3,4)

...hda5 said:

Welcom to Linux

Yeah!!!!!!!!

Thanks for your EXCELLENT help!

What do I do with /etc/fstab
 
Old 05-11-2004, 07:35 AM   #7
jtsosie
LQ Newbie
 
Registered: May 2004
Location: Austin,TX
Distribution: Red hat 7.3
Posts: 5

Original Poster
Rep: Reputation: 0
(Speaking from my working Linux book)

I changed my grub menu to the proper hda5

What should I change in /etc/fstab:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
 
Old 05-11-2004, 07:44 AM   #8
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Ah its a logical partition that's why its hda5 not 3, I overlooked it.
If everything is working properly then there's no need to update /etc/fstab
otherwise change the first 2 lines to:
Code:
/dev/hda5 / ext3 defaults 1 1
/dev/hda1 /boot ext3 defaults 1 2

Last edited by Demonbane; 05-11-2004 at 07:22 PM.
 
Old 05-11-2004, 01:58 PM   #9
jtsosie
LQ Newbie
 
Registered: May 2004
Location: Austin,TX
Distribution: Red hat 7.3
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks Demonbane.
Everything is working great now.

I only have 2 local Linux friends.
One was too busy, & the other couldn't figure it out.

I did change a line in /etc/fstab where swap was looking for hda3 but should have been hda6.

I think I'll install Linux at home now.
This shall be FUN!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i am in a fix over a dual boot system with win98 and redhat linux 7.3 ashutoshb Linux - General 4 07-12-2003 07:09 AM
multiboot win98 win2k and redhat 7.1 cmardhekar Linux - General 1 03-26-2002 07:18 AM
Triple Booting - Win2k, Win98 & Mandrake 8 MKsami Linux - Software 4 01-15-2002 09:57 PM
Dual Boot Win2K & RedHat 7.1 RedHatMN Linux - Newbie 2 10-19-2001 03:24 PM
Triple Boot: Win2k/linux/win98 mkhan Linux - Software 2 07-24-2001 09:45 AM


All times are GMT -5. The time now is 11:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration