LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-03-2004, 08:24 PM   #1
ClericPreston
LQ Newbie
 
Registered: Jun 2004
Location: Libria
Distribution: Slackware 9.1/10
Posts: 29

Rep: Reputation: 15
Angry Can't WRITE to USB stick, Mount OK NO WRITE!


Hello,
I was able to mount my usb jumpdrive. I created a new line in my fstab file.

/dev/sda1 /mnt/pendrive vfat noauto, owner, rw 00

and I mkdir /mnt/pendrive

I can copy from the drive but not write files to it, which I really need to do.

thanks

Cleric
 
Old 12-03-2004, 08:29 PM   #2
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
The obvious question first - Are you sure the drive is not write-protected. There should be a small switch on it somewhere, make sure that it is not in the lock position.

But other that that, you fstab line looks OK. Have you tried as root?
My fstab line is this (My USB drive works correctly):
Code:
/dev/sda1    /mnt/usb    vfat    rw,suid,dev,noexec,noauto,user,async 1 2
I hope this helps
--Ian
 
Old 12-03-2004, 08:41 PM   #3
ClericPreston
LQ Newbie
 
Registered: Jun 2004
Location: Libria
Distribution: Slackware 9.1/10
Posts: 29

Original Poster
Rep: Reputation: 15
Angry No switch

Thanks but there is no switch on my usb stick. It isnt write protected. I am about to do a girly thing and pull my hair out!

Cleric
 
Old 12-04-2004, 06:53 AM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,969

Rep: Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752
Add umask=000 option to the fstab entry.
 
Old 12-04-2004, 10:43 AM   #5
willmorrison
LQ Newbie
 
Registered: Dec 2004
Location: Lafayette Colorado
Distribution: Mandrake 10, Suse 9.1
Posts: 4

Rep: Reputation: 0
Check the permissions on the /dev/(whatever it's called) and see if they are listed as root owner or root group... these can frequently stop you from writing, but it will allow you to read from it all day long.
Just a thought...

Will
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Stick on Debian-Etch 2.4, write is disabled SlackerLX Linux - Hardware 12 10-08-2005 01:41 AM
USB Stick reads but won't write jaws_tas Linux - Hardware 3 09-23-2005 12:36 AM
Cannot mount a USB drive as read/write. icheyne MEPIS 2 06-28-2005 01:48 AM
MDK 10.x - Mount USB Pen OK, But no permission to write Xolo Linux - Software 2 05-20-2005 05:19 AM
write protect freezes my usb stick db391 Linux - Hardware 3 09-25-2004 04:43 AM


All times are GMT -5. The time now is 07:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration