LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-16-2003, 08:38 AM   #1
Remy Avril Jr.
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Rep: Reputation: 0
Can't view apache server files on lan


Desperate for help!!

I have apache webserver installed on my RH9 system, which will serve websites i create with php/mysql before publishing to the web. I also have IIS webserver running on my windows XP system on the same lan.

My problem is that i can't view the websites on the redhat pc from the windows pc. How do i enable that? The apache server works fine on the linux box cause i could access the files with a browser using either localhost or 127.0.0.1. I can even view the files on the windows server from linux using localhost/windowsfolder or using the windows pc ip address 192.168.1.103/windowsfolder!

But windows cannot view the linux server using the ip address of the linux box or the ip address of the webserver. I'm all for linux security, but it's driving me crazy trying to figure out whats wrong

Please help!
 
Old 10-16-2003, 08:59 AM   #2
mylo2003
Member
 
Registered: Jul 2003
Posts: 113

Rep: Reputation: 15
Hrm. I am assuming that both boxes can ping each other OK.

If this is the case, it could be something in the httpd.conf file that is missing or incorrect.

It could be this line:
ServerName *Linuxservernamehere*

OR

it could be this line also:
Listen *:80

Take a look at those lines and see what they say...if you edit them, don't forget to restart apache by

/sbin/service httpd restart
 
Old 10-16-2003, 09:24 AM   #3
Remy Avril Jr.
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for responding mylo2003

Yes, i can ping from both pc's.

The servername in the httpd.conf is localhost
the listen port is 80

i found this at the bottom of the file

<Directory "/var/www/html">
Options Indexes Includes FollowSymLinks

AllowOverride None
Allow from from all


Order allow,deny
</Directory>

quoted exactly. Is this correct?
 
Old 10-16-2003, 10:28 AM   #4
mylo2003
Member
 
Registered: Jul 2003
Posts: 113

Rep: Reputation: 15
Hrm. How about putting the Linux box IP and host name in the hosts file on the XP box. I believe it is in c:/winnt(or windows)/system32/drivers/etc/hosts

Also, it wouldn't hurt to put the host name (rather than localhost) in the servername field.) I'm not sure if it makes a difference but give it a shot.
 
Old 10-16-2003, 10:27 PM   #5
Remy Avril Jr.
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Original Poster
Rep: Reputation: 0
I did as u said:
Changing the servername to linuxhost1
Updating the win xp host file

But the result is the same (still can't view the files). I can ping linuxhost1 from winxp now.

Keep the suggestions coming.
 
Old 10-17-2003, 08:47 AM   #6
mylo2003
Member
 
Registered: Jul 2003
Posts: 113

Rep: Reputation: 15
OK. It still looks like there might be a problem with your apache web server. BUT..lets rule out network.

From a command prompt, run this

netstat -lntuw

This will show you the open ports on your linux machine. Hopefully, you will see a line that goes something like this:

tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN

and a whole bunch of other lines...we just want to see if we have port 80 open and listening..

try that and let me know!
 
Old 10-17-2003, 10:51 AM   #7
Remy Avril Jr.
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Results of 'netstat -intuw

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:32768 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:32769 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:901 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:5180 0.0.0.0:* LISTEN
udp 0 0 0.0.0.0:32768 0.0.0.0:*
udp 0 0 192.168.1.101:137 0.0.0.0:*
udp 0 0 0.0.0.0:137 0.0.0.0:*
udp 0 544 192.168.1.101:138 0.0.0.0:*
udp 0 0 0.0.0.0:138 0.0.0.0:*
udp 0 0 0.0.0.0:658 0.0.0.0:*
udp 0 0 0.0.0.0:68 0.0.0.0:*
udp 0 0 0.0.0.0:111 0.0.0.0:*
udp 0 0 0.0.0.0:631 0.0.0.0:*
 
Old 10-17-2003, 11:09 AM   #8
mylo2003
Member
 
Registered: Jul 2003
Posts: 113

Rep: Reputation: 15
How about chmod'ing the var/www/html folder (or whatever folder you are trying to see)
run the command:

chmod 777 /var/www/html (or dir in question)

If this doesn't work, try posing your httpd.conf file so we can take a look.
 
Old 10-17-2003, 11:31 AM   #9
Remy Avril Jr.
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Original Poster
Rep: Reputation: 0
here is the httpd.conf file with remarks removed for brevity

PART 1>>

ServerRoot "/etc/httpd"

PidFile "/var/run/httpd.pid"

TimeOut 300

KeepAlive false

MaxKeepAliveRequests 100

KeepAliveTimeout 15

<IfModule prefork.c>
StartServers 8
MinSpareServers 5
MaxSpareServers 20
MaxClients 150
MaxRequestsPerChild 100
</IfModule>

<IfModule worker.c>
StartServers 2
MaxClients 150
MinSpareThreads 25
MaxSpareThreads 75
ThreadsPerChild 25
MaxRequestsPerChild 0
</IfModule>

<IfModule perchild.c>
NumServers 5
StartThreads 5
MinSpareThreads 5
MaxSpareThreads 10
MaxThreadsPerChild 20
MaxRequestsPerChild 0
</IfModule>

Listen *:80

Include conf.d/*.conf

LoadModule access_module modules/mod_access.so
LoadModule auth_module modules/mod_auth.so
LoadModule auth_anon_module modules/mod_auth_anon.so
LoadModule auth_dbm_module modules/mod_auth_dbm.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule include_module modules/mod_include.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule env_module modules/mod_env.so
LoadModule mime_magic_module modules/mod_mime_magic.so
LoadModule cern_meta_module modules/mod_cern_meta.so
LoadModule expires_module modules/mod_expires.so
LoadModule headers_module modules/mod_headers.so
LoadModule usertrack_module modules/mod_usertrack.so
LoadModule unique_id_module modules/mod_unique_id.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule mime_module modules/mod_mime.so
LoadModule dav_module modules/mod_dav.so
LoadModule status_module modules/mod_status.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule asis_module modules/mod_asis.so
LoadModule info_module modules/mod_info.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule dir_module modules/mod_dir.so
LoadModule imap_module modules/mod_imap.so
LoadModule actions_module modules/mod_actions.so
LoadModule speling_module modules/mod_speling.so
LoadModule userdir_module modules/mod_userdir.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so

User apache
Group apache

ServerAdmin root@linuxhost1

ServerName linuxhost1

UseCanonicalName on

DocumentRoot "/var/www/html"

<LocationMatch "^/$">
Options -Indexes
ErrorDocument 403 /error/noindex.html
</LocationMatch>

<IfModule mod_userdir.c>
UserDir "disable"
</IfModule>

DirectoryIndex

AccessFileName .htaccess
 
Old 10-17-2003, 11:33 AM   #10
Remy Avril Jr.
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Original Poster
Rep: Reputation: 0
PART 2>>

<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>

TypesConfig "/etc/mime.types"

DefaultType text/plain

<IfModule mod_mime_magic.c>
# MIMEMagicFile /usr/share/magic.mime
MIMEMagicFile conf/magic
</IfModule>

HostNameLookups Off

ErrorLog "/var/log/httpd/error_log"

LogLevel warn

LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

CustomLog logs/access_log combined

ServerSignature on

Alias /icons/ "/var/www/icons/"

Alias /manual "/var/www/manual"

<IfModule mod_dav_fs.c>
# Location of the WebDAV lock database.
DAVLockDB /var/lib/dav/lockdb
</IfModule>

ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"

<IfModule mod_cgid.c>

</IfModule>

IndexOptions FancyIndexing VersionSort NameWidth=*

AddIconByEncoding (CMP,/icons/compressed.gif) x-compress x-gzip

AddIconByType (TXT,/icons/text.gif) text/*
AddIconByType (IMG,/icons/image2.gif) image/*
AddIconByType (SND,/icons/sound2.gif) audio/*
AddIconByType (VID,/icons/movie.gif) video/*

AddIcon /icons/binary.gif .bin .exe
AddIcon /icons/binhex.gif .hqx
AddIcon /icons/tar.gif .tar
AddIcon /icons/world2.gif .wrl .wrl.gz .vrml .vrm .iv
AddIcon /icons/compressed.gif .Z .z .tgz .gz .zip
AddIcon /icons/a.gif .ps .ai .eps
AddIcon /icons/layout.gif .html .shtml .htm .pdf
AddIcon /icons/text.gif .txt
AddIcon /icons/c.gif .c
AddIcon /icons/p.gif .pl .py
AddIcon /icons/f.gif .for
AddIcon /icons/dvi.gif .dvi
AddIcon /icons/uuencoded.gif .uu
AddIcon /icons/script.gif .conf .sh .shar .csh .ksh .tcl
AddIcon /icons/tex.gif .tex
AddIcon /icons/bomb.gif core

AddIcon /icons/back.gif ..
AddIcon /icons/hand.right.gif README
AddIcon /icons/folder.gif ^^DIRECTORY^^
AddIcon /icons/blank.gif ^^BLANKICON^^

DefaultIcon /icons/unknown.gif

ReadmeName README.html
HeaderName HEADER.html

IndexIgnore .??* *~ *# HEADER* README* RCS CVS *,v *,t

AddEncoding x-compress Z
AddEncoding x-gzip gz tgz

AddLanguage da .dk
AddLanguage nl .nl
AddLanguage en .en
AddLanguage et .et
AddLanguage fr .fr
AddLanguage de .de
AddLanguage he .he
AddLanguage el .el
AddLanguage it .it
AddLanguage ja .ja
AddLanguage pl .po
AddLanguage kr .kr
AddLanguage pt .pt
AddLanguage nn .nn
AddLanguage no .no
AddLanguage pt-br .pt-br
AddLanguage ltz .ltz
AddLanguage ca .ca
AddLanguage es .es
AddLanguage sv .se
AddLanguage cz .cz
AddLanguage ru .ru
AddLanguage tw .tw
AddLanguage zh-tw .tw
AddLanguage hr .hr

LanguagePriority en da nl et fr de el it ja kr no pl pt pt-br ltz ca es sv tw

ForceLanguagePriority Prefer Fallback

AddDefaultCharset ISO-8859-1

AddCharset ISO-8859-1 .iso8859-1 .latin1
AddCharset ISO-8859-2 .iso8859-2 .latin2 .cen
AddCharset ISO-8859-3 .iso8859-3 .latin3
AddCharset ISO-8859-4 .iso8859-4 .latin4
AddCharset ISO-8859-5 .iso8859-5 .latin5 .cyr .iso-ru
AddCharset ISO-8859-6 .iso8859-6 .latin6 .arb
AddCharset ISO-8859-7 .iso8859-7 .latin7 .grk
AddCharset ISO-8859-8 .iso8859-8 .latin8 .heb
AddCharset ISO-8859-9 .iso8859-9 .latin9 .trk
AddCharset ISO-2022-JP .iso2022-jp .jis
AddCharset ISO-2022-KR .iso2022-kr .kis
AddCharset ISO-2022-CN .iso2022-cn .cis
AddCharset Big5 .Big5 .big5
# For russian, more than one charset is used (depends on client, mostly):
AddCharset WINDOWS-1251 .cp-1251 .win-1251
AddCharset CP866 .cp866
AddCharset KOI8-r .koi8-r .koi8-ru
AddCharset KOI8-ru .koi8-uk .ua
AddCharset ISO-10646-UCS-2 .ucs2
AddCharset ISO-10646-UCS-4 .ucs4
AddCharset UTF-8 .utf8

AddCharset GB2312 .gb2312 .gb
AddCharset utf-7 .utf7
AddCharset utf-8 .utf8
AddCharset big5 .big5 .b5
AddCharset EUC-TW .euc-tw
AddCharset EUC-JP .euc-jp
AddCharset EUC-KR .euc-kr
AddCharset shift_jis .sjis

AddType application/x-tar .tgz

AddHandler imap-file map

AddHandler type-map var

AddOutputFilter INCLUDES .shtml

Alias /error/ "/var/www/error/"

BrowserMatch "Mozilla/2" nokeepalive
BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
BrowserMatch "RealPlayer 4\.0" force-response-1.0
BrowserMatch "Java/1\.0" force-response-1.0
BrowserMatch "JDK/1\.0" force-response-1.0

BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
BrowserMatch "^WebDrive" redirect-carefully

# Virtual hosts
<VirtualHost *>
ServerSignature email

DirectoryIndex index.php index.html index.htm index.shtml

LogLevel warn
HostNameLookups off
</VirtualHost>

<Directory "/">
Options FollowSymLinks

AllowOverride None
</Directory>

<Directory "/var/www/html">
Options Indexes Includes FollowSymLinks

AllowOverride None
Allow from from all

Order allow,deny
</Directory>

<Directory "/var/www/icons">
Options Indexes MultiViews

AllowOverride None
Allow from from all

Order allow,deny
</Directory>

<Directory "/var/www/cgi-bin">
Options ExecCGI

AllowOverride None
Allow from from all

Order allow,deny
</Directory>
 
Old 10-17-2003, 12:02 PM   #11
mylo2003
Member
 
Registered: Jul 2003
Posts: 113

Rep: Reputation: 15
I noticed that there are 2
'DirectoryIndex'
lines.
Delete the empty one.

Question, what are your contents of /var/www/html?

Is there a file called index.php or index.html?
 
Old 10-17-2003, 12:41 PM   #12
Remy Avril Jr.
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Original Poster
Rep: Reputation: 0
The two Directoryindex lines, the second of these lines is within the virtualhosts tag. The first is by itself. Should i delete the first?

Also
ls -l /var/www/html
-rw-r--r-- 1 root root 19 Oct 15 01:36 index.php
drwxrwxr-x 3 root websites 4096 Oct 13 13:27 testweb
drwxrwxr-x 2 webalizer websites 4096 Oct 14 09:20 usage

Last edited by Remy Avril Jr.; 10-17-2003 at 12:42 PM.
 
Old 10-17-2003, 12:58 PM   #13
mylo2003
Member
 
Registered: Jul 2003
Posts: 113

Rep: Reputation: 15
Sorry, my bad...try putting
DirectoryIndex index.php index.html index.htm index.shtml

in the 1st DirectoryIndex.

Don't forget to run the command
/sbin/services httpd restart

Then go to the windows machine and type http://linuxmachinename
 
Old 10-17-2003, 01:18 PM   #14
Remy Avril Jr.
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Still no joy, i get: This page cannot be displayed on the windows machine
 
Old 10-17-2003, 01:29 PM   #15
mylo2003
Member
 
Registered: Jul 2003
Posts: 113

Rep: Reputation: 15
OK.

Last resort. Lets check those logs. (not the ones we are crapping in frustration to get this working) LOL...

Go to /etc/httpd/logs and check out the access log and the errror log.

What are the errors here? (The recent errors will be at the bottom of the files so scroll down)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
setting up a apache server on lan dipen_linux Linux - Networking 1 06-10-2005 05:03 AM
Apache Server up, but acid and MRTG home page could not be view!! yitloo Linux - Networking 1 11-08-2004 04:20 AM
view files in ftp server in firefox browser like icons in konqueror pranith Linux - Newbie 3 10-16-2004 08:32 PM
Apache 2 Server - Can't access it via ip address from inside LAN Robstro Linux - Networking 1 06-30-2004 01:50 PM
unable to view documents from my apache server wendallsan Linux - Software 2 09-27-2003 03:13 PM


All times are GMT -5. The time now is 02:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration