LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 02-21-2012, 02:14 PM   #1
poisonborz
LQ Newbie
 
Registered: Apr 2008
Posts: 16

Rep: Reputation: 0
Can't set guest read/write samba share


Hola,

I try to set up a samba share, like this:

Code:
[global]
workgroup = WORKGROUP
netbios name = server
guest ok = yes
read only = no
security = user
wins support = yes
null passwords = true
guest account = nobody
map to guest = Bad Password
os level = 66
log level = 2
local master = yes
unix extensions = no
 
[Media]
path = /media/ServerMedia/Media
browseable = Yes
read only = No
guest ok = Yes

[WebTemp]
path = /home/server/www/tmp/stor
browseable = Yes
read only = No
guest ok = Yes
create mask = 0777
available = Yes
create mode = 0777
directory mode = 0777
public = yes
writable = yes
Media can be reached by any guest, but with no write access - it works well.
I want the WebTemp share to be fully read/writeable to guests, but somehow it asks for user/password for every access. Why? As you can see above, I've tried a lots of parameters, but none work. The "stor" dir is also chowned by sambashare...
Thanks
 
Old 02-21-2012, 02:26 PM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,613
Blog Entries: 1

Rep: Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048
What are the system permissions on /home/server/www/tmp/stor?
 
Old 02-21-2012, 06:07 PM   #3
liberalchrist
Member
 
Registered: Jun 2011
Location: Clover, SC
Distribution: Slackware Current & FreeBSD
Posts: 122

Rep: Reputation: 26
I have mine set as below and complete access is granted. It looks deceptively simple.

path = /home/username/media/Music
public = yes
only guest = yes
writable = yes
printable = no
 
Old 02-21-2012, 06:57 PM   #4
poisonborz
LQ Newbie
 
Registered: Apr 2008
Posts: 16

Original Poster
Rep: Reputation: 0
I know it should be simple, that's why I don't understand why it asks for login...
I've added the "only guest" line to the share, but still asks for pass.
Here are the permissions to the folder: http://borz.ath.cx/img/data/screenshot697.jpg
 
Old 02-21-2012, 07:33 PM   #5
liberalchrist
Member
 
Registered: Jun 2011
Location: Clover, SC
Distribution: Slackware Current & FreeBSD
Posts: 122

Rep: Reputation: 26
Some more ideas:

I have guest account commented out and the following in /etc/passwd:

nobody:x:99:99:nobody:/:/bin/false

/etc/group has:

nobody:x:98:nobody

Also, I have security=share instead of user.

My permissions on the actual folders are read, write, execute for everybody.

This is not a very secure setup, but it does allow the access you are looking for on my system. I use the hosts allow on static ip's for some security.
 
Old 02-22-2012, 04:51 AM   #6
poisonborz
LQ Newbie
 
Registered: Apr 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Thanks, I also set security to share, it seems to be more straightforward than the user-based mode.
The problem seemed to be with the folder that was located inside the www folder. No matter the permissions, somehow access was not granted. I "ln -s"-ed it to a folder in the system, and now it can be accessed as it set in Samba.
 
Old 06-16-2014, 09:41 AM   #7
pfisker
LQ Newbie
 
Registered: Jun 2014
Location: Copenhagen
Distribution: slack
Posts: 1

Rep: Reputation: Disabled
write access

you are almost there, but you need to make sure that the directory at a system level is also writeable by your nobody or guest user (who is running the samba process must be able to write also. a very simple way to check is to set the directory all writeable (chmod a+rwx) and reload you smb conf. if it now works, its due to the physical directory permissions and you can play around with various masks to get it tothe level of security you want.
kr per fisker
 
  


Reply

Tags
samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to automount a Samba network share read-write for multiple users on boot? ask Linux - General 2 01-02-2012 04:33 AM
Samba share read only for guests and write for some specific users ^andrea^ Linux - Server 6 06-21-2011 06:42 PM
[SOLVED] NFS share is mounted as read-only even if write permissions are set vofka Linux - Server 2 04-14-2010 07:09 PM
Cannot write to samba share with XP guest under VMware Workstation 6 (Feisty host) galileux Linux - Software 2 05-17-2007 05:22 PM
Why can I not write to a SAMBA share when read/write is enabled? eric m Linux - General 4 08-21-2006 10:22 PM


All times are GMT -5. The time now is 03:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration