LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-24-2008, 10:46 AM   #1
gregorian
Member
 
Registered: Apr 2006
Location: India
Posts: 473

Rep: Reputation: 33
Can't retain my resolution or choose my graphic manager in Slackware 12.1


I installed Slackware 12.1 using the "full" option. The installation was successful. After I logged on, I typed startx but I got some No screen error. I browsed for help and found that I could get my graphic manager working by typing xorgsetup and choosing a few basic settings. After doing this I could start my X server. I logged in at 1024 x 768 resolution in KDE (chose this as my default manager during setup). I went to the KDE Control Center and changed the resolution to 1280 x 768. When I logged out and logged back in I found that the resolution had been restored to 1024 X 768. I changed the resolution again, but this time the screen went black and there was nothing I could do. I repeated this procedure several times and the screen went black a few of the times. It hasn't happened now for a long time and I think that the black screen problem has gone away. However, I still have to change the resolution every time I log in.

Besides this, I do not get the option of choosing the graphic manager at startup. I know that the full installation of Slackware gives you 4-5 graphic managers.

xorg.conf

Code:
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/share/X11/rgb"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/TTF"
        FontPath     "/usr/share/fonts/OTF"
        FontPath     "/usr/share/fonts/Type1"
        FontPath     "/usr/share/fonts/misc"
        FontPath     "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
        Load  "glx"
        Load  "extmod"
        Load  "GLcore"
        Load  "xtrap"
        Load  "dbe"
        Load  "record"
        Load  "dri"
        Load  "type1"
        Load  "freetype"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option       "XkbModel"  "itouch"
        Option       "XkbLayout"  "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        #DisplaySize      280   210     # mm
        Identifier   "Monitor0"
        VendorName   "GSM"
        ModelName    "3acb"
        Option      "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"                   # [<bool>]
        #Option     "SWcursor"                  # [<bool>]
        #Option     "ColorKey"                  # <i>
        #Option     "CacheLines"                # <i>
        #Option     "Dac6Bit"                   # [<bool>]
        #Option     "DRI"                       # [<bool>]
        #Option     "NoDDC"                     # [<bool>]
        #Option     "ShowCache"                 # [<bool>]
        #Option     "XvMCSurfaces"              # <i>
        #Option     "PageFlip"                  # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName   "82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
        BusID       "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection


Thank your for your time.

Last edited by gregorian; 05-24-2008 at 10:48 AM.
 
Old 05-24-2008, 02:01 PM   #2
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
From your post, it sounds like you are logging in a CLI (Command Line Interface), and then switching to xserver.

If you look in the Slackware forum, 99% of the issues you have described are already answered. Take a look there.

And welcome to Slackware!
 
Old 05-24-2008, 11:16 PM   #3
gregorian
Member
 
Registered: Apr 2006
Location: India
Posts: 473

Original Poster
Rep: Reputation: 33
I went through the threads and added HorizSync, VertRefresh and the resolutions. I still have the same problem. It's not that I can't achieve the 1280 x 1024 resolution. It's just that it goes back to the 1024 x 768 when I log back. Even if I set it at 800 x 600, it goes back to 1024 x 768 as if that's the default resolution.

I've highlighted the additions with bold.

Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	RgbPath      "/usr/share/X11/rgb"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/TTF"
	FontPath     "/usr/share/fonts/OTF"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/misc"
	FontPath     "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
	Load  "glx"
	Load  "extmod"
	Load  "GLcore"
	Load  "xtrap"
	Load  "dbe"
	Load  "record"
	Load  "dri"
	Load  "type1"
	Load  "freetype"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option       "XkbModel"  "logicink"
	Option       "XkbLayout"  "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	#DisplaySize	  280   210	# mm
	Identifier   "Monitor0"
	HorizSync    30-70
	VertRefresh  50-120

	VendorName   "GSM"
	ModelName    "3acb"
	Option	    "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "CacheLines"         	# <i>
        #Option     "Dac6Bit"            	# [<bool>]
        #Option     "DRI"                	# [<bool>]
        #Option     "NoDDC"              	# [<bool>]
        #Option     "ShowCache"          	# [<bool>]
        #Option     "XvMCSurfaces"       	# <i>
        #Option     "PageFlip"           	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	VendorName  "Intel Corporation"
	BoardName   "82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 24
	SubSection "Display"
		Viewport   0 0
		Depth     1
		 Modes       "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
		 Modes       "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
		 Modes       "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	 	Modes       "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
 		Modes       "1280x1024" "1024x768" "800x600" "640x480"
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		 Modes       "1280x1024" "1024x768" "800x600" "640x480"
		Depth     24
	EndSubSection
EndSection

Last edited by gregorian; 05-24-2008 at 11:48 PM.
 
Old 05-25-2008, 02:05 PM   #4
okos
Member
 
Registered: May 2007
Location: California
Distribution: Slackware/Ubuntu
Posts: 609

Rep: Reputation: 37
Have you tried installing the video drivers for your monitor?


I had a similar problem until I installed the Nvidia driver.

Perhaps it is just a work around the actual issue.
 
Old 05-25-2008, 02:52 PM   #5
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
If you look, it's an Intel chipset. Compiling from source is NOT a good idea in SW for this chipset.
 
Old 05-25-2008, 11:00 PM   #6
gregorian
Member
 
Registered: Apr 2006
Location: India
Posts: 473

Original Poster
Rep: Reputation: 33
I don't understand why it defaults to 1024 x 768 every time I log in. Don't know if it's related but I chose Frame Buffer Console 1024 x 768 during setup. That's what it chose for me.

Last edited by gregorian; 05-25-2008 at 11:12 PM.
 
Old 05-26-2008, 03:37 AM   #7
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Have you tried deleting the other modes and leaving only
Code:
Modes       "1280x1024"
 
Old 05-26-2008, 04:30 AM   #8
gregorian
Member
 
Registered: Apr 2006
Location: India
Posts: 473

Original Poster
Rep: Reputation: 33
I didn't do that. Since the modes were not present in the original xorg.conf file, I didn't expect it to have an effect. I can set resolutions even higher than 1280 x 1024 even though they're not there in the file.
 
Old 05-26-2008, 11:02 PM   #9
gregorian
Member
 
Registered: Apr 2006
Location: India
Posts: 473

Original Poster
Rep: Reputation: 33
Can I write a script to change the resolution at startup? Something I could set to autostart every time I log on to KDE?
 
Old 05-27-2008, 12:13 AM   #10
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Maybe it's something to do with KDE. Maybe a setting or something that changes it.
 
Old 05-27-2008, 12:34 AM   #11
gregorian
Member
 
Registered: Apr 2006
Location: India
Posts: 473

Original Poster
Rep: Reputation: 33
I hope there's a way. Changing the display resolution every time I startx is tiresome. If Ctrl Alt + worked, it wouldn't have been so bad, but even that doesn't work for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New graphic card - help me choose! moljac024 Linux - Hardware 15 10-17-2007 01:41 PM
Text Resolution, Graphic resolution. Change from prompt dlublink Suse/Novell 2 01-28-2005 11:50 AM
gdm: choose window manager wampfler Fedora 23 01-28-2004 12:41 PM
choose windows manager _ben_deb_ Linux - Newbie 4 06-12-2003 09:18 AM


All times are GMT -5. The time now is 01:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration