LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 10-17-2006, 03:45 PM   #1
mikescony
LQ Newbie
 
Registered: Oct 2006
Location: Chicago
Distribution: suse 10.0
Posts: 23

Rep: Reputation: 15
Unhappy can't mount floppy drive


Hello lords of linux:

I have another problem this time I can not mount my floppy drive.

I am working with a IBM desktop netvista desktop and SuSE linux 10.1

The error that I recieve when I try to mount is

Mount error
Method "mount" with signature "ssas" on interface "org.freedesktop.hal.volume" doesn't exist

All I can say is HUH!!!

Now, I checked a few forums and got some guidance
such as: mount /dev/fd0/media/floppy

I get an error that /dev/fd0/ does not exist in fstab and mtab files.I checked the files and it is entered in there

Now I try to g-edit the fstab and mtab files but the syntax for these files look strange.

syntax is as follows:

/dev/fd0(14 spaces) /media/floppy(9 spaces) auto(7spaces) noauto,user,sync(6spaces) 0 0

With all of the spaces, is this the proper sysntax for editing this file?

I am a newbie and I need the guidance...


Last edited by mikescony; 10-17-2006 at 03:51 PM.
 
Old 10-17-2006, 05:46 PM   #2
bibh_lnxq
Member
 
Registered: Nov 2004
Location: Leiden, Netherlands
Distribution: SuSE; Fedora;Slackware
Posts: 58

Rep: Reputation: 15
The spaces in fstab are normal.

I have just rebooted to SUSE 10.1 to check if there wasn't some quirk, but these sets of standard commands simply work.

su
<rootpassword>
mount /dev/fd0 /mnt
cd /mnt
ls -a
and you should be able to see what is on the floppy under /mnt
Or
mount /dev/fd0 /media/floppy /mnt (in your post a space is missing after fd0)
So will
mount /media/floppy
cd /media/floppy
You are spoilt for choice!
Don't forget to umount after you are finished.
 
Old 10-18-2006, 11:09 AM   #3
mikescony
LQ Newbie
 
Registered: Oct 2006
Location: Chicago
Distribution: suse 10.0
Posts: 23

Original Poster
Rep: Reputation: 15
Hello BiBh_lnxq and linux world:

So far I have tried the above test with no success, and I have done some searching on the internet for mor guidance and still I am getting no where. I need some more assistance.

I have copied over /etc/fstab information is as follows:

/dev/hda6 / reiserfs acl,user_xattr 1 1

/dev/hda7 /home reiserfs acl,user_xattr 1 2

/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0

/dev/hda5 swap swap defaults 0 0

proc/proc proc defaults 0 0

sysfs/sys sysfs noauto 0 0

debugfs/sys/kernel/debug debugfs noauto 0 0

usbfs/proc/bus/usb usbfs noauto 0 0

devpts/dev/pts devpts mode=0620,gid=5 0 0

/dev/fd0/media/floppy auto noauto,user,sync 0 0


I have tried the command mount -a and the output from that is showing I have bad mount points?!?

I have also looked over some documentation at linuxquestions.org and found a toutorial on editing the /etc/fstab file but it is vauge to me. I don't want to be a time sink but I am looking for guidance

Please Help......
 
Old 10-18-2006, 11:38 AM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,950
Blog Entries: 11

Rep: Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860
Your problem is that your fstab line has TOO MANY ENTRIES.
/dev/fd0/media/floppy auto noauto,user,sync 0 0
should be
/dev/fd0 /media/floppy noauto,user,sync 0 0


Cheers,
Tink
 
Old 10-18-2006, 01:01 PM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
Quote:
Originally Posted by Tinkster
Your problem is that your fstab line has TOO MANY ENTRIES.
/dev/fd0/media/floppy auto noauto,user,sync 0 0
should be
/dev/fd0 /media/floppy noauto,user,sync 0 0


Cheers,
Tink
Are you sure?? the "auto" is for automatic detection of the filesystem, and the "noauto" means don't mount at boot........(I think... )
And of course that missing space between fd0 and /media.....

Some of the other fstab entries have missing spaces

To help understand the structure of fstab, look at this simple example:

device mountpoint filesystem defaults 0 0 (Only the 1st 4 fields are required--n'est-ce pas??)

This works for just about anything that is going to be automatically mounted at boot time.
So to mount the floppy at mountpoint "/media/floppy", the simplest construction would be:

/dev/fd0 /media/floppy auto defaults 0 0

Check my posting history and you will see my error rate---Caveat Emptor!!!
 
Old 10-18-2006, 05:59 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,950
Blog Entries: 11

Rep: Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860
Quote:
Originally Posted by pixellany
Are you sure?? the "auto" is for automatic detection of the filesystem, and the "noauto" means don't mount at boot........(I think...;) )
I am quite sure. Even though your statement is correct it has nothing to
do with the fact that the auto (separated from the other group of options
with whitespace) makes for one column too many for an fstab-entry.


Cheers,
Tink
 
Old 10-19-2006, 03:51 PM   #7
mikescony
LQ Newbie
 
Registered: Oct 2006
Location: Chicago
Distribution: suse 10.0
Posts: 23

Original Poster
Rep: Reputation: 15
Hello tinkster, pixellany, and linux world well so far I have the drive mounting (manually)

using this gedit /etc/fstab:
/dev/fd0 /media/floppy auto rw,users,umask=000 0 0

this gets the drive mounted manually.......
Now any tips on automounting the floppy....

So far this is really fustrating, But FUN
 
  


Reply

Tags
hardware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help need to mount floppy drive paschal83 Linux - Laptop and Netbook 7 12-01-2003 07:22 AM
Can't mount floppy drive crudux_cruo Linux - Laptop and Netbook 1 11-25-2003 03:40 AM
My floppy drive is not mount. m_pahlevanzadeh Linux - Hardware 2 06-20-2003 09:30 AM
why is UT 2003 trying to mount my floppy drive? the anti-riced Linux - Software 6 06-12-2003 08:23 PM
Can not mount my floppy drive. drfeelgood Linux - Newbie 4 10-22-2001 09:01 AM


All times are GMT -5. The time now is 07:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration