LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-13-2009, 01:32 PM   #1
rz1988
LQ Newbie
 
Registered: Dec 2008
Location: West Texas
Posts: 15

Rep: Reputation: 0
can't make ethernet on laptop work, wireless and usb work fine ubuntu 8.10


I have been running Ubuntu 8.10 for a couple of weeks. I can access wireless networks easily. I can access wired networks easily when the wired is plugged into my usb docking station. But I can not access wired networks when plugged into the ethernet port on my laptop. Any ideas?
 
Old 01-13-2009, 01:47 PM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
some more info would be usefull
ifconfig
iwconfig
route
firewall?
....

My guess is the firewall though
 
Old 01-13-2009, 02:01 PM   #3
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
hi,

try

Code:
sudo /etc/init.d/networking restart
Code:
sudo ifup eth0
and check

Code:
sudo netstat -rn

and what configuration do have DHCP or static...

explain your problem a bit in depth would make helping you very easy.

Cheers!!
 
Old 01-13-2009, 02:02 PM   #4
rz1988
LQ Newbie
 
Registered: Dec 2008
Location: West Texas
Posts: 15

Original Poster
Rep: Reputation: 0
I am in a motel, so I am not sure about the firewall. I have no problem with windows connecting. It says it connects, but no websites will come up. ifconfig shows it connected, but no data going either way. I have followed the offline help, but since I can't get online my help sources are diluted.

Sorry it is hard to report in depth. I have to restart into windows to get to this site and I have to write down the commands and configurations each time.

Last edited by rz1988; 01-13-2009 at 02:22 PM.
 
Old 01-13-2009, 02:02 PM   #5
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Oh in that case it sounds like a DNS issue..

cat /etc/resolv.conf

Last edited by farslayer; 01-13-2009 at 02:04 PM.
 
Old 01-13-2009, 02:20 PM   #6
rz1988
LQ Newbie
 
Registered: Dec 2008
Location: West Texas
Posts: 15

Original Poster
Rep: Reputation: 0
baig I get ignoring unknown interface eth0=eth0 It is using the automatic setup, that is what worked on the other 2 connections.
 
Old 01-13-2009, 02:21 PM   #7
rz1988
LQ Newbie
 
Registered: Dec 2008
Location: West Texas
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by farslayer View Post
Oh in that case it sounds like a DNS issue..

cat /etc/resolv.conf
I ran the dns choices in the offline help, it connects but gets no throughput.
 
Old 01-13-2009, 02:34 PM   #8
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Lets start from the beginning.
do you get an ip?
Quote:
ifconfig
can you ping the default gw?
can you ping to the outsite
Quote:
ping 212.100.160.51
can you ping on name?
Quote:
ping www.google.com
 
Old 01-13-2009, 02:58 PM   #9
rz1988
LQ Newbie
 
Registered: Dec 2008
Location: West Texas
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by repo View Post
Lets start from the beginning.
do you get an ip?

can you ping the default gw?
can you ping to the outsite

can you ping on name?
I get an ip, it says it connects but no websites will open. After a couple of minutes it shows disconnected.

ifconfig
link encap: ethernet Hw addr 00:16:d4:1b:f3:8b
up broadcast running multicast mtu:64 metric:1
rx packets:3 errors:0 dropped:0 overruns:0 frame:0
tx packets:8 errors:0 dropped:0 overruns:0 frame:0
collisions:0 txqueuelen:1000
rx bytes:1240 (1.2 kb) tx bytes:1921 (1.9 kb)
interrupt:219 base addressx8000

ping 212.100.160.51
network unreachable

ping www.google.com
unknown host
 
Old 01-13-2009, 03:02 PM   #10
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Quote:
I get an ip
which ip? I don't see any in ifconfig
 
Old 01-13-2009, 03:21 PM   #11
rz1988
LQ Newbie
 
Registered: Dec 2008
Location: West Texas
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by repo View Post
which ip? I don't see any in ifconfig
I think I get an ip, but i wrote everything that was in the ifconfig
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Netgear Wireless USB dongle WPN111 (Atheros chipset) to work on Ubuntu 6.06 mouzy93 Linux - Wireless Networking 6 09-11-2010 09:12 PM
Setting up Linux (Ubuntu) to work with Dell Truemobile 1300 USB Wireless Adaptor IBUA Linux - Networking 2 04-03-2009 11:38 PM
will d-link wireless-g USB work on old laptop running Zenwalk? cbauer86 Linux - Hardware 1 01-06-2007 05:11 PM
Will Ubuntu Work work With my Wireless Card? PulsarSL Ubuntu 3 10-07-2005 11:33 PM
Wireless internet doesn't work on laptop at school (Ubuntu 5.04) dbzsongoku Linux - Newbie 1 06-24-2005 02:47 PM


All times are GMT -5. The time now is 11:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration