LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-14-2005, 10:41 AM   #1
salviadud
Member
 
Registered: Feb 2005
Location: Mexico
Distribution: Slackware 14.1 [3.x]
Posts: 182

Rep: Reputation: 30
can't load proper keybord config on slackware 10.1


when i boot my machine and i'm at the terminal my keyboard is correct, i'm from mexico and i use a latin american keyboard. in terminal it works fine

but, i load X and it just goes to the default english.

im wondering if i need to do something to the xorg.conf file

what should i do?
 
Old 03-14-2005, 11:06 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Are you using KDE or GNOME? You have to change the keyboard preferences from the KDE Control Center or GNOME Preferences, if your keyboard works fine in console mode.
 
Old 03-14-2005, 11:11 AM   #3
salviadud
Member
 
Registered: Feb 2005
Location: Mexico
Distribution: Slackware 14.1 [3.x]
Posts: 182

Original Poster
Rep: Reputation: 30
actually, im using xcfe
and the other option that comes out besides default, is Emacs

is that the one?
 
Old 03-14-2005, 11:11 AM   #4
xowl
Member
 
Registered: Jan 2005
Distribution: Slackware current (and others)
Posts: 188

Rep: Reputation: 30
there is a much better way to fix it:


edit the file /etc/X11/xorg.conf and change

Option "XkbLayout" "us"

to


Option "XkbLayout" "la"

and thats all
 
Old 03-14-2005, 11:21 AM   #5
salviadud
Member
 
Registered: Feb 2005
Location: Mexico
Distribution: Slackware 14.1 [3.x]
Posts: 182

Original Poster
Rep: Reputation: 30
thanx a lot , i added that line to he keyboard section

i didn't even have a xkblayout option... weird
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
proper kernel config - using an oldconfig Godsmacker777 Linux - General 7 06-05-2005 12:11 AM
Keybord not working ValidiusMaximus Linux - Laptop and Netbook 0 01-05-2005 04:07 PM
Slackware can't address proper RAM? aegisorion Slackware 2 01-02-2005 10:26 AM
Keybord layer Getafix Linux - Newbie 0 10-11-2004 08:28 AM
How do i find the proper linux config file? justinfl General 2 10-08-2003 11:01 PM


All times are GMT -5. The time now is 06:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration