LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 01-29-2010, 01:59 PM   #1
LQ Newbie
Registered: Apr 2007
Posts: 1

Rep: Reputation: 0
Can't install Firefox 3.6 in suse 10 error

I downloaded and extracted it to a folder under my desktop. When I perform Desktop/firefox # ./firefox, i get: error while loading shared libraries: cannot open shared object file: No such file or director. I cannot seem to figure out haw to get this. Can anyone help a Linux newbie.

Old 01-29-2010, 05:43 PM   #2
Registered: Jan 2004
Location: Gießen, Germany
Distribution: Xubuntu 12.04, Mythbuntu, Ubuntu Server 12.04
Posts: 174

Rep: Reputation: 24
This means you don't have the appropriate version of libdbus installed.
Probably, libdbus-1-3 is not available for SUSE 10 at all, since 10.0 is out of support for over two years now.

This means you have to start compiling libdbus-1-3 for your system, and possibly a bunch of related tools - not much fun for a newbie.

The far better way would be upgrading to the current version of (Open)SUSE, which would keep the system in a consistent state and give you security updates when they appear.
Old 01-29-2010, 06:03 PM   #3
LQ 5k Club
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2015, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 15,906

Rep: Reputation: 3021Reputation: 3021Reputation: 3021Reputation: 3021Reputation: 3021Reputation: 3021Reputation: 3021Reputation: 3021Reputation: 3021Reputation: 3021Reputation: 3021
Welcome to LQ.

The latest version of firefox, I have been able to use on Suse 10.0
is 2.0.xx . I have the old 2.0.11 installed. The latest is probably 2.0.20 :
This package : mozilla-firefox- , can be used.

The later versions of firefox, 3.0.xx, 3.5.x, 3.6
are not working on Suse 10.

May be 3.0.xx will work with a dedicated version of ' ' ?
The instruction for building dbus-glib-0.73 >, etc. is here
> > post # 7.

Last edited by knudfl; 01-30-2010 at 04:38 PM.


firefox, suse10

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
libdbus-dev error while installing raphtor Linux - Newbie 5 01-18-2011 06:45 PM
configure: error: Couldn't find DBus >= 1.0.0, install libdbus-dev ? saroramay Linux - Newbie 1 09-20-2008 06:12 AM
vmware and libdbus error TheOneAndOnlySM Linux - Software 0 05-05-2008 03:39 PM
Can't find for Suse 10.1 Tillus SUSE / openSUSE 5 08-17-2007 11:08 AM
libdbus error lucky6969b Programming 2 05-23-2006 03:02 AM

All times are GMT -5. The time now is 09:31 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration