LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-19-2009, 10:30 PM   #1
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 648

Rep: Reputation: 78
can't get autofs to automount CD Drives


I have searched the forums and tried several gentoo autofs howtos. Still, I cannot get a cd to automount.

I can manually mount the drives, but autofs is just not picking my dvd-rom or dvd-rw drive on it's own.

Any suggestions on where to start with something that could help determine the problem?

/etc/fstab:
Code:
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda1      /boot      ext2      defaults,noatime   1 2
/dev/sda3      /      ext3      noatime      0 1
/dev/sda4       /home      ext3      noatime
/dev/sda2      none      swap      sw      0 0
/dev/cdrom      /mnt/cdrom   auto      noauto,ro,user   0 0
/dev/dvdrw      /mnt/dvd   auto      noauto,user   0 0
#/dev/FLOPPY      /mnt/floppy   auto      noauto      0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
shm         /dev/shm   tmpfs      nodev,nosuid,noexec   0
/etc/auto.auto:
Code:
#directory name      options for mount      device to mount
boot         -fstype=ext3         /dev/sda1
cdrom         -fstype=iso9660,ro      /dev/cdrom
/etc/auto.master:
Code:
#directory name      options for mount      device to mount
boot         -fstype=ext3         /dev/sda1
cdrom         -fstype=iso9660,ro      /dev/cdrom
/etc/auto.misc:
Code:
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage

cd      -fstype=auto,ro      :/dev/cdrom
dvd      -fstype=auto      :/dev/dvdrw
 
Old 12-19-2009, 10:57 PM   #2
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian jessie/sid; OpenSuSE; Fedora
Posts: 1,591

Rep: Reputation: 162Reputation: 162
take the noauto option out of the /etc/fstab lines for cdrom and dvdrw.
 
0 members found this post helpful.
Old 12-20-2009, 07:12 AM   #3
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 648

Original Poster
Rep: Reputation: 78
ok, well it is now Automounting.... Now for the next part, I'm not even sure what to call it. But in every other distro I've used, ubuntu, suse, fedora, slackware etc. When you put the cd in, it automounts and pulls the folder up automatically, so you don't have to navigate to the mounted location. My wife is not gonna have this, going to the file browser->mnt->auto->cdrom. Any ideas what makes this work?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Autofs/Automount configuration problems Ccielogs Linux - Server 2 09-11-2009 02:21 AM
SELinux Message when trying automount/autofs louisb Linux - Security 1 07-28-2007 04:27 AM
Autofs and automount socks Linux - Software 0 07-20-2004 12:28 PM
samba & autofs (automount) acb67 Linux - Networking 4 06-10-2004 10:57 AM
Setting up automount with autofs smattbac Slackware 0 10-12-2003 08:51 AM


All times are GMT -5. The time now is 09:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration