LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-06-2004, 08:09 PM   #1
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Rep: Reputation: 30
Can't enable MonMOtha's firewall!


I've got MonMotha's firewall setup, like i think it should, but when I try to execute it, it gives me the

"You've got to set ENABLE to "Y" if you want to do this,

then gives me the license information,

then prints the Enable statment again, then stops.

Argh!

What's going on ?! ENABLE is set to Y!
 
Old 10-06-2004, 09:02 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
are you using the current version.........2.3.8 ??
I'm looking at the one I find here......

http://monmotha.mplug.org/~monmotha/.../firewall/2.3/

that's a hellava script!! that guy took some time to code it...........
exactly what error are you getting........
did you make the script executable??? and have you recompiled the kernel
to include the listed SYSTEM REQUIREMENTS:
Code:
 You will need (at least) the following kernel options to use	|
# this firewall: CONFIG_NETFILTER, CONFIG_IP_NF_IPTABLES,		|
# CONFIG_IP_NF_FILTER, CONFIG_IP_NF_MATCH_STATE and			|
# CONFIG_IP_NF_TARGET_REJECT.						|
# 	To use the masquerading you will also need (at least):		|
# CONFIG_IP_NF_CONNTRACK, CONFIG_IP_NF_NAT, CONFIG_IP_NF_NAT_NEEDED	|
# and CONFIG_IP_NF_TARGET_MASQUERADE.

And have you installed IPTABLES!!!

Last edited by 320mb; 10-06-2004 at 09:04 PM.
 
Old 10-06-2004, 09:36 PM   #3
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
heh yes, to all.

I've got it fixed.... I must have messed something up. All it took was a delete then a clean copy to edit, and now it works.... sort of. having someproblems with my eth1,, but that's for a different post, if i can't find it after a search.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enable Firewall after Install? ctroyp Fedora - Installation 2 09-21-2005 08:06 PM
How to enable Outlook Express Mail Checking from Firewall Host wintoe Linux - Networking 3 08-20-2005 08:57 PM
Enable firewall to allow VNC connection tflovik Suse/Novell 2 05-29-2005 10:28 AM
How to enable ping after APF firewall install? acis Linux - Security 3 08-12-2004 03:43 PM
Enable gaming through firewall etvagonema Linux - Networking 2 03-28-2004 02:38 AM


All times are GMT -5. The time now is 04:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration