LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-21-2007, 02:24 PM   #1
haraldsf
LQ Newbie
 
Registered: May 2007
Location: Oslo, Norway
Distribution: Ubuntu
Posts: 11

Rep: Reputation: 0
Question Can't change screen resolution to 1280x1024 on Ubuntu with ATI Radeon Mobility X1600


I have an Asus A6J laptop with an external monitor. When I try to change the screen resolution in GNOME, I can choose between these resolutions:

1280x800
1024x768
800x600
640x480

How do I change the resolution to 1280x1024?




This is the first time I've tried Linux, so please be gentle
 
Old 05-21-2007, 06:18 PM   #2
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Rep: Reputation: 31
I had the same problem with my video card. You have to modify your xorg.conf located in /etc/X11/xorg.conf to allow for such a resolution.
An example of what you need to changes is this... Scroll down until you see something similar to this:
Code:
    Identifier     "Screen 1"
    Device         "VESA Framebuffer"
    Monitor        "My Monitor"
    DefaultDepth    24
    SubSection     "Display"
         Depth       24
         Modes     "1024x768" "800x600" "640x480"
    EndSubSection
And I needed to use the resolution of 1440x900 so I added just that:
Code:
    Identifier     "Screen 1"
    Device         "VESA Framebuffer"
    Monitor        "My Monitor"
    SubSection     "Display"
        Depth       24
        Modes      "1440x900" "1024x768" "800x600" "640x480"
    EndSubSection
All I added was the "1440x900". You have more sections such as 8, 16, 24, 32, but you most likely only use 24 (it is the default). But there is no need to delete them, just leave them there and only modify the Modes line. Modify your xorg.conf and dont forget the ""'s. Save it and restart X (Ctrl + Shift + Backspace). And enjoy your new screen resolution!

Hope this helps you out.
DragonM15

Last edited by DragonM15; 05-21-2007 at 06:24 PM.
 
Old 05-24-2007, 07:06 PM   #3
haraldsf
LQ Newbie
 
Registered: May 2007
Location: Oslo, Norway
Distribution: Ubuntu
Posts: 11

Original Poster
Rep: Reputation: 0
Thx for rapid reply...

The problem went away on its own, I think. I booted my computer without the external monitor connected, and behold, the resolution changed to 1280x800.
 
Old 05-27-2007, 09:28 AM   #4
Bobgster
LQ Newbie
 
Registered: May 2007
Posts: 4

Rep: Reputation: 0
Hello,

I need help.I just install linux Ubuntu and i have the same problem.I cant make my operating system work with resolution 1280x1024. I read the topic u wrote before some days but when i try do the same i had an error which said i dont have the permissions to change these file. What is it talking about lol!!
 
Old 05-27-2007, 09:52 AM   #5
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
It's a pretty vital system file so it's protected from regular users. If it needs to be edited, you have to get the permissions to do so. The magic word is: sudo.

So you do it like this:
make sure that gedit is installed; and then start a terminal and type

sudo gedit /etc/X11/xorg.conf

It will ask for your password and then it will launch the file in gedit.
 
Old 05-27-2007, 10:05 AM   #6
Bobgster
LQ Newbie
 
Registered: May 2007
Posts: 4

Rep: Reputation: 0
I still can't do it...Can u please be more specific? :/
 
Old 05-27-2007, 10:07 AM   #7
Bobgster
LQ Newbie
 
Registered: May 2007
Posts: 4

Rep: Reputation: 0
After i made the what i want how i save it again ???
 
Old 05-27-2007, 10:11 AM   #8
Bobgster
LQ Newbie
 
Registered: May 2007
Posts: 4

Rep: Reputation: 0
I did it !!!!!!!! Thank you very much!!!!!
But now i have to restart my computer and after the restart all will work ?
Thanks again pal!!
 
Old 05-27-2007, 01:34 PM   #9
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Yes, just restart although, in this case, a simple Ctrl + alt + backspace would do as well.

Btw, if you ever need to edit xorg.conf again, do make sure you don't make any typos (a missing blank space or comma can be enough). If you do, you may be unable to get back into your GUI - that can be solved but it's quite uncomfortable until you know your way about Linux a bit better. So always double-check before you either reboot or do the ctrl+alt+bacspace.
 
Old 05-28-2007, 12:53 PM   #10
haraldsf
LQ Newbie
 
Registered: May 2007
Location: Oslo, Norway
Distribution: Ubuntu
Posts: 11

Original Poster
Rep: Reputation: 0
I opened xorg.conf but 1280x1024 was already on the list:

ection "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
Defaultdepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1280x800" "1024x768" "800x600" "640x480"

I still can't set my resolution to 1280x1024 though.
Any ideas?
 
Old 05-28-2007, 01:45 PM   #11
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Check the "monitor" section for the VertRefresh and HorizSync values, i.e. the minimum and maximum vertical and horizontal refresh rates. Those are directly related to the kind of resolutions that are available; if the maximum rates are lower than what your monitor can actually support, you simply won't be able to get the higher resolutions. In my case, for a 19inch ACER LCD, the VertRefresh is 31-75 and HorizSync is 31-82. Yours may be different because these values vary from one type of monitor to the next. If you have a manual, check whether those values are specified somewhere - if not, search google (that's where I got mine).
 
Old 05-29-2007, 12:01 PM   #12
haraldsf
LQ Newbie
 
Registered: May 2007
Location: Oslo, Norway
Distribution: Ubuntu
Posts: 11

Original Poster
Rep: Reputation: 0
This is all there was in the monitor section:

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

I googled around and found the right vert. and horiz. sync values (56-75 Hz & 30-83kHz, respectively). Can I insert these values manually? If so, what's the right syntax?
 
Old 05-29-2007, 01:20 PM   #13
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Rep: Reputation: 31
my xorg.conf looks like this when it comes to vert/horiz sync values:
Code:
Section "Monitor"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
#    HorizSync  30-64         # multisync
#    HorizSync  31.5, 35.2    # multiple fixed sync frequencies
#    HorizSync  15-25, 30-50  # multiple ranges of sync frequencies
# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
    Identifier     "My Monitor"
    HorizSync       31.5 - 50.0
    VertRefresh     40.0 - 90.0
EndSection
Hope this helps you out a little bit.

DragonM15
 
Old 05-29-2007, 05:00 PM   #14
haraldsf
LQ Newbie
 
Registered: May 2007
Location: Oslo, Norway
Distribution: Ubuntu
Posts: 11

Original Poster
Rep: Reputation: 0
Tried it, but it didn't make any difference...
 
Old 05-30-2007, 12:31 AM   #15
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
No, of course not, vertical and horizontal refresh rates vary according to monitor brand / type. What works for one person, doesn't necessarily work for the other. For example , my own refresh rates (ACER 19 inch LCD) are 31-82 horizontal and 31-75 vertical...

Here is mine; it may work better considering that your monitor seems to have pretty much the same refresh rates as mine. This is a heavily modified xorg.conf as generated by Suse but it should work on any distro - it does for me. If you haven't installed the ATI driver yet, you need to locate the "Device" section and replace "fglrx" with "vesa" or you'll still end up with a blank screen. Then you can install the ATI driver and let it rewrite your xorg.conf or you can do so yourself. You may also receive some errors concerning the paths to your fonts but that shouldn't have any consequences. Also, most distros use video group 0666 instead of 0660 so you could adjust this before you actually give this file a try - unless you are using Suse, of course.

Quote:
# /.../
# SaX generated X11 config file
# Created on: 2007-05-26T04:03:58+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
FontPath "unix/:7100"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "IgnoreABI" "on"
Option "AIGLX" "off"
EndSection

Section "Module"
Load "dbe"
Load "fbdevhw"
Load "type1"
Load "freetype"
Load "record"
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
Load "GLcore"
Load "glx"
Load "v4l"
Load "dri"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "be"
Option "XkbModel" "pc104"
Option "XkbRules" "xorg" #"xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
# Option "Buttons" "9"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Logitech Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
# Option "CalcAlgorithm" "XServerPool"
Identifier "Monitor[0]"
ModelName "AL1951AS"
VendorName "ACER"
DisplaySize 380 300
HorizSync 31-82
VertRefresh 50-75
Option "DPMS" "true"
# UseModes "Modes[0]"
EndSection


#Section "Modes"
# Identifier "Modes[0]"
# Modeline "1280x1024" 138.54 1280 1368 1504 1728 1024 1025 1028 1069 +hsync +vsync
#EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "Radeon X1600 [RV530]"
BusID "1:0:0"
Driver "fglrx"
Identifier "Device[0]"
Option "FSAADisableGamma" "no"
Option "Capabilities" "0x00000000"
Option "ScreenOverlap" "0"
Option "mtrr" "off"
Option "FSAAScale" "1"
Option "ForceGenericCPU" "no"
Option "GammaCorrectionI" "0x00000000"
Option "CapabilitiesEx" "0x00000000"
Option "no_accel" "no"
Option "FSAACustomizeMSPos" "no"
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "FSAAEnable" "no"
Option "GammaCorrectionII" "0x00000000"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
Option "no_dri" "no"
Option "PseudoColorVisuals" "off"
Option "StereoSyncEnable" "1"
Option "UseInternalAGPGART" "no"
Option "Stereo" "off"
Option "CenterMode" "off"
Option "KernelModuleParm" "locked-userpages=0"
Option "FSAAMSPosX0" "0.000000"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosX1" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "FSAAMSPosX2" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosX3" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY5" "0.000000"
VendorName "ATI Technologies Inc"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
Option "DAMAGE" "false"
Option "Composite" "disable"
EndSection

Last edited by jay73; 05-30-2007 at 12:36 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black screen when trying to install ATI drivers on Radeon x1600 vangelis Linux - Hardware 6 03-25-2008 01:18 AM
ATI Mobility Radeon 9600 M10 on Ubuntu grandnagel Linux - Laptop and Netbook 2 08-07-2007 06:59 AM
Intel PRO/Wireless 3945ABG and ATI Mobility Radeon X1600 on Slackware 11 dizzi Slackware 21 05-21-2007 02:21 AM
Can't configure 1280x1024 resolution with Radeon X800 in XOrg in Ubuntu 5.10 habiblove Ubuntu 10 02-23-2006 04:35 PM
can't get resolution higher than 1024x768 using knoppix w/ ati mobility radeon 200m theknowledgeist Linux - Newbie 16 01-25-2006 02:17 AM


All times are GMT -5. The time now is 11:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration