LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-15-2012, 07:56 PM   #1
theADOLESCENT
LQ Newbie
 
Registered: Sep 2012
Posts: 16

Rep: Reputation: Disabled
Can't boot Wary Puppy Linux anymore, login: root (automatic login)


Hey guys, I had Wary Puppy 5.2.2 working and I used Gparter to give my drive a "boot flag" because I thought that would load up Wary Puppy right away instead of loading what I think is the grub loader.

Now I'm on a screen that says:

Wary Puppy Linux
Linux 2.6.32-uni [i686 arch]

puppypc10613 login: root (automatic login)
#

I can type stuff in now but I have no idea how to get back to the normal Wary Puppy Linux and taking that bootflag off.

Any help is appreciated.

By the way I have Wary Puppy linux on a full install, XP shouldn't be on the system anymore ( I know people say don't do this but it's what I did).

Thanks again.
-theadolescent
 
Old 09-15-2012, 08:05 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,988

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
What Desktop environment gnome3? If so
Quote:
startgdmd
or
Quote:
startx
 
Old 09-15-2012, 08:17 PM   #3
theADOLESCENT
LQ Newbie
 
Registered: Sep 2012
Posts: 16

Original Poster
Rep: Reputation: Disabled
Thanks, I typed that in, and it says
Starting X, specs in /etx/X11/xorg.conf, startup apps /root/.xinitrc...
Exited from X. Type "xwin [fvwm95:jwm]" to restart X ([ ] mean optional).
(To shutdown PC type "poweroff", to reboot PC type "reboot")
If X failed to start, type "xorgwizard" to set up x.

I tried xorgwizard, put in necessary information. Then I get

If X did not work, type "xorgwizard" to run video wizard again.
After that, type "xwin" to run X graphics mode.
Note, if X works but need sminor adjustment to the display, run the
Video Wizard from within X (in the Setup menu) -- module "xvidtune"
may be used, with caution, to finetune the display dimensions.

I type in xwin, then I get

Starting X, specs in /etx/X11/xorg.conf, startup apps /root/.xinitrc...
Exited from X. Type "xwin [fvwm95:jwm]" to restart X ([ ] mean optional).
(To shutdown PC type "poweroff", to reboot PC type "reboot")
If X failed to start, type "xorgwizard" to set up x.

again
 
Old 09-15-2012, 10:05 PM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,988

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
What Desktop environment gnome3?
 
Old 09-15-2012, 10:12 PM   #5
theADOLESCENT
LQ Newbie
 
Registered: Sep 2012
Posts: 16

Original Poster
Rep: Reputation: Disabled
startgdmd did not work, startx is what got it to attempt to start
 
Old 09-16-2012, 01:00 AM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,988

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
Quote:
Originally Posted by theADOLESCENT View Post
startgdmd did not work, startx is what got it to attempt to start
My
bad typo if you have gnome3 & gdm it would be startgdm3
 
Old 09-16-2012, 08:53 AM   #7
theADOLESCENT
LQ Newbie
 
Registered: Sep 2012
Posts: 16

Original Poster
Rep: Reputation: Disabled
Oh, okay.

startgdm3 doesn't work either.
 
Old 09-16-2012, 08:57 AM   #8
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,988

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
What Desktop environment?
 
Old 09-16-2012, 12:38 PM   #9
theADOLESCENT
LQ Newbie
 
Registered: Sep 2012
Posts: 16

Original Poster
Rep: Reputation: Disabled
I'm not sure. It's Wary Puppy Linux 5.2.2
 
Old 09-16-2012, 07:13 PM   #10
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,988

Rep: Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544Reputation: 544
Ijust downloaded puppy it uses jwm atleast wary does unless you changed it.
Try
Quote:
jwm -restart
Also have you tried changing boot flag back to the other partition?

Last edited by EDDY1; 09-16-2012 at 08:10 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LiveCD Demo needs Automatic Login as Root aquaguard Linux - Security 1 04-30-2006 03:44 PM
can't login as root anymore TranceDude Linux - Software 1 09-18-2005 06:08 PM
automatic login as root jagibbs Ubuntu 5 04-15-2005 08:15 PM
Cannot login as root anymore Schmurff Linux - Newbie 6 03-16-2004 12:59 AM
Automatic root login at start? Hogweed Linux - General 10 02-01-2002 08:38 AM


All times are GMT -5. The time now is 02:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration