LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-24-2005, 05:24 PM   #1
sstyl
LQ Newbie
 
Registered: Oct 2005
Location: Glygada, Attica, Hellas
Distribution: SUSE Linux 10.1
Posts: 9

Rep: Reputation: 0
Can't automount with charset


Hi, I am pretty new to linux (Suse 9.3, KDE 3.4.0 b, kernel 2.6) and have the following problem:
When I plug a USB flash disk, or a media card, linux mount it, but with no character set, so my files with Greek characters filename displayed with unread characters.

This is the following entries in mtab:
/dev/hda6 / reiserfs rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
tmpfs /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/hda1 /windows/C ntfs ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8 0 0
/dev/hda2 /windows/D vfat rw,noexec,nosuid,nodev,umask=0,utf8=true 0 0
usbfs /proc/bus/usb usbfs rw 0 0
/dev/hdb /media/SU930_001 subfs ro,nosuid,nodev,fs=cdfss,procuid 0 0
/dev/fd0 /media/floppy subfs rw,nosuid,nodev,sync,fs=floppyfss,procuid 0 0
/dev/sda1 /media/usbdisk subfs rw,nosuid,nodev,sync,fs=floppyfss,procuid 0 0
/dev/sdb1 /media/FLASH_DISK subfs rw,nosuid,nodev,sync,fs=floppyfss,procuid 0 0


and this is entries in fstab
/dev/hda6 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda2 /windows/D vfat user,umask=0,utf8=true 0 0
/dev/hda5 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid= 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/dvd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvdram /media/dvdram subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,users,fs=floppyfss,procuid,nodev,nosuid,sync,utf8=true 0 0
/dev/hdc2 /SuseLinux/c2 auto noauto,user 0 0
/dev/hdc3 /SuseLinux/c3 auto noauto,user 0 0
/dev/hdc1 /data2 swap pri=42 0 0

I wrote this in my fstab
/dev/sda1 /media/usbdisk subfs rw,nosuid,nodev,sync,fs=floppyfss,procuid,utf8=true 0 0
/dev/sdb1 /media/FLASH_DISK subfs rw,nosuid,nodev,sync,fs=floppyfss,procuid,utf8=true 0 0
but seems that automount is not read fstab.

So, i run (as root):
umount /media/usbdisk
umount /media/FLASH_DISK
and then
mount /media/usbdisk
mount /media/FLASH_DISK
After that, I can read my disks as utf8
But is not the best way to do this. I hope for something better.

This is the output when I type, as root:
test -e /etc/SuSEconfig/profile && . /etc/SuSEconfig/profile && locale -k charmap
charmap="UTF-8"

This is the following entries in /var/log/messages
Oct 24 23:09:26 linux kernel: usb 3-3: new high speed USB device using ehci_hcd and address 3
Oct 24 23:09:28 linux kernel: Initializing USB Mass Storage driver...
Oct 24 23:09:28 linux kernel: drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 3 if 1 alt 0 proto 2 vid 0x04B8 pid 0x0803
Oct 24 23:09:28 linux kernel: usbcore: registered new driver usblp
Oct 24 23:09:28 linux kernel: drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
Oct 24 23:09:28 linux kernel: scsi0 : SCSI emulation for USB Mass Storage devices
Oct 24 23:09:28 linux kernel: usbcore: registered new driver usb-storage
Oct 24 23:09:28 linux kernel: USB Mass Storage support registered.
Oct 24 23:09:28 linux kernel: usb-storage: device found at 3
Oct 24 23:09:28 linux kernel: usb-storage: waiting for device to settle before scanning
Oct 24 23:09:33 linux kernel: Vendor: EPSON Model: Stylus Storage Rev: 1.00
Oct 24 23:09:33 linux kernel: Type: Direct-Access ANSI SCSI revision: 02
Oct 24 23:09:33 linux kernel: SCSI device sda: 125440 512-byte hdwr sectors (64 MB)
Oct 24 23:09:33 linux kernel: sda: Write Protect is off
Oct 24 23:09:33 linux kernel: sda: Mode Sense: 0d 00 00 08
Oct 24 23:09:33 linux kernel: sda: assuming drive cache: write through
Oct 24 23:09:33 linux kernel: SCSI device sda: 125440 512-byte hdwr sectors (64 MB)
Oct 24 23:09:33 linux kernel: sda: Write Protect is off
Oct 24 23:09:33 linux kernel: sda: Mode Sense: 0d 00 00 08
Oct 24 23:09:33 linux kernel: sda: assuming drive cache: write through
Oct 24 23:09:33 linux kernel: sda: sda1
Oct 24 23:09:33 linux kernel: Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
Oct 24 23:09:33 linux kernel: Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0
Oct 24 23:09:33 linux kernel: usb-storage: device scan complete
Oct 24 23:09:34 linux /etc/hotplug.d/block/50-hwscan.hotplug[17091]: new block device /block/sda
Oct 24 23:09:34 linux /etc/hotplug.d/block/50-hwscan.hotplug[17136]: new block device /block/sda/sda1
Oct 24 23:09:34 linux hal-subfs-mount[17151]: registered at resmgrd and called(0) /bin/mount -t subfs -o fs=floppyfss,sync,procuid,nosuid,nodev,exec /dev/sda1 "/media/usbdisk"
Oct 24 23:09:43 linux hal.hotplug[17179]: DEVPATH is not set
Oct 24 23:09:46 linux hal.hotplug[17186]: DEVPATH is not set
Oct 24 23:09:50 linux kernel: usb 3-1: new high speed USB device using ehci_hcd and address 4
Oct 24 23:09:50 linux kernel: scsi1 : SCSI emulation for USB Mass Storage devices
Oct 24 23:09:50 linux kernel: usb-storage: device found at 4
Oct 24 23:09:50 linux kernel: usb-storage: waiting for device to settle before scanning
Oct 24 23:09:50 linux hal.hotplug[17214]: DEVPATH is not set
Oct 24 23:09:53 linux hal.hotplug[17266]: DEVPATH is not set
Oct 24 23:09:55 linux kernel: Vendor: JetFlash Model: TS512MJF2B Rev: 2.00
Oct 24 23:09:55 linux kernel: Type: Direct-Access ANSI SCSI revision: 02
Oct 24 23:09:56 linux kernel: SCSI device sdb: 1024000 512-byte hdwr sectors (524 MB)
Oct 24 23:09:56 linux kernel: sdb: Write Protect is off
Oct 24 23:09:56 linux kernel: sdb: Mode Sense: 03 00 00 00
Oct 24 23:09:56 linux kernel: sdb: assuming drive cache: write through
Oct 24 23:09:56 linux kernel: SCSI device sdb: 1024000 512-byte hdwr sectors (524 MB)
Oct 24 23:09:56 linux kernel: sdb: Write Protect is off
Oct 24 23:09:56 linux kernel: sdb: Mode Sense: 03 00 00 00
Oct 24 23:09:56 linux kernel: sdb: assuming drive cache: write through
Oct 24 23:09:56 linux kernel: sdb: sdb1
Oct 24 23:09:56 linux kernel: Attached scsi removable disk sdb at scsi1, channel 0, id 0, lun 0
Oct 24 23:09:56 linux kernel: Attached scsi generic sg1 at scsi1, channel 0, id 0, lun 0, type 0
Oct 24 23:09:56 linux kernel: usb-storage: device scan complete
Oct 24 23:10:00 linux /etc/hotplug.d/block/50-hwscan.hotplug[17345]: new block device /block/sdb
Oct 24 23:10:01 linux /etc/hotplug.d/block/50-hwscan.hotplug[17395]: new block device /block/sdb/sdb1
Oct 24 23:10:01 linux hal-subfs-mount[17410]: registered at resmgrd and called(0) /bin/mount -t subfs -o fs=floppyfss,sync,procuid,nosuid,nodev,exec /dev/sdb1 "/media/FLASH_DISK"
Oct 24 23:10:05 linux hal.hotplug[17421]: DEVPATH is not set
Oct 24 23:10:08 linux hal.hotplug[17426]: DEVPATH is not set
Oct 24 23:10:12 linux hal.hotplug[17432]: DEVPATH is not set
Oct 24 23:10:15 linux hal.hotplug[17435]: DEVPATH is not set

Last edited by sstyl; 10-25-2005 at 06:28 AM.
 
Old 10-25-2005, 10:27 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,516

Rep: Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501
Try
Code:
iocharset=utf8
instead of "utf8=true" in your fstab
 
Old 10-25-2005, 04:07 PM   #3
sstyl
LQ Newbie
 
Registered: Oct 2005
Location: Glygada, Attica, Hellas
Distribution: SUSE Linux 10.1
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by bathory
Try
Code:
iocharset=utf8
instead of "utf8=true" in your fstab
Thank you for your help.
I΄ve already try this, concretely I have a lot tryed, more from that I describe.
Has passed one month where I try to resolve this problem. Unfortunately submount (automount) dosn΄t read fstab.
 
Old 10-26-2005, 03:46 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,516

Rep: Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501
AFAIK autofs reads /etc/auto.master. So take a look at this file and find the map file it uses (perhaps /etc/auto.misc if you use the default installation). Edit auto.misc and add the option
Code:
-fstype=auto,iocharset=utf8
among the other options. Then restart autofs.
For more details:
Code:
man autofs

Last edited by bathory; 10-26-2005 at 05:57 AM.
 
Old 10-29-2005, 06:20 PM   #5
sstyl
LQ Newbie
 
Registered: Oct 2005
Location: Glygada, Attica, Hellas
Distribution: SUSE Linux 10.1
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by bathory
AFAIK autofs reads /etc/auto.master. So take a look at this file and find the map file it uses (perhaps /etc/auto.misc if you use the default installation). Edit auto.misc and add the option
Code:
-fstype=auto,iocharset=utf8
among the other options. Then restart autofs.
For more details:
Code:
man autofs
I have install autofs but Suse use only the submount and not the autofs.
In my /etc/auto.master and /etc/auto.misc, all the lines begin with #.
But I tryed something else:
I remove submount, reinstall autofs and remove # from auto.master and from floppy in auto.misc. I fix fstab (remove procuid,fs=floppyfss and in place of subfs I wrote autofs). Then I try to see my floppy, but nothing. I cannot mount and my PC slow down.

The problem is that I can't understand the hotplug - submount system of SUSE.
 
Old 10-30-2005, 09:15 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,516

Rep: Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501
I cannot help you with Suse submount (maybe someone can) but for automount you don't have to edit anything in /etc/fstab, since automount does not use it.
Take a look here, edit /etc/auto.master and /etc/auto.misc accordingly and (re)start automount.

Regards
 
Old 11-07-2005, 06:02 AM   #7
sstyl
LQ Newbie
 
Registered: Oct 2005
Location: Glygada, Attica, Hellas
Distribution: SUSE Linux 10.1
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by bathory
I cannot help you with Suse submount (maybe someone can) but for automount you don't have to edit anything in /etc/fstab, since automount does not use it.
Take a look here, edit /etc/auto.master and /etc/auto.misc accordingly and (re)start automount.

Regards
Thank's for all.
I find the solution. I had a mistake when installed Suse. I had select utf8. This is wrong, because I need iso8859-7.
So, I change with YaST sysconfig Editor this lines:
LANG=el_GR.UTF-8 with el_GR
LC_CTYPE=el_GR.UTF-8 with el_GR.
and at the next start of Suse the problem was solved.
Those files I had great with UTF8 and now I can't read their filenames, I convert with convmv from UTF8 to ISO8859-7.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
charset in Apache 2 swmok Linux - Software 2 06-14-2005 02:57 AM
Where canI get? jmdlcar Slackware 1 05-19-2005 02:32 AM
Trouble with charset? dreamtheater Linux - Software 2 07-15-2004 07:12 AM
BMP Charset gamehack Slackware 0 04-26-2004 10:58 AM
Charset in MySQL YMJ Programming 1 03-26-2003 04:35 PM


All times are GMT -5. The time now is 06:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration