LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-02-2003, 02:18 PM   #1
Fin-Fin
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Rep: Reputation: 0
Cant write on new HD


Ive had a windows HD installed (FAT 32)everything was fine, but I cant do any Actions on it. I can read the files, but thats all. I cant create Folders or so. Im using Suse 8.2 with KDE.
 
Old 07-02-2003, 02:24 PM   #2
aherm
Member
 
Registered: Jan 2003
Location: upNorth
Distribution: openSuSE/uBuntu
Posts: 410

Rep: Reputation: 30
Can you post your:

/etc/fstab

Maybe it's on ro (read only) mode.
 
Old 07-02-2003, 03:39 PM   #3
Fin-Fin
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Im sorry, but Im a reeal noob in Linux, so I dont know what you mean with /etc/fstab I wrote it in a shell window, but it said, Im not allowed to do this action
 
Old 07-02-2003, 03:44 PM   #4
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
well all you have to do is log into your terminal window as root, which is done by typing "su" and then type your root password, and then open up the file fstab which is located in the /etc folder (/etc/fstab) and copy and paste the contents of that file so we can see what it says in there...
some text editors are vi, pico, emacs to name a couple..
 
Old 07-02-2003, 04:51 PM   #5
aherm
Member
 
Registered: Jan 2003
Location: upNorth
Distribution: openSuSE/uBuntu
Posts: 410

Rep: Reputation: 30
Or using all mouse only: open konqueror, click home, click up twice, click etc folder, click fstab file (it will open in KWrite), block all, click copy.. and paste in Your Reply using midle click (all using mouse).

Last edited by aherm; 07-02-2003 at 04:56 PM.
 
Old 07-03-2003, 11:01 AM   #6
Fin-Fin
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Original Poster
Rep: Reputation: 0
All right, here is my fstab:

/dev/hda6 / reiserfs defaults 1 1
/dev/hda1 /windows/C vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0
/dev/hda5 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
/dev/cdrecorder /media/cdrecorder auto ro,noauto,user,exec 0 0
/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
/dev/hdc1 /home2 vfat defaults 0 0
/dev/hdb1 /temp vfat defaults 0 0
 
Old 07-03-2003, 11:22 AM   #7
Fin-Fin
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Original Poster
Rep: Reputation: 0
the 2 I cant edit are: home2 and temp
 
Old 07-03-2003, 11:49 AM   #8
aherm
Member
 
Registered: Jan 2003
Location: upNorth
Distribution: openSuSE/uBuntu
Posts: 410

Rep: Reputation: 30
Now edit it like this (you need to be root):
Change from:

/dev/hdc1 /home2 vfat defaults 0 0
/dev/hdb1 /temp vfat defaults 0 0

to:

/dev/hdc1 /home2 vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0
/dev/hdb1 /temp vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0

Have fun :-)
 
Old 07-03-2003, 11:53 AM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,938

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
There are tons of threads on how to mount vfat paritions read / write that you can search for on this site. But wait...

Look at your fstab entry for /dev/hda1. Use those options instead of defaults and but change umask=002 to umask=000.

Look at man pages for mount and fstab for additional help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
grip : no write access to write encoded file bidouilleur Linux - Software 5 10-09-2010 10:23 PM
Can't WRITE to USB stick, Mount OK NO WRITE! ClericPreston Linux - Newbie 4 12-04-2004 11:43 AM
Grip- "no write access to write encoded file" Alvis Linux - Software 4 01-06-2004 05:18 PM
Err if I tray Write Date To CD-Write Sn4s Linux - Newbie 2 07-23-2003 09:53 PM
Open office read only, K-write read/write mode lwtvh Linux - Newbie 1 07-19-2003 12:33 PM


All times are GMT -5. The time now is 10:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration