LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-19-2006, 01:29 PM   #1
jrmints
LQ Newbie
 
Registered: Aug 2006
Posts: 9

Rep: Reputation: 0
Can't stop X Server


I have been trying to download an Nvidia driver, but I keeping getting the error message that I need to end X Server. How do I do this?
 
Old 08-19-2006, 03:17 PM   #2
AzrielMacKay
Member
 
Registered: Jul 2001
Location: Moody, AL
Distribution: Debian and Kubuntu
Posts: 249

Rep: Reputation: 30
Well if you aren't running a display manager you can just hit cntl-alt-backspace. If you are running kdm or gdm though you can do /etc/init.d/kdm stop and then do the previous thing I mentioned (on debian based distros atleast, you didnt say what you're using)
 
Old 08-19-2006, 03:21 PM   #3
dangerboy
Member
 
Registered: Aug 2003
Distribution: Slackware 12.1, Slackware Current, Ubuntu Hardy Heron 8.04
Posts: 110

Rep: Reputation: 15
If you can't log out of your X Session to a command prompt, open a console in X and type:
Code:
su
Enter your root password, then type:
Code:
init 3
This should kick X off and bring you to a command prompt. Make sure your NVIDIA*.run file is saved to a convenient location. I usually like '/home/user/' and make sure it is executable with
Code:
chmod +x NVIDIA*.run
Run it and you should be good to go.
 
Old 08-20-2006, 03:07 PM   #4
jrmints
LQ Newbie
 
Registered: Aug 2006
Posts: 9

Original Poster
Rep: Reputation: 0
I'm running FC5, i tried the cntrl-alt-backspace, but I dont think that worked, any other ideas?
 
Old 08-20-2006, 06:52 PM   #5
dangerboy
Member
 
Registered: Aug 2003
Distribution: Slackware 12.1, Slackware Current, Ubuntu Hardy Heron 8.04
Posts: 110

Rep: Reputation: 15
Out of curiousity... have you (jrmints) tried my suggestion above? If so, what results did you get?
 
Old 08-21-2006, 06:13 PM   #6
jrmints
LQ Newbie
 
Registered: Aug 2006
Posts: 9

Original Poster
Rep: Reputation: 0
this is what happened

[jrmints@localhost ~]$ su
Password:
[root@localhost jrmints]# init 3
bash: init: command not found
[root@localhost jrmints]#

maybe it has to do with the distro?
 
Old 08-21-2006, 06:38 PM   #7
arturhawkwing
LQ Newbie
 
Registered: Dec 2005
Distribution: SourceMage
Posts: 8

Rep: Reputation: 0
What distro do you use? differant distros handle init differantly.
 
Old 08-21-2006, 07:49 PM   #8
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,125

Rep: Reputation: 164Reputation: 164
It could be that by using su instead of su -, you didn't get root's environment settings. Try it with su - or use the full path to init (or telinit) - /sbin/init or /sbin/telinit
 
Old 08-21-2006, 07:59 PM   #9
dangerboy
Member
 
Registered: Aug 2003
Distribution: Slackware 12.1, Slackware Current, Ubuntu Hardy Heron 8.04
Posts: 110

Rep: Reputation: 15
After some Googling, I found a howto on NVIDIA drivers in FC. It recommends init 3. I think gilead is right, specific paths or 'su -' should do the trick. Here's the How To:

http://www.patheticcockroach.com/mpam4/index.php?p=36

It's for FC4 but unless FC5 is radically different, installation should be the same.

Let us know how it turns out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to stop X server C.Aymen Debian 17 11-13-2007 04:27 PM
Stop a server? esc_5p1d0r Linux - Newbie 1 06-18-2006 03:49 PM
Can't stop X server halldor_marson Linux - Hardware 3 06-20-2005 07:18 PM
Help me to stop X server Johnny77 Linux - Newbie 2 06-09-2004 10:39 PM
how to stop X server? Baklan Linux - Newbie 2 07-10-2003 07:07 PM


All times are GMT -5. The time now is 04:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration