LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2005, 11:01 PM   #1
King of Japan
Member
 
Registered: Jul 2003
Location: Lincoln Nebraska
Distribution: Redhat 9
Posts: 61

Rep: Reputation: 15
Can't Start X Windows. Font Problem?


I just installed Suse 10.00.
It took awhile but I got it figured out and was using it for a couple days.
Then I rebooted and now it won't get into X windows.

It ends at this warning,

could not init font path Path element /usr/X11R6/lib/X11/fonts/local
removing from list!

could not init font path Path element /usr/X11R6/lib/X11/fonts/CID
removing from list!

I think this isn't platform dependant since I've googled and there is a lot of stuff about this kind of error, but I haven't been able to find anything that works.

First I just commented out the ref to

/usr/X11R6/lib/X11/fonts/local and
/usr/X11R6/lib/X11/fonts/CID

in the /etc/X11/xorg file.

Although the, Could not init errors disappeared, it still didn't do anything.

Then I tried this ln -s /usr/share/X11/fonts /usr/X11R6/lib/X11/fonts
I saw it mentioned somewhere so I tried it. It didn't work.

I need a little help here. I will provide you with any additional info if you need it.

Help help.
 
Old 10-12-2005, 11:03 PM   #2
Gort32
Member
 
Registered: Sep 2004
Distribution: Slack!
Posts: 150

Rep: Reputation: 15
grep EE /var/log/Xorg.0.log
 
Old 10-12-2005, 11:03 PM   #3
narmida
Member
 
Registered: Mar 2005
Location: Alphen aan den Rijn , netherlands
Distribution: core
Posts: 57

Rep: Reputation: 15
is xfs deamon running ?
that is the font server of X
 
Old 10-12-2005, 11:08 PM   #4
King of Japan
Member
 
Registered: Jul 2003
Location: Lincoln Nebraska
Distribution: Redhat 9
Posts: 61

Original Poster
Rep: Reputation: 15
ok. I don't think the xfs server is running.
When I was looking through yast and I tried to start it because it said it wasn't running. I tried to start it and it wouldn't

Keep in mind for me too go back and forth between XP (now) and Suse. I have to a bit of HD swapping. So I will stay here and look for a little bit before I do the reccomendations and come back.


Was the grep command for me to execute it and post the results here?
 
Old 10-12-2005, 11:52 PM   #5
King of Japan
Member
 
Registered: Jul 2003
Location: Lincoln Nebraska
Distribution: Redhat 9
Posts: 61

Original Poster
Rep: Reputation: 15
Ok,
xfs is currently disabled.
if i try to enable it using yast, I get this error message

/etc/initd/xfs start
returned 7 (program not running)
starting X Font Serverfind: /tmp/.font-unix: no such file or directory /tmp/.font-unix


well there is a directory /tmp/.font-unix but it's empty.


I also have a copy of xorg.0.log too, but it's pretty long. Do you want I should post the whole thing, or some section in particular?

Thank you
Thank you.
 
Old 10-13-2005, 07:34 AM   #6
Gort32
Member
 
Registered: Sep 2004
Distribution: Slack!
Posts: 150

Rep: Reputation: 15
grep searches for and returns lines that contain a specified substring. In this case it would look for any line that contains 'EE' - in the Xorg.0.log file, lines that contain this marker are errors and are likely the most relevent part of the log when you are having problems.
 
Old 10-13-2005, 12:05 PM   #7
King of Japan
Member
 
Registered: Jul 2003
Location: Lincoln Nebraska
Distribution: Redhat 9
Posts: 61

Original Poster
Rep: Reputation: 15
Oh, ok.
No instances of EE in the file.

Just let me know if there is anything you want to look at it.
 
Old 10-13-2005, 05:23 PM   #8
King of Japan
Member
 
Registered: Jul 2003
Location: Lincoln Nebraska
Distribution: Redhat 9
Posts: 61

Original Poster
Rep: Reputation: 15
I just ended up re-installing it.
It seemed to install a lot better this time.

maybe the Update pacthes screwed stuff up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
big problem! tried a live cd, windows won t start anymore lek General 2 09-03-2005 12:44 PM
How do I start X Font Server? DustinH Debian 2 12-11-2003 07:49 AM
font problem with openoffice windows fonts Pete Dogg Linux - Software 8 11-02-2003 05:12 AM
XFree doesn't start - fixed font not found danny_kurniawan Linux - Software 2 09-25-2003 12:52 AM
Font size of WIndows under RH 80 fischtoeter Linux - General 3 11-28-2002 04:23 AM


All times are GMT -5. The time now is 12:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration