LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-26-2008, 02:53 PM   #1
JasonC10203
Member
 
Registered: Sep 2007
Distribution: GRML 1.1
Posts: 56

Rep: Reputation: 15
Can't shut down my computer


I installed GRML and after using it for a while, I suddenly became unable to shut down the computer.

My shutdown method was to simply enter "halt" at the terminal prompt.

This worked for several weeks.

Then one day, I typed "halt" and pressed Enter and it started doing its thing like normal and then I got the following two lines:

There are no more processes left in this runlevel
Cannot execute /etc/init.d/grml-halt
_


The underscore above represents my cursor. It just hangs there and I have to pull the power to get my computer to power down.

This has happened twice. The first time, I just reinstalled the whole OS and everything was fine until now. I just recently installed Pidgin and the next time I went to shut down, I got the above error. I don't know if this has anything to do with it or not.

If anyone has any ideas, I would greatly appreciate it.

Thanks


Jason
 
Old 08-27-2008, 08:10 AM   #2
ernst
Member
 
Registered: May 2006
Location: Sydney
Distribution: Debian etch, SkoleLinux
Posts: 77

Rep: Reputation: 15
Hi Jason,
Did you try:

/sbin/shutdown -h now

for explanation see
man shutdown

Disclaimer: I do not know GRML or Pidgin

/etc/init.d/grml-halt
is probably a script.
Does it exist?
ls -l /etc/init.d/grml-halt
does it have execution permission?

Greetings
Ernst
 
Old 08-27-2008, 08:19 AM   #3
JasonC10203
Member
 
Registered: Sep 2007
Distribution: GRML 1.1
Posts: 56

Original Poster
Rep: Reputation: 15
Hey enrst.

Thanks for the reply. I asked around a bit more and it turns out that /etc/init.d/grml-halt is a symbolic link to /etc/init.d/grml-reboot which is a script. So all I had to do was recreate a symlink called grml-halt that was pointing to grml-reboot and my problem was fixed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What would cause a computer to shut off? davidguygc Linux - Hardware 30 07-22-2007 12:05 AM
Can't shut down the computer emereck Linux - Newbie 6 04-22-2006 12:52 AM
Computer doesn't turn off after shut down... figfighter Mandriva 3 07-22-2005 02:04 AM
HELP! -> Computer won't shut down! chocobanana Linux - Hardware 19 03-24-2005 09:15 AM
Computer Won't Shut Down djabbot Linux - General 3 01-11-2005 01:07 AM


All times are GMT -5. The time now is 06:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration