LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-09-2004, 01:25 AM   #1
retarded
LQ Newbie
 
Registered: Nov 2003
Location: Sydney, Australia
Distribution: Slackware 10.2
Posts: 19

Rep: Reputation: 0
Can't set console display mode to anything but VGA


I am trying to set my console display mode to 1024x768 but all i can get is VGA.
When i set the display mode to 1024x768x256 in liloconfig and reboot i get a message saying:

you passed an undefined mode number

I have an old S3 Trio 64 video card which i suspect is causing the problem, i can live without X but i assumed i could at least get a decent resolution in console on it.

Is this something that only gets set in lilo.conf or is there some other file i need to edit?

Any ideas?
 
Old 05-09-2004, 01:43 AM   #2
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Try just editing your /etc/lilo.conf file and change vga=normal to vga=773 then run lilo afterwards
 
Old 05-09-2004, 01:51 AM   #3
retarded
LQ Newbie
 
Registered: Nov 2003
Location: Sydney, Australia
Distribution: Slackware 10.2
Posts: 19

Original Poster
Rep: Reputation: 0
tried that already...if i set it to anything but vga=normal i get the "undefined mode number" error message
 
Old 05-09-2004, 01:56 AM   #4
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Have you got framebuffer compiled into your kernel?
 
Old 05-09-2004, 02:27 AM   #5
retarded
LQ Newbie
 
Registered: Nov 2003
Location: Sydney, Australia
Distribution: Slackware 10.2
Posts: 19

Original Poster
Rep: Reputation: 0
Yes it is, ive only had this problem since i changed the video card.
Apparently i need a Vesa 2.0 compliant card to use the framebuffer driver and i dont think the S3 is.
 
Old 05-09-2004, 02:29 AM   #6
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Then AFAIK you can only use vga=normal so i dont think you can get a better resolution
 
Old 05-09-2004, 02:42 AM   #7
retarded
LQ Newbie
 
Registered: Nov 2003
Location: Sydney, Australia
Distribution: Slackware 10.2
Posts: 19

Original Poster
Rep: Reputation: 0
oh well...thanks anyway
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I change display mode from character mode to graph mode wuzhong Linux - Hardware 1 08-08-2004 10:36 AM
How To Edit My /etc/inittab To Boot Into VGA console mode (non-X) CAL Linux - Newbie 3 04-06-2004 08:06 AM
VGA console ---> bulliver Linux - General 3 03-11-2004 05:51 PM
Console vga mode problem after X logout Iskendar Linux - Software 6 12-08-2003 03:24 AM
how to edit VGA mode ? futurist Linux - Software 3 04-04-2002 01:43 AM


All times are GMT -5. The time now is 05:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration