-   Linux - Newbie (
-   -   Can't send print jobs from win to Cups (

Deluka 07-17-2009 06:24 AM

Can't send print jobs from win to Cups
Hey there
I have some problem with CUPS. I'm using Fedora11
From the my localhost everything prints fine.
On my xp box the jobs always fail but the cups logs says everything is done just fine.
In vista i can't even connect to the CUPSD.
On my eeepc with Ubuntu i see the print server but its marked with a "Do Not Enter" sign.
I wanna use CUPS without the use of SAMBA.
Done some looking around but nothing so far
Is there anyone how can set me in the right direction?

scottro11 07-18-2009 06:35 PM

I've only done it with samba, but I'll throw this one out in case you get no working answers. (Unlikely on these forums, but ya never know)

One can add the line

use client driver = yes

to smb.conf

I *do* realize you said you don't want to use samba, again, I'm just putting this suggestion in case nothing else works.

Deluka 07-19-2009 12:18 AM

Well i'm still looking some help or maybe a "good" howto.
Yes i have been searching trough Google and even Bing and the once i have found done't work for me.
Scottr thanks for the answer, i'm going to take a look at it
But since i don't even have SMB installed, i don't think its going to do anything for me.
It must be something really simple that i miss.
So this is what i have so far.
  • From all my systems i can connect to the queue with a browser.
  • Cups running on fedora 11 and i can print local (but not in Firefox, this is a know bug).
  • Windows XP - It seems that i can connect but all my jobs fail and they are kept in the local queue.
  • Windows Vista - Can't even connect but i can view my queue trough a browser.
  • Windows 7 - The same thing as in Vista.
  • Ubuntu 9.04 - I see the printerserver but can't verify the connection.

Well thats it more or less, by the way do i need to install a cups drive on my MS systems?

jdkaye 07-19-2009 12:37 AM

Google is your friend.

Deluka 07-19-2009 12:52 AM

Thanks for the reply Jdkaye
Like i told in my previos post i already looked arround using my best frind Google and even MS there attempt of a search engine.(Bing)
Found the how2 you posted to, it was the first one i tried but with no result so far
But going to get me lots of heavy Java and read it again maybe i missed something.
Going to post the result when i'm done

jdkaye 07-19-2009 12:57 AM


Originally Posted by Deluka (Post 3612430)
But going to get me lots of heavy Java

The drink or the run time environment? ;)

Deluka 07-19-2009 08:39 AM

Still not working
Well done everything again but still no go. again i print local put not remote.

jdkaye 07-19-2009 09:00 AM

Any particular reason you don't want to use Samba? That's the standard solution.

Deluka 07-19-2009 11:34 AM

I now that is the easy way to solve the problem, but then i would learn nothing at all.
I'm building a small server from the ground up and already learned allot about Linux from all of the problems i encountered.
And also it can be done without the help of SMB.
I just need to find out whats going wrong now.
The link above is a bit old (2004) and some of the options you have to set can't be set because those options aren't there anymore.
So any idea's would be welcome

jdkaye 07-19-2009 12:05 PM

I have 0 experience connecting windows machines to printers running on linux without using Samba. I have loads of experience connecting linux machines to printers running on linux without using Samba. But that's easy. All I would do is google and search, google and search and see if there's any solution out there. If you say it can be done without using Samba then you already know more about it than I do. ;)

Deluka 08-01-2009 03:08 AM

Solved it
Well after looking around for days almost weeks i finally solved it myself.
Its really simple.
All i needed to do on the windows machines is add the "Unix client for printing".(rough translation from dutch)
This little piece of software can be found in the "add/remove windows parts" in the "add/remove software" panel in the controle panel directory.
After i done this i could use the printer as normal from all my windows systems.
So as i thought you really don't need Samba to share a printer trough a network.

Hope this helps other people facing the same problem.

All times are GMT -5. The time now is 11:53 PM.