LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-14-2004, 12:21 PM   #1
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Rep: Reputation: 15
Can't select Parellel printer with Cups Admin or KDE Print Manager


What the topic says, basicly :/
In KDE Printing Manager, I select Local Printer in the box, and it has about 30 serial ports, 30 usb ports, and one parallel which doesn't put in a URI (parallel:/dev/lp0). When I put in my own uri, it says "The local uri doesn't correspond to a detected port. continue?"

I click yes...
Then I get this error...
Unable to change printer properties. Error received from manager:
The requested operation cannot be completed.

I have an Epson Stylus Color 660, and am using Gimp-Print drivers.
 
Old 02-16-2004, 07:08 PM   #2
Doug Miller
LQ Newbie
 
Registered: Dec 2003
Location: San Francisco/Petaluma, CA
Distribution: Slack 9.1
Posts: 1

Rep: Reputation: 0
If your printer is connected to your computer by a normal parallel-port printer cable, I think you should select the normal, plain vanilia, " parallel:/dev/lp0 "

( But what do I know? I've spent this whole weekend trying to get my printer set up, and it's not working yet. But it's getting close. ) Hang in there!
 
Old 07-23-2004, 05:55 AM   #3
jjge
Member
 
Registered: Jun 2003
Location: Kalkar, Germany
Distribution: Slackware
Posts: 81

Rep: Reputation: 15
I am having the same problem!

I am having the same problem. Moreover, I tried parallel:/dev/lp0 (/dev/lp0 exists) but it did not help. I also tried preloading lp.o and parport.o, to no avail
 
Old 07-25-2004, 04:11 PM   #4
TaylorVcl
LQ Newbie
 
Registered: Jul 2004
Posts: 27

Rep: Reputation: 15
Same problem

Hey man, have you figured an answer to this? I have the exact same issue.

There has to be some good reason why lp0 is not listed, and that any manual override
doesn't work. In addition, I have tried the command:

cat filename > /dev/lp0

and I get ascii out my printer. So, it isn't like lp0 is dead or something.
 
Old 07-26-2004, 03:06 PM   #5
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
I fixed this a bit ago by upgrading my kernel. For some reason it wasn't compiled into the kernel, and I couldn't find a module for it. Just make sure if you do upgrade your kernel, you select the Parellel port support
 
Old 07-27-2004, 01:58 PM   #6
jjge
Member
 
Registered: Jun 2003
Location: Kalkar, Germany
Distribution: Slackware
Posts: 81

Rep: Reputation: 15
I fixed it in a similar way. In make menuconfig I set the following entries from <M> to <*>:
Character devices -> parallel printer support
Parallel port support and PC-style hardware.
I have not tried to figure out which one is really necessary, but with this mod, it works.
 
Old 08-16-2004, 08:29 PM   #7
jcomeau_ictx
LQ Newbie
 
Registered: Aug 2004
Location: Petaluma, CA, US
Distribution: Debian GNU/Linux squeeze/sid
Posts: 28

Rep: Reputation: 17
Quote:
Originally posted by jjge
I fixed it in a similar way. In make menuconfig I set the following entries from <M> to <*>:
Character devices -> parallel printer support
Parallel port support and PC-style hardware.
I have not tried to figure out which one is really necessary, but with this mod, it works.
Another possibility for some of these problems is to modprobe the necessary modules, in my case parport_pc wasn't being loaded automatically, though both parport and lp (once I went back and reconfigured the kernel conf with it!) were loaded when rc.cups (slackware 9.1) ran.

Here is the patch for rc.cups:

--- ./rc.cups.orig 2003-08-25 23:42:39.000000000 +0000
+++ ./rc.cups 2004-08-17 01:17:53.000000000 +0000
@@ -159,6 +159,8 @@

case $1 in
start | restart | reload)
+ modprobe -q parport_pc &>/dev/null
+ modprobe -q lp &>/dev/null
if $IS_ON cups; then
if test "$pid" != ""; then
kill -HUP $pid
@@ -183,6 +185,9 @@
$ECHO_OK
$ECHO "cups: stopped scheduler."
fi
+ modprobe -qr lp &>/dev/null
+ modprobe -qr parport_pc &>/dev/null
+ modprobe -qr parport &>/dev/null
;;

status)
-----snip here-----

Hope this helps someone. It won't help anyone who can already cat a file to /dev/lp0 though, because if you can do that either the modules are already loaded or the kernel has the support built in.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS finds printer, won't print esp Slackware 5 07-14-2005 02:28 AM
CUPS: Cannot print to remote printer nazarioz Linux - General 16 01-12-2005 09:11 PM
parrellel printer in CUPS? No parellel printer option... servnov Linux - General 3 10-31-2004 02:08 PM
OfficeJet G85, CUPS Web based Admin test print works, lpr/lp dose not. ptal-print OK. NLR Linux - Hardware 2 09-20-2004 02:59 PM
KDE 3.2.3 Print Manager not detecting printer? m_lp_ql_m Linux - Hardware 0 08-23-2004 09:58 PM


All times are GMT -5. The time now is 07:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration