LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-14-2014, 03:08 AM   #1
m1ckrz
LQ Newbie
 
Registered: Apr 2014
Posts: 2

Rep: Reputation: Disabled
Can't seem to SSH from Mint into Server 2008


Trying to SSH into Win Server 2008 from Linux Mint. Running FreeSSHD (SSH required, password disabled) on port 2222.

I have public key in FreeSSHD\keys
Private key in %HOME%\user\.ssh

When I try to SSH from terminal, key passphrase is accepted but then it requests "user password". Windows user password returns "Permission denied".

As far as I can tell everything is configured correctly. I can only assume it is a permissions issue, but my user is a domain admin and I have allowed necessary ports, firewall rules, etc.

Any help will be greatly appreciated. Thanks!

Last edited by m1ckrz; 09-14-2014 at 03:24 AM.
 
Old 09-14-2014, 02:11 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
You can run ssh with the "-v" option (for verbose). You can use "v" up to 2 times (e.g. "ssh -vvv user@host") to get increasingly more verbose debug information. I'm not sure how much it will help, though. This looks like an issue on the Windows end and not the Linux side. Is there a way to run FreeSSHD in debug mode? If so, that might provide some useful information about what's going on.
 
Old 09-14-2014, 06:15 PM   #3
m1ckrz
LQ Newbie
 
Registered: Apr 2014
Posts: 2

Original Poster
Rep: Reputation: Disabled
Here's the output from terminal. This is with CYGWINN on Server '08. Same issue. "Permission denied". I have confirmed the correct passwords, both passphrase and Win user:

Code:
ssh -v -p 22 -i /home/m1ckrz/.ssh/id_rsa m1ckrz@10.11.1.22
OpenSSH_6.2p2 Ubuntu-6ubuntu0.4, OpenSSL 1.0.1e 11 Feb 2013
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 10.11.1.22 [10.11.1.22] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /home/m1ckrz/.ssh/id_rsa type -1
debug1: identity file /home/m1ckrz/.ssh/id_rsa-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.2p2 Ubuntu-6ubuntu0.4
debug1: Remote protocol version 2.0, remote software version WeOnlyDo 2.1.3
debug1: no match: WeOnlyDo 2.1.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: sending SSH2_MSG_KEXDH_INIT
debug1: expecting SSH2_MSG_KEXDH_REPLY
debug1: Server host key: RSA f6:cf:a9:fe:42:6e:21:73:84:1e:08:25:b7:b2:5b:38
debug1: Host '10.11.1.22' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: password,publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/m1ckrz/.ssh/id_rsa
debug1: key_parse_private_pem: PEM_read_PrivateKey failed
debug1: read PEM private key done: type <unknown>
Enter passphrase for key '/home/m1ckrz/.ssh/id_rsa': 
debug1: read PEM private key done: type RSA
debug1: Authentications that can continue: password,publickey
debug1: Next authentication method: password
m1ckrz@10.11.1.22's password: 
debug1: Authentications that can continue: password,publickey
Permission denied, please try again.
m1ckrz@10.11.1.22's password: 

debug1: Authentications that can continue: password,publickey
Permission denied, please try again.
m1ckrz@10.11.1.22's password: 
Received disconnect from 10.11.1.22: 2: Too many attempts.

Last edited by m1ckrz; 09-14-2014 at 06:17 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to connect to ms sql server 2008 from a linux mint 17 machine having unixodbc 2.2 ram avtar Linux - Newbie 1 08-22-2014 10:17 AM
[SOLVED] SSH SSO in Windows 2008 not working manyrootsofallevil Linux - Server 3 02-28-2012 01:55 PM
Unable to connect MS SQL server 2008 Remote Server through SQUID proxy server samank75 Linux - Server 5 01-19-2012 10:19 PM
LXer: The Perfect Server - Mandriva 2008 Spring Free (Mandriva 2008.1) LXer Syndicated Linux News 0 04-10-2008 05:10 PM
LXer: The Perfect Server - Mandriva 2008 Free (Mandriva 2008.0) LXer Syndicated Linux News 0 10-11-2007 10:41 PM


All times are GMT -5. The time now is 06:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration