LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-29-2003, 04:50 PM   #1
blaint
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Rep: Reputation: 0
Can't seem to get the right packages for a ./configure


Okay I'm stuck on this....

I'm trying to install "pan-0.14.0.93" I grabbed the source and do a ./configure and it tells me I need "gtk+-2.0 >= 2.0.5"

Okay, so no problem, I downloaded source for gtk+-2.2.4
do a ./configure there and it tells me it needs "glib-2.0 >= 2.1.4 atk>=1.0.1 pango >=1.0.1"

Okay so I grabbed "glib-2.2.3" and it gives me
that pkg-config too old I need version 0.14 or better

So I grabbed "pkgconfig-0.9.0"
did configure, make and make install, no errors.

Go back to glib-2.2.3 try it again and it still tells me pkg-config is too old.

So maybe I can take care of atk while I'm there, but I do an "rpm -qa | grep atk" and I get back "atk-1.2.0-2" which should exceend the version gtk was looking for.

Ditto when I do "rpm -qa | grep pango" I get back "pango-1.2.1-3" which again exceeds the version number that gtk complained about.

So if glib-2.2.3 would recognize my newer version of pkgconfig, I should be set right? Could anyone help me on that point? is there an old version of pkgconfig floating around that is messing it up? How can I tell and what do I do?

I thought I was finally getting the hang of this!

Thanks,
=Blain
 
Old 10-29-2003, 08:02 PM   #2
kasperhans
Member
 
Registered: Oct 2003
Location: right behind the moon
Distribution: gentoo
Posts: 466

Rep: Reputation: 30
what distribution are you using???
 
Old 10-29-2003, 09:15 PM   #3
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Rep: Reputation: 32
Re: Can't seem to get the right packages for a ./configure

Quote:
Originally posted by blaint
Okay so I grabbed "glib-2.2.3" and it gives me
that pkg-config too old I need version 0.14 or better

So I grabbed "pkgconfig-0.9.0"
did configure, make and make install, no errors.

Go back to glib-2.2.3 try it again and it still tells me pkg-config is too old.
9 is less than 14...you grabbed an older version The latest right now is 0.15, you can get it here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to configure apt-get to install suggested packages? davidas Debian 20 02-25-2013 12:59 AM
./configure problem & packages? Denwar Linux - Newbie 4 04-06-2004 12:04 PM
help installing ANYTHING... configure doesn't work bc I am missing lots of packages Avatar Linux - Software 30 12-08-2003 09:43 PM
Unable to configure new packages when upgrading. cirofren Linux - Newbie 0 10-27-2003 03:36 PM
Can I automate the tar, ./configure, make, and make install of about 50 packages? JoeLinux Linux - General 2 04-13-2002 03:35 AM


All times are GMT -5. The time now is 12:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration