LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-14-2004, 09:24 AM   #1
Geoff Cox
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 11

Rep: Reputation: 0
Unhappy Can't save files to FAT32 drive


Hi

I have Mandrake 9.2, but cannot save files to a FAT32 partition on a second drive on my PC, when I am logged in as user.

I have tried logging in as root - but get the same error message, that I do not have the permissions, even though, when I click on "Permissions" it says that I have write permissions.

I have seen similar questions on this format. Apologies if I am duplicating.

Best regards


Geoff
 
Old 02-14-2004, 12:24 PM   #2
RobertP
Member
 
Registered: Jan 2004
Location: Manitoba, Canada
Distribution: Debian
Posts: 454

Rep: Reputation: 32
How is the partition mounted? Perhaps it is mounted readonly...
mount
cat /etc/fstab
ls -l /dev/hdx or whatever device you use
Will show the desired information.
 
Old 02-14-2004, 12:59 PM   #3
Geoff Cox
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 11

Original Poster
Rep: Reputation: 0
Hi

They are all set to ro. It does not matter with some, as my C drive (with XP) is NTFS. The other drives I can use Partition Magic to convert to FAT32, as I have read that it can cause problems trying to write to NTFS drives.

Here is the result of the doing the cat /etc/ftstab:

/dev/hdb9 / ext2 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/cdrom supermount dev=/dev/hdc,fs=udf:iso9660,ro,--,iocharset=iso8859-15 0 0
none /mnt/cdrom2 supermount dev=/dev/scd0,fs=udf:iso9660,ro,--,iocharset=iso8859-15 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,codepage=850,iocharset=iso8859-15,sync,umask=0 0 0
/dev/hda1 /mnt/win_c ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hdb5 /mnt/win_c2 ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hda5 /mnt/win_d vfat ro,iocharset=iso8859-15,umask=0 0 0
/dev/hdb6 /mnt/win_d2 ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hda6 /mnt/win_e ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hdb7 /mnt/win_e2 ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hda7 /mnt/win_f ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hdb8 /mnt/win_f2 ntfs ro,iocharset=iso8859-15,umask=0 0 0
none /proc proc defaults 0 0
/dev/hdb10 swap swap defaults 0 0
[geoff@localhost geoff]$

How do I change the ones that I need to change?

Best regards

Geoff
 
Old 02-14-2004, 01:13 PM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
I assume that you want to write to hda5. If you are the only user on the computer, you may want to add the options uid=gcox,gid=gcox. I assumed that your user name is gcox, substitute your own user name or user/group id. If there are others you can create a group that will allow you to access this drive.
By using user and group permissions instead of the users option, The drive is more secure incase someone can gain remote access to your computer. However, I don't understand why root wasn't able to write to the drive.
Your fstab entry should then look like this:
Code:
/dev/hda5 /mnt/win_d vfat iocharset=iso8859-1,codepage=850,uid=gcox,gid=gcox,umask=0 0 0
Also, Mandrake sets up a group called fileshare for the purpose of sharing access to drives. To allow another user to access the drive, add the user to the fileshare group and change the fstab option to gid=fileshare.

Last edited by jschiwal; 02-14-2004 at 01:15 PM.
 
Old 02-14-2004, 01:17 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,265

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
If you have a vfat partition on your hdb then there isn't an entry in your /etc/fstab. Add a line like hda5.

Quote:
/dev/hda5 /mnt/win_d vfat ro,iocharset=iso8859-15,umask=0 0 0
BTW the option ro means readonly and umask=0 means read / write for all. Since umask is after ro option it will take precedence. Since NTFS module is read only umask=0 will not work.
 
Old 02-14-2004, 01:32 PM   #6
Geoff Cox
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 11

Original Poster
Rep: Reputation: 0
Hi

What do you recommend as an editor? I remember using vi many, many years ago when I was learning a bit of Unix - very unintuitive! I can use it, but if there is a simpler text editor, I would prefer to use it.

I assume that I just remove the ro from the string? I can also add the other things that you suggest.

Do the changes take immediate effect or do I need to reboot ?- spoken like an experienced Windows user!

Best regards and thanks


Geoff
 
Old 02-14-2004, 01:48 PM   #7
RobertP
Member
 
Registered: Jan 2004
Location: Manitoba, Canada
Distribution: Debian
Posts: 454

Rep: Reputation: 32
I recommend vi for its simplicity. You only need to know a couple of commands to use it for this purpose. "I" puts you in insert mode. <esc>:q or wq gets you out.

You can use a GUI like gedit or kate but many prefer not to use a GUI as root.
 
Old 02-14-2004, 03:08 PM   #8
Geoff Cox
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 11

Original Poster
Rep: Reputation: 0
Hi

I have tried editing /etc/fstab. I think that there should have been a comma after the vfat. However, now I cannot even open win-d.

Here is my fstab:

[geoff@localhost geoff]$ cat /etc/fstab
/dev/hdb9 / ext2 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/cdrom supermount dev=/dev/hdc,fs=udf:iso9660,ro,--,iocharset=iso8859-1 5 0 0
none /mnt/cdrom2 supermount dev=/dev/scd0,fs=udf:iso9660,ro,--,iocharset=iso8859 -15 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,codepage=850,iocharset= iso8859-15,sync,umask=0 0 0
/dev/hda1 /mnt/win_c ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hdb5 /mnt/win_c2 ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hda5 /mnt/win_d vfat,iocharset=iso8859-15,codepage=815,uid=geoff,gid=filesh are,umask=0 0 0
/dev/hdb6 /mnt/win_d2 ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hda6 /mnt/win_e ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hdb7 /mnt/win_e2 ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hda7 /mnt/win_f ntfs ro,iocharset=iso8859-15,umask=0 0 0
/dev/hdb8 /mnt/win_f2 ntfs ro,iocharset=iso8859-15,umask=0 0 0
none /proc proc defaults 0 0
/dev/hdb10 swap swap defaults 0 0
[geoff@localhost geoff]$

What have I done wrong? Just to say that I have put spaces after each comma, which is how it looks in the terminal view.

When I go into Mandrake Control Centre, and look at the mount option, it identifies the drive as:

Type: vfat,iocharset=iso8859-15,codepage=815,u

This does not seem correct.

Any thoughts?

Best regards


Geoff
 
Old 02-14-2004, 03:14 PM   #9
Geoff Cox
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 11

Original Poster
Rep: Reputation: 0
I have just seen that I have misspelled fileshare as filesh are!
 
Old 02-14-2004, 03:16 PM   #10
Geoff Cox
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 11

Original Poster
Rep: Reputation: 0
Having said that, it may be the way in which the copy command worked, as the word fileshare went across to the next line.
 
Old 02-14-2004, 09:40 PM   #11
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,265

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
Quote:
/dev/hda5 /mnt/win_d vfat,iocharset=iso8859-15,codepage=815,uid=geoff,gid=filesh are,umask=0 0 0
There needs to be a space inbetween each section of an entry. You are correct there should be a space between vfat and iocharset=iso8859-15...
 
Old 02-15-2004, 10:51 AM   #12
Geoff Cox
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 11

Original Poster
Rep: Reputation: 0
Hi

In the original, there are spaces. What does the codepage=815 mean? Why do none of the others have it there?

Cheers

Geoff
 
Old 02-16-2004, 06:36 AM   #13
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Since FAT32 drives are windows creation, you want to use the same codepage that windows does.
 
Old 02-17-2004, 08:27 AM   #14
Geoff Cox
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 11

Original Poster
Rep: Reputation: 0
Hi

I decided that the simple way out was to change all my data drives to FAT32 and reinstall Linux, which I did, and now I can read and write to my data drives even as "user" and not root.

Many thanks for all those who helped me with their contributions.

Cheers

Geoff
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I save to fat32 with openoffice.org 1.1.3 writer? DeekBeek Linux - Software 5 07-23-2005 08:47 AM
OpenOffice 2.0: can't save files ltd602 Linux - Software 3 03-31-2005 04:05 PM
Hate to ask this...But, can anyone help me save my lost FAT32 partition? glenn69 Linux - General 13 06-17-2004 07:20 AM
Azeureus (Bittorrent) - cant save files to fat32 drives o.O nexx_au Linux - Software 2 02-06-2004 07:17 PM
Cannot Copy Files From Network FAT32/NTFS Drive to My Local Linux Drive michaelh Linux - Networking 3 10-29-2002 11:27 AM


All times are GMT -5. The time now is 04:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration