LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-16-2007, 05:00 PM   #1
mfurnanz
LQ Newbie
 
Registered: Jan 2007
Posts: 5

Rep: Reputation: 0
Unhappy Can't satisfy wxpython python2.4 dependencies - rpm database problem?


My goal was to intall Boa constructor, the Python debugger.

1) Running Fedora Core 4 (?):
$ cat /etc/redhat-release
Red Hat Enterprise Linux WS release 4 (Nahant Update 2)

2) Original version of Python was 2.2 (i think)
3) Had already installed Python 2.3 many months ago for another project
3) Recently installed Python 2.4 in preperation for wxpython (without erasing Python 2.3)

* With Python 2.4 installations, I get the following warnings:

$ sudo rpm -i -v python2.4-2.4.1-1pydotorg.i386.rpm
warning: python2.4-2.4.1-1pydotorg.i386.rpm: V3 DSA signature: NOKEY, key ID 95ccbcff
Preparing packages for installation...
python2.4-2.4.1-1pydotorg

$ sudo rpm -i -v python2.4-devel-2.4.1-1pydotorg.i386.rpm
warning: python2.4-devel-2.4.1-1pydotorg.i386.rpm: V3 DSA signature: NOKEY, key ID 95ccbcff
Preparing packages for installation...
python2.4-devel-2.4.1-1pydotorg

Are these NOKEY warnings significant? If so, how to overcome them?

$ rpm -q -p python*
warning: python2.4-2.4.1-1pydotorg.i386.rpm: V3 DSA signature: NOKEY, key ID 95ccbcff
python2.4-2.4.1-1pydotorg
python2.4-devel-2.4.1-1pydotorg

$ rpm -i -v wxPython-common-gtk2-ansi-2.8.0.1-fc4_py2.4.i386.rpm
error: Failed dependencies:
python(abi) = 2.4 is needed by wxPython-common-gtk2-ansi-2.8.0.1-fc4_py2.4.i386

Removal of the python 2.4 packages, still shows V4 is installed when issuing '$ rpm -q -p python*'

Thanks for any help!
Mike
 
Old 01-16-2007, 05:26 PM   #2
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,498

Rep: Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956
Quote:
Originally Posted by mfurnanz
1) Running Fedora Core 4 (?):
$ cat /etc/redhat-release
Red Hat Enterprise Linux WS release 4 (Nahant Update 2)
You are running RHEL4 (not Fedora).

Quote:
$ sudo rpm -i -v python2.4-2.4.1-1pydotorg.i386.rpm
warning: python2.4-2.4.1-1pydotorg.i386.rpm: V3 DSA signature: NOKEY, key ID 95ccbcff
Preparing packages for installation...
python2.4-2.4.1-1pydotorg

Are these NOKEY warnings significant? If so, how to overcome them?
This tells that you have not installed the proper key to verify the RPM signature.

Quote:
Removal of the python 2.4 packages, still shows V4 is installed when issuing '$ rpm -q -p python*'
rpm -p does not query the installed packages, but the RPMs you have effectively downloaded in the current directory. Probably you are issuing the rpm -qp command against the RPMs saved on your hard disk. Try simply 'rpm -q python'.

Anyway, it sounds strange to me the "pydotorg" suffix in the above python RPMs. Are you sure you are installing the packages built for your system?

Last edited by colucix; 01-16-2007 at 05:27 PM.
 
Old 01-16-2007, 08:29 PM   #3
mfurnanz
LQ Newbie
 
Registered: Jan 2007
Posts: 5

Original Poster
Rep: Reputation: 0
wrong packages

Thanks alot for pointing out my mistakes--i'm obviously a newbie!
Since you pointed out that I have RHEL4 rather than FC4, apprently I have the wrong packages downloaded.

I have downloaded the source and will try (again) at builing and installing. I had tried this earlier and the install didn't seem to work, so I'll have to pay closer attention to the README instructions.

Will I have NOKEY problems if I build from souce? If so, where/how do I obtain these and fix it?

Also, I have a build environment which uses python 2.3 (currently installed over the system version). Should I remove 2.3 before installing 2.4, or can they co-exist? It wouldn't be too much trouble to remove 2.3 and update my build (boost) environment if necessary.

Thanks again for the quick reply and help.
Mike
 
Old 01-17-2007, 03:46 AM   #4
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,498

Rep: Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956Reputation: 1956
Quote:
Originally Posted by mfurnanz
Will I have NOKEY problems if I build from souce? If so, where/how do I obtain these and fix it?
No problem with the source. The signature is generally associated to the RPM packages. When you download RPM from a website, generally you will find instructions on how to import the proper key into your PGP keys database. But I think there is no problem if you do not.

Quote:
Also, I have a build environment which uses python 2.3 (currently installed over the system version). Should I remove 2.3 before installing 2.4, or can they co-exist?
Multiple versions of Python can coexist, since each version of the interpreter can find its associated library files. One can install a separate, customized version elsewhere without disturbing the pre-installed version, which may be used for many system configuration tasks, and probably shouldn't be overwritten. Be careful to not install the python executables over the pre-installed ones and change their name accordingly.

You're welcome!
Alex
 
  


Reply

Tags
installation


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get returns unmet dependencies error with python2.3-sip4-qt3 package 1337ln Linux - Newbie 5 06-16-2006 07:36 PM
Rpm Dependencies problem djpacman Linux - Software 4 05-17-2006 05:31 PM
RPM Install problem - dependencies The_JinJ Linux - Newbie 3 11-22-2004 07:08 PM
unable to satisfy dependencies ??? belkins Linux - Newbie 2 10-18-2004 03:23 PM
python2.2 Dependencies webboss Linux - General 3 03-06-2002 04:20 AM


All times are GMT -5. The time now is 03:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration