LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-05-2003, 07:50 PM   #1
Moses420ca
Member
 
Registered: Jul 2003
Distribution: Ubuntu
Posts: 142

Rep: Reputation: 15
can't run X programs as root under suse 8.2


I can't run and X programs under root. I open a console and su to root. I type kwrite and it can't find it. I know this is because it's not in root's $PATH. That's ok. I cd to the directory kwrite is in and I get this.

workstation1:/opt/kde3/bin # ./kwrite
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
kwrite: cannot connect to X server :0.0
workstation1:/opt/kde3/bin #


Thanks for any help.
 
Old 09-05-2003, 08:00 PM   #2
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
either use sux - instead of su , or type xhost +localhost to allow others to use the xserver from your account

Last edited by rshaw; 09-05-2003 at 08:02 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't run gui (X) programs as root user nazdrowie Linux - General 25 12-02-2008 01:24 AM
setuid programs hang when run by non-root users in RH9 jbkrash Red Hat 0 09-21-2004 01:17 PM
how can i use Wine to run my windows programs on SuSe 9.0? elbrens Linux - Software 4 06-18-2004 03:46 AM
trying to run programs in JavaDesktop from SuSE bcottam Linux - Distributions 4 04-12-2004 06:18 PM
programs won't run on user (non-root) accounts....? once here Slackware 16 12-02-2003 08:44 AM


All times are GMT -5. The time now is 08:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration