LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-12-2006, 06:23 AM   #1
yukie
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Rep: Reputation: 0
can't play audio CD when I'm not root


well the thread title pretty much says it all. All my cd players behave as if there was no cd in the drive whenever I'm not root. below is my fstab.

Code:
/dev/hda5        swap             swap        defaults         0   0
/dev/hda2        /                ext2        defaults         1   1
/dev/hda6        /usr             ext2        defaults         1   2
/dev/hda7        /opt             ext2        defaults         1   2
/dev/hda8        /home            ext2        defaults         1   2
/dev/hda1        /mnt/windows     ntfs        ro               1   0
/dev/cdrom       /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
 
Old 06-12-2006, 06:25 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Is your user account in the cdrom and audio groups? Look in /etc/group to find out.
 
Old 06-12-2006, 06:32 AM   #3
worzel68
Member
 
Registered: May 2006
Location: Sydney
Distribution: FC5, FC3, AIX, System V,
Posts: 50

Rep: Reputation: 15
yukie,

Quote:
/dev/cdrom /mnt/cdrom auto noauto,owner,ro
this line shows the option "owner", which means only the owner can mount that device.

You can change this to user, which will allow any user to mount the device.

Also check the permissions on /dev/cdrom - it is probably owned by root.

Check out the man page for mount.

Enjoy your audio experience.
 
Old 06-12-2006, 06:37 AM   #4
yukie
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
this line shows the option "owner", which means only the owner can mount that device.

You can change this to user, which will allow any user to mount the device.
ok, just did this, but it didn't seem to help.

Quote:
Also check the permissions on /dev/cdrom - it is probably owned by root.
yeah, it looks like it is owned by root. An ls -l /dev/cdrom gives:
Code:
lrwxrwxrwx  1 root root 8 2006-06-09 04:14 /dev/cdrom -> /dev/hdb
so, do i change ownership?

thanks.

EDIT:

by the way, /etc/group/ contains

Code:
.
,
.
audio::17:
.
.
.
cdrom::19:
are those numbers user ids or group ids? in any case I don't seem to be there, my id is 1000.

Last edited by yukie; 06-12-2006 at 06:41 AM.
 
Old 06-12-2006, 06:39 AM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Changing "owner" to "user" (or "users") in your fstab won't help with audio CDs, because you don't mount those..
 
Old 06-12-2006, 06:48 AM   #6
yukie
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Original Poster
Rep: Reputation: 0
ok I already added myself to the audio and cdrom user groups, but the problem persists...
 
Old 06-12-2006, 07:09 AM   #7
worzel68
Member
 
Registered: May 2006
Location: Sydney
Distribution: FC5, FC3, AIX, System V,
Posts: 50

Rep: Reputation: 15
Quote:
/dev/cdrom /mnt/cdrom auto noauto,owner,ro
As Nylex says - the noauto means that the device isn't automatically mounted at boot time.

But changing this won't do anything if there is nothing in the cd drive, so you have to do both of the folowing:

Quote:
/dev/cdrom /mnt/cdrom auto noauto,user,ro
and

Quote:
mount /mnt/cdrom
the mount command works like this because the info it needs is in /etc/fstab.

Read the man page for mount - don't forget to use umount to get your CD back !!
 
Old 06-12-2006, 07:16 AM   #8
yukie
LQ Newbie
 
Registered: Jun 2006
Posts: 5

Original Poster
Rep: Reputation: 0
thanks all for your suggestions, but I found a solution in a different thread. turns out i needed to add myself to the 'disk' and 'sys' usergroups.

just curious, though... honestly i feel this solution is a bit overkill. I didn't think I had to add myself to 'sys' just so I can play audio cds, but it works so what the heck.

thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio::Play/Audio::Data DanTaylor Programming 0 02-07-2006 06:37 PM
Can not play audio cds as user (just as root) hraposo Slackware 4 08-06-2004 02:20 PM
Cannot play audio CD when non-root rsamurti Slackware - Installation 2 05-06-2004 07:49 PM
Can't play audio cd melinda_sayang Slackware 12 03-20-2004 04:23 AM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 07:52 AM


All times are GMT -5. The time now is 02:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration