LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2015, 11:59 AM   #1
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Rep: Reputation: 49
Can't open pavucontrol in xfce - sound not configured


I am trying to open pavucontrol in debian with the xfce desktop.
The error message is:

Code:
Connection to Pulseaudio failed. Automatic retry in 5s
In this case this is likely because PULSE_SERVER in the Environment/X11 Root Windows Properties or default-server in client.conf is misconfigured.
I am having trouble getting sound and configuring the settings.
There is no sound setting in the Settings Manager of xfce.
Also, every time I change alsamixer to my hdmi sound card it keeps going back to the default analog sound card when I exit the program.

How can I access the system settings on the desktop or do I need to change a file setting from the terminal?
 
Old 01-16-2015, 08:44 AM   #2
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
My radeon sound card has given me problems with my previous debian install. From this, I've learned some changes I need to make which rectify the problem.
I've done the following:

Ensure etc/apt/sources.list includes 'contrib' and 'non-free'
Code:
debian stable main contrib non-free
Install relevant firmware:
Code:
apt-get install firmware-linux
apt-cache search firmware 
apt-get install alsa-firmware-loaders
Ensure /etc/default/grub has 'radeon.audio=1' added:
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet radeon.audio=1"
When I open alsamixer from the terminal it defaults to the analog sound card which isn't being used. I need to set the sound card to the radeon hdmi one but don't know how.
There is no sound icon on this xfce DE under system settings!
 
Old 01-16-2015, 11:13 AM   #3
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,165

Rep: Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223
If the card you want is listed as 1 and the analogue as 0, try creating a file $HOME/.asoundrc to contain
defaults.pcm.card 1
defaults.pcm.device 0
defaults.ctl.card 1
Then you need to log out and in again. No guarantees, though: Debian sound is a black art. I remember one case where the numbering of the devices could change from boot to boot!
 
Old 01-16-2015, 12:58 PM   #4
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by DavidMcCann View Post
If the card you want is listed as 1 and the analogue as 0, try creating a file $HOME/.asoundrc to contain
defaults.pcm.card 1
defaults.pcm.device 0
defaults.ctl.card 1
Then you need to log out and in again. No guarantees, though: Debian sound is a black art. I remember one case where the numbering of the devices could change from boot to boot!
My previous install on a different partition where the sound is working doesn't have a .asoundrc file.
I have come across some solutions referring to the .asoundrc file. However, since the first install doesn't even have the file, I'm wondering if the answer is somewhere else.

One thing I haven't done is change the system settings for sound on the desktop. But for some reason there is no icon for it on this xfce desktop!
I'm thinking that there must be a problem if the xfce desktop doesn't even have a system setting for sound...
 
Old 01-16-2015, 01:41 PM   #5
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Well, I've got pavucontrol working!

I tried opening pavucontrol from the terminal, and nothing happened.
So I tried installing it again. It installed correctly without saying that the program was already installed.

So the error message for the program must have been due to a broken install.
I can now open the program via desktop and terminal.
Still got no sound though.
 
Old 01-17-2015, 11:45 AM   #6
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,165

Rep: Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223
Quote:
Originally Posted by Higgsboson View Post
My previous install on a different partition where the sound is working doesn't have a .asoundrc file. I have come across some solutions referring to the .asoundrc file. However, since the first install doesn't even have the file, I'm wondering if the answer is somewhere else.
I don't think any distro creates that file by default. It's something you make yourself if you need it in very hands-on distros like Debian, Arch, or Slackware.

The command
aplay -l
should list your devices and confirm which is numbered 0 and which is 1. If the sound card isn't listed, try
cat /proc/asound/modules
to see if the kernel module for it is loaded. If it isn't, then you need to install that from Debian and reboot.

Last edited by DavidMcCann; 01-17-2015 at 11:49 AM.
 
Old 01-17-2015, 12:04 PM   #7
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by DavidMcCann View Post
The command
aplay -l
should list your devices and confirm which is numbered 0 and which is 1. If the sound card isn't listed, try
cat /proc/asound/modules
to see if the kernel module for it is loaded. If it isn't, then you need to install that from Debian and reboot.
The hdmi card is listed under 'aplay-l':
Code:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
The problem I'm having is being able to change system settings to default to the hdmi sound card.
But now I'm beginning to wonder if the .asoundrc file will do this anyway.
I'll give it a try.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] No sound on debian live usb using pavucontrol and ATI RS880 [Radeon HD 4200] audio Higgsboson Linux - Newbie 7 01-09-2015 04:37 AM
Sound indicator: settings doesn't open pavucontrol miguelg Linux - General 2 11-19-2014 12:35 PM
Have To Keep Pavucontrol Open In Order For Sound To Work Sumguy Linux - Newbie 5 03-29-2014 04:23 PM
[SOLVED] Set a persistent background with fluxbox when I have xfce configured as default Miranden Slackware 5 12-05-2013 10:45 PM
sound not working in SUSE 10.2 although sound card correctly configured mhardwick Linux - Software 4 03-05-2007 03:13 PM


All times are GMT -5. The time now is 10:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration