LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-28-2006, 03:46 AM   #1
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 17.3
Posts: 192

Rep: Reputation: 31
Can't open mplayer


Hi !

I can't open the mplayer video player. When I click in the menu an error message occur. It dissappear before I can read it.

But mplayer can play videos from the Terminal. Typing mplayer vid in the Terminal gives this output:

thort@thortsystem:~/Desktop$ mplayer vid boraas_djurpark_tiger.wmv
MPlayer 2:0.99+1.0pre7try2+cvs20060117-0ubuntu8 (C) 2000-2006 MPlayer Team
CPU: Intel Pentium 4 Willamette; Xeon Foster (Family: 15, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.


91 audio & 204 video codecs
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
Playing vid.
File not found: 'vid'
Failed to open vid

Playing boraas_djurpark_tiger.wmv.
ASF file format detected.
VIDEO: [WMV2] 320x240 24bpp 1000.000 fps 0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 32000 Hz, 2 ch, s16le, 48.0 kbit/4.69% (ratio: 6000->128000)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
==========================================================================
Opening video decoder: [dshow] DirectShow video codecs
Decoder supports the following YUV formats: YUY2 IYUV UYVY YV12 YVYU I420 YVU9
Decoder is capable of YUV output (flags 0x7f)
VDec: vo config request - 320 x 240 (preferred colorspace: Packed YUY2)
[PP] Using codec's postprocessing, max q = 4.
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 320x240 => 320x240 Planar YV12
Selected video codec: [wmv8] vfm: dshow (Windows Media Video 8)
==========================================================================
Building audio filter chain for 32000Hz/2ch/s16le -> 0Hz/0ch/??...
alsa-init: 1 soundcard found, using: default
alsa-init: playback open error: No such file or directory
AO: [oss] 32000Hz 2ch s16le (2 bytes per sample)
Building audio filter chain for 32000Hz/2ch/s16le -> 32000Hz/2ch/s16le...
Starting playback...
A: 38.7 V: 38.8 A-V: -0.112 ct: -0.081 847/847 11% 0% 0.2% 9 0

Exiting... (End of file)


How can I make mplayer start when clicking in the menu?
 
Old 07-28-2006, 04:05 AM   #2
crazyjimbo
Member
 
Registered: Mar 2006
Location: Edinburgh
Distribution: Debian Etch, Gentoo
Posts: 90

Rep: Reputation: 16
mplayer is a command line program - it is designed to be run from a terminal with the file(s) to play as arguments. It will complain (as it does) if you start it by just calling 'mplayer' - you're not giving it anything to play. I guess this is what happens when you click it in the menu.

When you compile mplayer, you can choose to also build a gui for it. I've never used this but i believe you invoke it with 'gmplayer'. This might be more suited to running from a menu.
 
Old 07-28-2006, 04:27 AM   #3
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 17.3
Posts: 192

Original Poster
Rep: Reputation: 31
Thanks crazyjimbo !

Quote:
Originally Posted by crazyjimbo
mplayer is a command line program - it is designed to be run from a terminal with the file(s) to play as arguments. It will complain (as it does) if you start it by just calling 'mplayer' - you're not giving it anything to play. I guess this is what happens when you click it in the menu.
I looked in my menu. I can see the menu command for my mplayer is gmplayer. Typing gmplayer in the Terminal gives this output:

thort@thortsystem:~$ gmplayer
MPlayer 2:0.99+1.0pre7try2+cvs20060117-0ubuntu8 (C) 2000-2006 MPlayer TeamCPU: Intel Pentium 4 Willamette; Xeon Foster (Family: 15, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.



91 audio & 204 video codecs
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startupscripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
[skin] file ( /usr/share/mplayer/Skin/default/skin ) not found.
Skin not found (default).
thort@thortsystem:~$ cd /usr/share/mplayer/Skin/default/skin
bash: cd: /usr/share/mplayer/Skin/default/skin: No such file or directory
thort@thortsystem:~$ cd /usr/share/mplayer
thort@thortsystem:/usr/share/mplayer$ cd Skin
thort@thortsystem:/usr/share/mplayer/Skin$ cd..
bash: cd..: command not found
thort@thortsystem:/usr/share/mplayer/Skin$ cd default
thort@thortsystem:/usr/share/mplayer/Skin/default$ cd skin
bash: cd: skin: No such file or directory


As I understand this text there is no skin for mplayer. Therefore it can't start in gui mode.

Peculiar. How can I fix this? Shall I uninstall and install mplayer again?
 
Old 07-28-2006, 04:57 AM   #4
crazyjimbo
Member
 
Registered: Mar 2006
Location: Edinburgh
Distribution: Debian Etch, Gentoo
Posts: 90

Rep: Reputation: 16
I think you just need to install a skin. The mplayer site has plenty (at the bottom of the page) as well as instructions:

http://www.mplayerhq.hu/design7/dload.html
 
Old 07-28-2006, 05:47 AM   #5
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 17.3
Posts: 192

Original Poster
Rep: Reputation: 31
I downloaded the default skin and copied it to the /usr/share/mplayer/Skin/default folder. And now, mplayer starts from the menu !

Very good !

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer installed, but doesn't open mustangfanatic01 Slackware 13 11-18-2005 02:46 AM
mplayer wont open pasalacqua128 Linux - Software 2 08-25-2004 10:17 AM
Can't open up mplayer JunZ Mandriva 17 06-05-2004 01:27 PM
Keep mplayer windows open Wynd Linux - General 2 09-07-2003 12:04 PM
mplayer open gl cyrille Linux - General 9 05-28-2002 06:22 AM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration