LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-11-2005, 08:56 AM   #1
heande
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Rep: Reputation: 0
"Can't open display" error when try to use a program remote


Hello

I am using "Xandros Desktop OS Version 3 Open Circulation Edition" and when I try to open a program remote via ssh, I get error messages like this:

"remoteserver":heande:[~]> gimp

Gtk-WARNING **: cannot open display:

or when I am trying to open Mathematica:

xset: unable to open display ""
xset: unable to open display ""
xset: unable to open display ""
Can't open display

Is there anyone who know how I can solve this problem?

/Henrik Andersson

Last edited by heande; 03-11-2005 at 10:16 AM.
 
Old 03-11-2005, 09:16 AM   #2
kees-jan
Member
 
Registered: Sep 2004
Distribution: Debian, Ubuntu, BeatrIX, OpenWRT
Posts: 273

Rep: Reputation: 30
Use ssh -X instead (enable X-forwarding)
on the remote, type
Code:
echo $DISPLAY
to check that it is actually set (if it prints anything else than an empty line, you're fine.

start gimp.

Groetjes,

Kees-Jan
 
Old 03-11-2005, 10:13 AM   #3
heande
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you, it works perfectly

/Henrik
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 03:07 PM
xset: unable to open display "mycomputer.mynetwork:0.0" nicolaeancuta Linux - Networking 2 07-13-2005 01:39 AM
Getting error: "ALSA device "default" is already in use by another program." brynjarh Debian 7 02-04-2005 11:45 AM
unable to open display "24.228.61.72:0.0" while installing oracle remotely cheeku Linux - Newbie 3 08-13-2004 04:08 PM
"Can't open display" error simanyay Linux - Software 5 03-22-2004 10:59 AM


All times are GMT -5. The time now is 05:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration