LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-01-2009, 03:23 AM   #1
DarkSlayer
Member
 
Registered: Apr 2008
Location: Tbilisi , Georgia
Distribution: Fedora, CentOS
Posts: 65

Rep: Reputation: 19
Question can't normally shutdown Fedora 11


Using Fedora 11 with GNOME desktop.

normal shutdown button which i added to taskbar is disabled.
it had hibernate, suspend, restart, log out etc.... u know, standart shutdown dialog window
When i removed it from taskbar and tried to add it again it disappeared from the list of launchers for taskbar
I found some thread, which says, that issue may be because of Compiz or Beril, but i don't have them on my system

shutting with:
Code:
sudo shutdown -h/-r now
I'll be more than happy to return this button back.

Regards
 
Old 07-01-2009, 04:06 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,497

Rep: Reputation: 90
No sure about the GNOME error you've apparently encountered, but it is possible to put that shutdown command into a script file, and call that from a KDE icon - so maybe you can do something similar in GNOME.

I. e. in KDE you would

Code:
1. Create a text file using vi, emacs, kate, or whatever text editor you prefer, and call the file stop.sh

Put this inside it: 

sudo shutdown -h now

2. Save the file in your home directory.

3. Unlock the KDE desktop widgets

4. Press ALT-F2 to bring up the quick execution bar

5. Type 

kmenuedit

6. Click on New

7. Select an icon for your new button by clicking on the icon button

8. Go to the "command" or "application" tab.

9. In the line where you can enter the name of the excutable to run if that icon is clicked, type

sh -f /home/your_home_dir_name/stop.sh

10. Apply

11. Click and drag that icon from the kmenueditor's list to the taskbar and move it into position

12. Close kmenueditor

13. Optionally, relock the desktop icons.
If you now click on the icon you just created, it should call the stop.sh script, which contains sudo shutdown -h now which should shut down your system. I. e. you'll mostly have the functionality back of having a single button you can click on to shutdown your system. You can also, of course, make your own "reboot" button, just change the -h to -r, as you already indicated.

Note that doing it this way -might- bother some KDE programs (for example, in FC10, doing a shutdown -h now instead of the normal "logout" on my system, would make some KDE stuff complain on the next startup, but nothing serious)

Last edited by rylan76; 07-02-2009 at 10:29 AM. Reason: Didn't see GNOME was having the problem...
 
Old 07-01-2009, 04:48 AM   #3
DarkSlayer
Member
 
Registered: Apr 2008
Location: Tbilisi , Georgia
Distribution: Fedora, CentOS
Posts: 65

Original Poster
Rep: Reputation: 19
i'm not using KDE , but GNOME
 
Old 07-01-2009, 10:22 AM   #4
fpmurphy
Member
 
Registered: Jan 2009
Location: /dev/ph
Distribution: Fedora, Ubuntu, Redhat, Centos
Posts: 299

Rep: Reputation: 62
Did you right-click on it and tick box the option "Lock to Panel"?
 
Old 07-02-2009, 02:37 AM   #5
DarkSlayer
Member
 
Registered: Apr 2008
Location: Tbilisi , Georgia
Distribution: Fedora, CentOS
Posts: 65

Original Poster
Rep: Reputation: 19
yes i did everything with this Panel: Lock Unlock ADD item etc....

Also already can't Log Out....
screen hangs, only background image and cursor

I think this gone wrong after installing first updates 320+ (i had fresh system install)

Quote:
Originally Posted by fpmurphy View Post
Did you right-click on it and tick box the option "Lock to Panel"?
 
Old 07-06-2009, 06:00 AM   #6
DarkSlayer
Member
 
Registered: Apr 2008
Location: Tbilisi , Georgia
Distribution: Fedora, CentOS
Posts: 65

Original Poster
Rep: Reputation: 19
Shutdown button with options is disabled only when I log to PC via VNC

And when directly entering this PC it works normally.

What should it be ?
 
Old 07-06-2009, 10:54 AM   #7
ECRocker
Member
 
Registered: May 2007
Distribution: RHEL 5, Ubuntu 9.10, Fedora 12
Posts: 85

Rep: Reputation: 17
I've encountered this issue too.
I believe it occurs when I've logged into a terminal session as root or something where now only root can shutdown my machine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
shutdown problem with fedora 10 asifbasha Linux - Laptop and Netbook 6 06-30-2009 10:31 AM
Fedora 11 Shutdown problem happygolucky Linux - Software 2 06-22-2009 08:04 PM
Cannot shutdown Fedora 7 Dummy-in-Linux Fedora 6 06-21-2007 08:48 PM
Shutdown problem with Fedora 3 Obedience Linux - Software 1 07-10-2005 10:30 AM
Help ? my fedora 3 can't shutdown pleasehelpme Linux - Newbie 1 05-08-2005 01:41 PM


All times are GMT -5. The time now is 07:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration