LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2010, 01:17 PM   #1
puneetsoni
LQ Newbie
 
Registered: Jun 2009
Posts: 7

Rep: Reputation: 0
Can't mount windows partition in non admin mode


Hi all,
My problem goes as :
I can mount and access windows drive in root, but cannot mount NTFS partition in non admin mode. It tells authentication required!! , could not find out why it is happening. Please help me out

MY /etc/fstab goes as :

/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda10 during installation
UUID=80117144-8dfc-47ad-8896-dea9c426f7ee / ext4 errors=remount-ro 0 1
# swap was on /dev/sda9 during installation
UUID=40e64729-21e7-495a-a0f1-89636ede0262 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
 
Old 02-15-2010, 01:45 PM   #2
biggocharley
LQ Newbie
 
Registered: Jun 2009
Location: Southeast Michigan
Distribution: ubuntu
Posts: 6

Rep: Reputation: 1
[QUOTE=puneetsoni;3864609]Hi all,
My problem goes as :
I can mount and access windows drive in root, but cannot mount NTFS partition in non admin mode. It tells authentication required!! , could not find out why it is happening. Please help me out


I think you may have an ownership issue. Suggest you mount the partition as root --then check the properties and you will find that root is the owner. Change the ownership to your username and that will probably solve the problem.
Charley
 
1 members found this post helpful.
Old 02-15-2010, 02:02 PM   #3
puneetsoni
LQ Newbie
 
Registered: Jun 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Hi i was able to mount the disk.

All i did was i worked with /etc/fstab.

Thanks for the help.
 
Old 02-15-2010, 02:09 PM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
I don't know which Linux distro and version you are using and whether you are talking about an external (removable) drive or an internal one.

For removable drives, on recent distro versions, policy-kit is used to enable the desktop user to the media. There is a similar policy for fixed media. This is how auto-mounting of pen drives works.

Code:
polkit-auth --show-obtainable
org.freedesktop.network-manager-settings.system.modify
org.freedesktop.hal.storage.mount-fixed
org.opensuse.cupspkhelper.mechanism.printer-set-default
org.opensuse.cupspkhelper.mechanism.printer-enable
org.opensuse.cupspkhelper.mechanism.printer-local-edit
org.opensuse.cupspkhelper.mechanism.printer-remote-edit
org.opensuse.cupspkhelper.mechanism.class-edit
org.opensuse.cupspkhelper.mechanism.server-settings
org.opensuse.cupspkhelper.mechanism.job-not-owned-edit
org.opensuse.cupspkhelper.mechanism.printeraddremove
org.freedesktop.policykit.read
org.freedesktop.policykit.revoke
org.freedesktop.policykit.grant
org.freedesktop.policykit.modify-defaults
For fixed media, a root user can edit /etc/fstab so that is mounted when you boot up. After that it doesn't need to be mounted by a regular user.

If the /etc/fstab entry uses the "user" or "users" option and the "uid=" value is set, then a regular user can mount that partition. ( This is for systems where the mount command is suid root ) The "mount" command checks for a uid= value. For removable drives, the first column in the /etc/fstab file should be a unique identifier for the filesystem.

The uid, gid, fmask and dmask mount options determine the permissions of a HFS, FAT32 or NTFS filesystem. The permissions of all files will be the same.
 
  


Reply

Tags
access, authentication, ntfs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how mount mount ntfs partition of windows xp kashif2131971 Linux - Newbie 3 07-07-2009 07:34 PM
How to mount NTFS partition from Fedora 10 Rescue Mode/Disk varaaha Fedora - Installation 5 03-09-2009 10:41 AM
Mount windows partition vcatalano Debian 6 11-12-2006 12:30 AM
cannot mount windows partition scng Linux - Networking 6 07-09-2005 11:56 PM
how do i mount my windows partition ? abiagi Linux - Newbie 8 12-07-2003 07:45 PM


All times are GMT -5. The time now is 09:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration