LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-08-2009, 01:51 PM   #1
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Rep: Reputation: 15
Can't Mount cdrom


Hi,
I tried to mount my cd with the following command,i've searched the forum regarding this but nothing helped me

mout /dev/cdrom

and the error i got is

mount: can't find /dev/cdrom in /etc/fstab or /etc/mtab

and my cat /etc/fstab is
Code:
#
# /etc/fstab
# Created by anaconda on Fri Jun 26 13:34:49 2009
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
#
UUID=16d88684-1260-4f2b-a68f-2f583dfb7636 /                       ext3    defaults        1 1
UUID=faf5274e-78b3-480f-8101-9093f9032c90 /usr                    ext3    defaults        1 2
UUID=1748124a-d25b-4962-8f63-63b732bc2081 /home                   ext3    defaults        1 2
UUID=7cbb737b-db4f-4edc-b2aa-e047f7dbc93e /data                   ext3    defaults        1 2
UUID=74e5ae49-e854-4391-9342-8640bd03d2c3 /data2                  ext3    defaults        1 2
UUID=6e10d4f9-c4af-4030-9990-afc740f9cdd4 /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
UUID=29b7cdbf-99cb-41c2-b1e8-f6bda50a6808 swap                    swap    defaults        0 0
and my cat /etc/mtab is
Code:
/dev/sda2 / ext3 rw 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/sda6 /usr ext3 rw 0 0
/dev/sda5 /home ext3 rw 0 0
/dev/sda3 /data ext3 rw 0 0
/dev/sda8 /data2 ext3 rw 0 0
/dev/sda1 /boot ext3 rw 0 0
tmpfs /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
gvfs-fuse-daemon /home/malick/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=malick 0 0
Need some Help
 
Old 07-08-2009, 02:29 PM   #2
NeddySeagoon
Gentoo support team
 
Registered: May 2009
Location: 56N 3W
Distribution: Gentoo
Posts: 178

Rep: Reputation: 40
malickhat,

Add
Code:
/dev/cdrom              /mnt/cdrom      udf,iso9660     users,noauto,ro 0 0
to /etc/fstab or use the full mount command. Ensure that /mnt/cdrom exists too.
The options users,noauto,ro allow any user to mount and unmount cdroms, it not automouted at boot and cdroms are mounted read only.
If you don't trust your users, you can add other options, like noexec, to prevent programs on optical media from being run.
 
Old 07-08-2009, 02:44 PM   #3
abi0909
Member
 
Registered: Jul 2009
Distribution: Ubuntu, RedHat, VMWare, CentOS, Windows, Android, Mac
Posts: 55

Rep: Reputation: 18
mount /dev/cdrom

This command is not the complete command to mount a filesystem. Issuing this command will search for an entry for /dev/cdrom in the fstab, and in your case since this is missing, it will kick you out with this error.

Complete mount command is:

mount /dev/cdrom /mnt/cdrom

And if you want this to be mounted on system reboot too, as in the entry in the fstab and do "mount -a". This mount -a will re-read the fstab and remount what ever file system is not mounted.

So once you do mount -a and then a df -h, you must see your cdrom mounted on /mnt/cdrom .

If not, check your fstab for a typo.

Cheers!!!
 
Old 07-08-2009, 11:20 PM   #4
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by NeddySeagoon View Post
malickhat,

Add
Code:
/de/dev/cdrom              /mnt/cdrom      udf,iso9660     users,noauto,ro 0 0
I added that line in my fstab but when i reopened it i couldn't see the line again it's been deleted i guess
 
Old 07-08-2009, 11:24 PM   #5
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Original Poster
Rep: Reputation: 15
[QUOTE=abi0909;3601362]mount /dev/cdrom


Quote:
Complete mount command is:

mount /dev/cdrom /mnt/cdrom
I issued this comand and i got a error that mount point dose not exist and i created a dir in mnt with the name of cdrom,then it's works fine for me
Quote:
And if you want this to be mounted on system reboot too, as in the entry in the fstab and do "mount -a". This mount -a will re-read the fstab and remount what ever file system is not mounted.

So once you do mount -a and then a df -h, you must see your cdrom mounted on /mnt/cdrom .

Cheers!!!
df -h shows the /mnt/cdrom
 
Old 07-09-2009, 02:01 PM   #6
NeddySeagoon
Gentoo support team
 
Registered: May 2009
Location: 56N 3W
Distribution: Gentoo
Posts: 178

Rep: Reputation: 40
malickhat,

There is no /de on the front of the line.

You must be the root user to edit that file or use sudo on the front of the editor command.
 
Old 07-11-2009, 12:54 PM   #7
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by NeddySeagoon View Post
malickhat,

There is no /de on the front of the line.

You must be the root user to edit that file or use sudo on the front of the editor command.
I can mount now ,but i still have some problem ,why my Cd is not autoplaying though i'm using fedora 10 ,or how can i make it to auto play
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CDROM refuses to mount, /dev/cdrom does not exist shane25119 Linux - Hardware 10 08-02-2009 10:43 PM
Cannot mount cdrom noonmid27 Linux - Newbie 1 11-18-2006 07:00 PM
mount cdrom... ilectrcbob Linux - Newbie 12 04-10-2005 09:13 AM
Cdrom won't mount, "cdrom busy" mickeyboa Fedora 7 11-30-2004 10:39 PM
cdrom will not mount leeley Linux - Newbie 2 08-03-2001 11:11 PM


All times are GMT -5. The time now is 01:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration