LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-03-2014, 02:45 PM   #1
sharky
Member
 
Registered: Oct 2002
Posts: 478

Rep: Reputation: 47
Can't mount 128GB NTFS USB stick


If I completely reboot with the stick plugged in it will mount and I can move data in and out.

If I plug it in while the system is running absolutely nothing happens. There are no warnings, errors or any indication, other than output from lsusb, that the device is plugged in.

I run winxp in a vbox machine and the device does load in the virtual machine.

output from lsusb;
Quote:
Bus 002 Device 004: ID 154b:fa05 PNY
Bus 008 Device 002: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
The first device listed is the USB stick.

I'm stumped on how to make this work and open to suggestions.

Cheers,
 
Old 02-03-2014, 03:18 PM   #2
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
You may need to mount it by hand when you plug it in after the system is running.
 
Old 02-03-2014, 04:56 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,822

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
what operating system and what version

all modern OS's should AUTO mount it as read only for the normal user in /media

mind you if this is RHEL4 or RHEL 5 ( under 5.3) there is read only support

and the same for OLD versions of Debian

Also is NTFS-3g installed ?
 
Old 02-03-2014, 06:34 PM   #4
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,383

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
Wonder if some fstab entry is messing it up?
 
Old 02-03-2014, 07:28 PM   #5
sharky
Member
 
Registered: Oct 2002
Posts: 478

Original Poster
Rep: Reputation: 47
I am using Linux Mint 14.

Tried mounting it manually but keep getting errors (don't remember the exact syntax and I'm not home right now). Basically the error had to do with not be able to find the device. Tried mounting /dev/sdc, /dev/sdc1, /dev/sdc2, /dev/sdd1, etc. System said all those devices do not exist.
 
Old 02-03-2014, 07:45 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,822

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
what desktop
the cinnamon version of gnome
or
xfce
lxde
or kde4

it should have an entry in the left window on KDE's dolphin or in Nautilus in Gnome
under "tree" or in "places"

with it plugged in
what is listed in /etc/mtab
( NOT to be confused with "fstab" )
and what dose
Code:
sodo fdisk -l
say as to what the device is ( sd??)
 
Old 02-03-2014, 07:58 PM   #7
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,904

Rep: Reputation: 261Reputation: 261Reputation: 261
Maybe there is a driver that is not loading when booting without the stick plugged in. Compare the output of lsmod with booting with the stick plugged in, and booting without the stick plugged in.
 
Old 02-03-2014, 08:17 PM   #8
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,630

Rep: Reputation: 495Reputation: 495Reputation: 495Reputation: 495Reputation: 495
few basics to check in addition to what has been asked and presented.

*** TURN OFF THE VM BEFORE STARTING THIS SET OF TESTS ***

1. switch over to root via CLI and BEFORE you plug in the USB drive run the following command
Code:
# tail -f /var/log/messages
you are looking for the /dev/sdX# were X is a letter from a-z and # is a number, typically 1
2. once you see it in the above tail command ctrl+c out of that and run the following
Code:
# df -Th
you are looking for the drive to be mounted by something.
3. if it is not there and you know for a fact that it is properly formatted the mount it manually and verify the permissions on both the mount point BEFORE and AFTER the mount to ensure the user can access the device. keeping in mind that NTFS fails with linux permissions, but the mount point should not.
 
1 members found this post helpful.
Old 02-04-2014, 09:08 PM   #9
sharky
Member
 
Registered: Oct 2002
Posts: 478

Original Poster
Rep: Reputation: 47
Quote:
Originally Posted by lleb View Post
few basics to check in addition to what has been asked and presented.

*** TURN OFF THE VM BEFORE STARTING THIS SET OF TESTS ***

1. switch over to root via CLI and BEFORE you plug in the USB drive run the following command
Code:
# tail -f /var/log/messages
you are looking for the /dev/sdX# were X is a letter from a-z and # is a number, typically 1
2. once you see it in the above tail command ctrl+c out of that and run the following
Code:
# df -Th
you are looking for the drive to be mounted by something.
3. if it is not there and you know for a fact that it is properly formatted the mount it manually and verify the permissions on both the mount point BEFORE and AFTER the mount to ensure the user can access the device. keeping in mind that NTFS fails with linux permissions, but the mount point should not.
With the VM shutdown the device connects with no issue.

BTW there is no /var/log/messages file. There is a syslog file and the mount device was /dev/sdc1.

I start up the virtual machine and it is immediately lost to linux.

Kind of annoying.
 
Old 02-04-2014, 09:27 PM   #10
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
It sounds like you've told your VM software to transfer that device to the VM. When you do that, it is inaccessible to the host system.
 
Old 02-04-2014, 10:57 PM   #11
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,383

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
Oh heck lleb

"
I run winxp in a vbox machine and the device does load in the virtual machine."

Good catch.
 
Old 02-04-2014, 11:50 PM   #12
sharky
Member
 
Registered: Oct 2002
Posts: 478

Original Poster
Rep: Reputation: 47
There is a vbox menu that allows me to "eject" the USB device. As soon as I select it the device is available in linux again.

That'll work.
 
Old 02-05-2014, 09:26 PM   #13
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,630

Rep: Reputation: 495Reputation: 495Reputation: 495Reputation: 495Reputation: 495
Quote:
Originally Posted by sharky View Post
With the VM shutdown the device connects with no issue.

BTW there is no /var/log/messages file. There is a syslog file and the mount device was /dev/sdc1.

I start up the virtual machine and it is immediately lost to linux.

Kind of annoying.
then its simple, your VM has taking full ownership of that USB port. you need to adjust the settings in your VM software.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] can't mount usb stick in ntfs format porphyry5 Slackware - Installation 2 03-29-2011 01:54 PM
How to stop USB stick to mount automatically and mount it manually. gardenair Linux - Hardware 1 01-26-2011 11:04 PM
cannot mount usb stick trnz$mr Linux - Newbie 12 02-25-2009 08:58 AM
How Do mount USB stick connected to pcmcia-usb-adapter Raamisaha Linux - Newbie 3 02-11-2008 11:46 AM
mount/umount usb stick - PQI Intelligent Stick 2.0 sandbag Linux - Software 5 05-06-2005 12:12 PM


All times are GMT -5. The time now is 06:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration