LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-20-2003, 10:33 AM   #1
gabemonster
LQ Newbie
 
Registered: Jul 2003
Location: Cape Town - South Africa
Distribution: RedHat 8
Posts: 1

Rep: Reputation: 0
Can't log on to PDC


I have created a PDC on my redhat 8 box. My smb.conf file has been created no problems - to what I assume. I have done extensive reading and troubleshooting with different options.

When I try to join my WinXP pro machine to the 'PDC', I get the following error message:

"The following error occurred attempting to join the domain "domain".

Logon failure: Unknown user or bad password"

I have used the account 'root' with the relevant password to join the machine to the domain. I also created another user account with root permissions - no luck either.

I have looked into the problem extensively and cannot come up with a logical explanation as to why this is happening. I have tried workarounds too. I manually created a machine account on the linux box and that doesn't seem to work either.

Has anyone had a similar scenario. Is it XP that's the problem? I have not tried to duplicate the problem with another machine running another OS like 98 or NT.

Any suggestions would be greatly appreciated to relieve me of this massive frustration!
 
Old 07-20-2003, 11:45 AM   #2
itsjustme
Senior Member
 
Registered: Mar 2003
Location: Earth
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 1,571

Rep: Reputation: 45
Hmmm... I'm no network expert, but are you simply saying that you are using samba to connect your linux box to your winXP box and it isn't working?

I know sometimes the problem might be with encrypted passwords. Do you have this in your smb.conf file:

encrypt passwords = yes

Also, I think the username and the password for the windows box has to match a username and password that is set up on the linux box.

Just grabbing at straws for ya there...
 
Old 08-29-2003, 06:57 PM   #3
takhyon
LQ Newbie
 
Registered: Aug 2003
Posts: 1

Rep: Reputation: 0
I was getting the same problem till I created an SMB user root. I also used the same password as used for linux.
 
Old 06-17-2004, 04:19 PM   #4
tbeehler
Member
 
Registered: Aug 2003
Location: Washington State, USA
Distribution: Mainly RH 9.0
Posts: 227

Rep: Reputation: 30
He's right. I had the same issue as well. Just add the samba user and you'll be golden. I think the command is "smbpasswd -a root" without the quotes of course.

Travis L. Beehler
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Deleted /var/log/messages, can't log any files-iptables chingyenccy Linux - Newbie 7 02-27-2005 04:03 PM
Strange results in /var/log/apache/access.log subt13 Linux - Security 2 08-03-2004 01:21 PM
pppd logging to /var/log/ppp.log problem mrtwice Linux - Software 1 01-10-2004 05:38 PM
pdc & DNS or pdc & wins saavik Linux - Networking 4 04-25-2003 01:40 AM
iptables, changing log file from /var/log/messages acid2000 Linux - Networking 3 03-11-2003 08:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration