LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-20-2005, 04:08 PM   #1
figmentium
Member
 
Registered: Mar 2002
Location: Alberta, Canada
Distribution: Debian 4.0 Etch
Posts: 64

Rep: Reputation: 15
Can't load xwindows (gnome)


Hi,

I have RedHat 8 and I can't get into xwindows anymore.

I was updating my website and adding a GD module (for image compression), and I also did an up2date.

I followed these instructions on this website to help me install PHP GD and I think it messed up my Xfree stuff...

http://www.php-faq.com/gdinstall.php

I now get this error when typing "startx":

/usr/bin/gnome-session: relocation error:
/usr/lib/libXft.so.2: undefined symbol
: FT_Set_Hint_Flags

Is there a way to reinstall Xfree or something, or put it back to the way it was?

I really don't want to reinstall my whole system

Thanks in advance for any help

- figgy
 
Old 10-21-2005, 01:09 PM   #2
Thulemanden
Member
 
Registered: Sep 2003
Location: Copenhagen, Denmark
Distribution: PC-BSD, PCLOS, MeeGo, Win 7
Posts: 189

Rep: Reputation: 30
3 options

You could use your back up copy of xf86config-4 you made changing it ;-)

Or run xf86config from the command line as root.

Or... ask another Red Hat user to send you a file.
 
Old 10-21-2005, 01:11 PM   #3
Thulemanden
Member
 
Registered: Sep 2003
Location: Copenhagen, Denmark
Distribution: PC-BSD, PCLOS, MeeGo, Win 7
Posts: 189

Rep: Reputation: 30
By the way

My MEPIS cd-run disk has a service called: Restore X and another Restore Grub - quite clever. Might be an idea for Redt Hat to copy.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome xwindows won't load figmentium Red Hat 2 08-12-2005 08:01 PM
Need help setting up xwindows/gnome/kde Phalloides Linux - Software 10 07-18-2004 05:39 PM
xwindows / refusal to load polynotre Linux - Software 14 08-04-2003 07:37 AM
unable to get Xwindows to load..fatal error..pls help 1question Linux - Newbie 2 07-16-2003 04:19 PM
gnome, kde, xwindows kprocter Linux - General 6 04-23-2003 11:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration