LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-04-2005, 05:15 PM   #1
racyrefinedraj
LQ Newbie
 
Registered: Sep 2005
Posts: 3

Rep: Reputation: 0
can't install xsupplicant - dependent on old versions!


First of all, let me say a gigantic THANK YOU to linuxquestions.org as a whole for helping me take the plunge into linux. All the articles and howtos on here have been INCREDIBLE thus far in getting me going. So thanks.

Oh yeah, and before I start, I am on fedora core 4.

Now to the problem. I am at college and the wireless network in my apartment uses 802.1x PEAP authentication. I tried to install xsupplicant but it says that it can't locate the following packages:

libcrypto.so.0.9.7
libssl.so.0.9.7

Both of these are part of the openSSL library that I already have installed on my system. only problem is, I have a newer version so the file names look like this:

libcrypto.so.0.9.7f
libssl.so.0.9.7f

I have tried the following remedies, all to no avail.

Copying both files in the directories they are in and renaming the copies to get rid of the "f" - says it still cant find them

Creating a link to both files in the same directories and remaing the link without the "f" - says it still can't find them

Installing the 0.9.7 version of openSSL - "A newer version of 'openssl' is currently installed"

Can anyone help me either get the old version on my computer or tell xsupplicant to look for the new version in the dependency check? this is really maddening... it should work if I have a

newer version than required... shouldn't it?

Anyway. thanks a bunch for helping my n00b self.
 
Old 09-05-2005, 12:48 AM   #2
racyrefinedraj
LQ Newbie
 
Registered: Sep 2005
Posts: 3

Original Poster
Rep: Reputation: 0
alright, fixed it myself. all it took was compiling from source

Now I can't seem to get xsupplicant working properly. It seems to be drawing an IP and WEP key, but no webpages, no pinging, nothing.

anybody know much about xsupplicant?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Different versions of Linux bits4linux Linux - Newbie 1 10-27-2005 02:29 AM
Can't install Xsupplicant ozymandias Linux - Networking 0 10-22-2005 12:56 PM
how to install new versions of glib? gobi_dgm Linux - Newbie 2 02-07-2005 11:53 PM
autoloading dependent modules saajii Programming 1 09-15-2004 12:04 AM
two dependent rpms pasalacqua128 Linux - Software 1 06-14-2004 02:54 PM


All times are GMT -5. The time now is 01:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration